[RELEASE] YouTube (Video) Plugin - De facto default standard YouTube Addon for XBMC

  Thread Rating:
  • 23 Votes - 4.22 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
HenrikDK Offline
Skilled Python Coder
Posts: 539
Joined: Jul 2007
Reputation: 18
Post: #31
theuni Wrote:Keep in mind, we'll not be able to include it into the official repo if it includes rtmpe. You know, because of our (my) backwards laws.

TheUni

We don't include any lib's related to rtmpe, or swf verification. We only extract the url included in the video page from YouTube and pass it on to xbmc which does the rest of the work. Would this still preclude the plugin from entry to the official repo?

/HenrikDK
find quote
poserdonut Offline
Senior Member
Posts: 101
Joined: Jun 2009
Reputation: 0
Post: #32
When I try to login I get the following notification (it might not be exactly this
"Login failed: urllib2.urlerror instance at 0xafa67faf3034" where the last 0xa etc. part changes every time.


http://pastebin.com/0i2uGsZF
find quote
theuni Offline
Team-XBMC Communication Manager
Posts: 1,105
Joined: Oct 2007
Reputation: 2
Location: Atlanta, Ga, USA
Post: #33
HenrikDK Wrote:We don't include any lib's related to rtmpe, or swf verification. We only extract the url included in the video page from YouTube and pass it on to xbmc which does the rest of the work. Would this still preclude the plugin from entry to the official repo?

/HenrikDK

Basically, xbmc provides rtmpe for you to use. That's your business.

As soon as we provide rtmpe+implementation we're empowering dmca circumvention. So unfortunately, if your addon uses rtmpe, it cannot be included in our repo.

Stupid? Yes.

TheUni
find quote
TobiasTheCommie Offline
Skilled Python Coder
Posts: 617
Joined: Apr 2008
Reputation: 4
Post: #34
theuni Wrote:Basically, xbmc provides rtmpe for you to use. That's your business.

As soon as we provide rtmpe+implementation we're empowering dmca circumvention. So unfortunately, if your addon uses rtmpe, it cannot be included in our repo.

Stupid? Yes.

TheUni

Would you accept that we have it supported in our development version available from our own site and/or another repository, but with the rtmpe disabled in your repo?
find quote
theuni Offline
Team-XBMC Communication Manager
Posts: 1,105
Joined: Oct 2007
Reputation: 2
Location: Atlanta, Ga, USA
Post: #35
TobiasTheCommie Wrote:Would you accept that we have it supported in our development version available from our own site and/or another repository, but with the rtmpe disabled in your repo?

Sure, that's pretty much ideal.

And don't say "would you accept", because trust me... we don't like this at all Smile.

TheUni
find quote
akawoj Offline
Junior Member
Posts: 10
Joined: Jul 2010
Reputation: 0
Post: #36
I have problems with install ,can anyone help?

The plugin is unpacked into: ~/.xbmc/plugins/video/plugin.video.youtube.beta
In XBMC going into videos-plugins gives me plugins list, I can see plugin.video.youtube.beta, but when I'm trying to launch it I get an error.

I'm using stable live release of XBMC

regards
Woj
find quote
TobiasTheCommie Offline
Skilled Python Coder
Posts: 617
Joined: Apr 2008
Reputation: 4
Post: #37
akawoj Wrote:I have problems with install ,can anyone help?

The plugin is unpacked into: ~/.xbmc/plugins/video/plugin.video.youtube.beta
In XBMC going into videos-plugins gives me plugins list, I can see plugin.video.youtube.beta, but when I'm trying to launch it I get an error.

I'm using stable live release of XBMC

regards
Woj

"an error" is way to vague for us to be of any help.

Please enable debug log in XBMC.

Restart XBMC to get a clean log.

And upload the log file ~/.xbmc/temp/xbmc.log to http://pastebin.ca/upload.php and give us the url.

Then we might be able to be of assistance.
find quote
HenrikDK Offline
Skilled Python Coder
Posts: 539
Joined: Jul 2007
Reputation: 18
Post: #38
akawoj Wrote:I have problems with install ,can anyone help?

The plugin is unpacked into: ~/.xbmc/plugins/video/plugin.video.youtube.beta
In XBMC going into videos-plugins gives me plugins list, I can see plugin.video.youtube.beta, but when I'm trying to launch it I get an error.

I'm using stable live release of XBMC

regards
Woj

From the home page
http://code.google.com/p/youtubexbmc/

"In order to use this plugin you will need the upcoming Dharma release of XBMC. The latest stable 9.11 version will not work."
find quote
HenrikDK Offline
Skilled Python Coder
Posts: 539
Joined: Jul 2007
Reputation: 18
Post: #39
It's release time again, as we're trying to knock all the bugs out of this plugin.

What's new:
- Added refinements of searches, allowing you to limit searches to specific users
- Searches now jump to top every time they're run so you don't loose those frequent searches to the limit monster
- Added queue folder support, for non-recursive user folders like playlists and favorites
- Fixed RTMP support (and hopefully SWF Verification)
- Hopefully improved login debugging.

As always the latest version is on the plugin home page:

http://code.google.com/p/youtubexbmc/
(This post was last modified: 2010-08-24 00:22 by HenrikDK.)
find quote
TobiasTheCommie Offline
Skilled Python Coder
Posts: 617
Joined: Apr 2008
Reputation: 4
Post: #40
Now grasshoppers, remember the rules.

Break it if you can. But please provide a debug log if you succeed Wink

And hopefully we can soon destroy this login bug.
find quote
Flomaster Offline
Posting Freak
Posts: 1,287
Joined: Jun 2010
Reputation: 6
Location: East Texas
Post: #41
to install I just go to addons and select install from zip?


-=Jason=-
find quote
procrastinator Offline
Fan
Posts: 443
Joined: Aug 2008
Reputation: 4
Location: UK
Post: #42
well, I found a few minutes to have another go at posting the debug log again. I downloaded and installed the latest version of the plugin from the Google code page (uploaded at about 11pm GMT), and then ran the same test as I described in my first post on this thread. Same problems occured I'm afraid.

debug log: http://pastebin.com/116uXc9z

Hope it's useful. Best of luck!
find quote
procrastinator Offline
Fan
Posts: 443
Joined: Aug 2008
Reputation: 4
Location: UK
Post: #43
Quote:to install I just go to addons and select install from zip?

Yep, that should work. Can be done for updates as well as new addon installs
find quote
akawoj Offline
Junior Member
Posts: 10
Joined: Jul 2010
Reputation: 0
Post: #44
HenrikDK Wrote:From the home page
http://code.google.com/p/youtubexbmc/

"In order to use this plugin you will need the upcoming Dharma release of XBMC. The latest stable 9.11 version will not work."


Upss,

Thanks, I didn't noticed,

regards
WOJ
find quote
Robotica Offline
Banned
Posts: 1,202
Joined: Aug 2010
Post: #45
Any change this plugin is working on a XBOX? Or could be reworked a little to work?
find quote
Post Reply