Set time and date in Xbmc live.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Chegz254 Offline
Junior Member
Posts: 12
Joined: Aug 2010
Reputation: 0
Post: #1
This question is to anyone. Is there a way to change the time and date in xbmc live?
find quote
DougJ Offline
Junior Member
Posts: 18
Joined: Dec 2009
Reputation: 0
Location: Bethesda, MD
Post: #2
Yes,

http://wiki.xbmc.org/index.php?title=App...e_Settings

please read and do us that favor.
find quote
bobb09 Offline
Junior Member
Posts: 5
Joined: Jul 2010
Reputation: 0
Post: #3
DougJ Wrote:Yes,

http://wiki.xbmc.org/index.php?title=App...e_Settings

please read and do us that favor.
DougJ

Is there really any reason to flame a user for a simple question. Give the guy a break its a reasonable question. The forum is here for a reason to support everyone that loves XBMC and people that are new to XBMC.

bobb09
find quote
Chegz254 Offline
Junior Member
Posts: 12
Joined: Aug 2010
Reputation: 0
Post: #4
DougJ Wrote:Yes,

http://wiki.xbmc.org/index.php?title=App...e_Settings

please read and do us that favor.

Are you sure? I want to change the system time and date, not the region. When I set the region to Africa/Nairobi, the clock is ahead by 3 hrs. when i go online, it is synced to the time server. When I reboot then disconnect, The clock is then ahead by 3 hrs.
find quote
DougJ Offline
Junior Member
Posts: 18
Joined: Dec 2009
Reputation: 0
Location: Bethesda, MD
Post: #5
bobb09,
agreed. point well taken.

Chegz254,
have you checked the bios clock settings? are they correct? I have my region set to my timezone (I am in DC) and wheather I connected to the internet or not I get an accurate date and time.

Btw what hardware are you running?
find quote
Hannes The Hun Offline
Posting Freak
Posts: 1,217
Joined: May 2009
Reputation: 3
Post: #6
the thing is: I have no idea if chegz is running minimal ubuntu with XBMC on top or desktop ubuntu (add.: okay it's in thread title...). usually when installing you tell ubuntu your timezone and from then on all the date/timezone stuff incl. ntp updates are done by the underlying system if there's a working internet connection. the options in xbmc are mostly regional and just for fun also include time settings in case they're different from what was given at installation and/or in the ubuntu desktop.

chances are chegz is running XBMCbuntu but during setup entered a wrong time zone. this is why the clock always reverts after every reboot. so one needs to find out what steps need to be done in the underlying system (i.e. ubuntu linux) via the terminal or SSH console to get the correct time zone. and again, google comes to the rescue!

XBMCbuntu Frodo --> Foxconn Netbox 330i --> Onkyo TX-NR709 --> Sharp Aquos LC-46XD1E
XBMCbuntu FAQ <-- answers 99% of your questions.
Forum Search answers the rest.
(This post was last modified: 2010-08-25 19:25 by Hannes The Hun.)
find quote
trolly Offline
Junior Member
Posts: 34
Joined: Jan 2007
Reputation: 0
Location: Alsace, France
Post: #7
According to ubuntu doc

Using the Command Line (terminal)

Using the command line, you can use dpkg-reconfigure tzdata.

1. Open a terminal window by going to Applications>Accessories>Terminal
2. dpkg-reconfigure tzdata
3. Follow the directions in the terminal.
find quote
Chegz254 Offline
Junior Member
Posts: 12
Joined: Aug 2010
Reputation: 0
Post: #8
DougJ Wrote:bobb09,
agreed. point well taken.

Chegz254,
have you checked the bios clock settings? are they correct? I have my region set to my timezone (I am in DC) and wheather I connected to the internet or not I get an accurate date and time.

Btw what hardware are you running?

I installed xbmc live on usb. The laptop I use is hp pavillion dv6000, MS Vista, 1 gb ram, intel mobility 945 family chipset. The bios time is set correctly (GMT +3)(Nairobi).
find quote
Chegz254 Offline
Junior Member
Posts: 12
Joined: Aug 2010
Reputation: 0
Post: #9
@trolly, I'll try out the commands and see if they work for me in the intel GPU safe mode.
(This post was last modified: 2010-08-26 07:52 by Chegz254.)
find quote
Chegz254 Offline
Junior Member
Posts: 12
Joined: Aug 2010
Reputation: 0
Post: #10
trolly Wrote:According to ubuntu doc

Using the Command Line (terminal)

Using the command line, you can use dpkg-reconfigure tzdata.

1. Open a terminal window by going to Applications>Accessories>Terminal
2. dpkg-reconfigure tzdata
3. Follow the directions in the terminal.

trolly, when I used this command, it only changed the time zone, not the time and date.

In case any of you are wondering, i am using the live cd on an usb.
find quote