XBMC doesn't start on Mac Mini PPC

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
svassie Offline
Junior Member
Posts: 2
Joined: Sep 2010
Reputation: 0
Post: #1
Hi, I'm looking for some help.

I have a ppc mac mini and I'm trying to get XBMC to work. I downloaded the 9.11 version for ppc and installed it by moving it to my applications folder.

I'm running OSX 10.5.8 and when I open XBMC it sort of starts in the dock and then exits. Here is the output of the console log and the XBMC log:


02/09/2010 22:52:32 XBMCHelper[271] XBMCHelper 0.7 starting up...
02/09/2010 22:52:32 [0x0-0x1a01a].com.teamxbmc.xbmc[267] 2010-09-02 22:52:32.951 XBMCHelper[271:10b] XBMCHelper 0.7 starting up...
02/09/2010 22:52:33 XBMCHelper[271] [DEBUG] Driver has started successfully.
02/09/2010 22:52:33 [0x0-0x1a01a].com.teamxbmc.xbmc[267] 2010-09-02 22:52:33.025 XBMCHelper[271:10b] [DEBUG] Driver has started successfully.
02/09/2010 22:52:33 [0x0-0x1a01a].com.teamxbmc.xbmc[267] 2010-09-02 22:52:33.027 XBMCHelper[271:10b] [ERROR] Driver has not found any remotes it could use. Will use remotes as they become available.
02/09/2010 22:52:33 XBMCHelper[271] [ERROR] Driver has not found any remotes it could use. Will use remotes as they become available.
02/09/2010 22:52:33 XBMC[267] invalid pixel format
02/09/2010 22:52:33 XBMC[267] invalid context
02/09/2010 22:52:33 [0x0-0x1a01a].com.teamxbmc.xbmc[267] ERROR: Unable to create application. Exiting
02/09/2010 22:52:33 [0x0-0x1a01a].com.teamxbmc.xbmc[267] Asking helper to start.
02/09/2010 22:52:33 com.apple.launchd[110] ([0x0-0x1a01a].com.teamxbmc.xbmc[267]) Stray process with PGID equal to this dead job: PID 271 PPID 1 XBMCHelper
02/09/2010 22:52:33 com.apple.launchd[110] ([0x0-0x1a01a].com.teamxbmc.xbmc[267]) Exited with exit code: 255
02/09/2010 22:52:33 com.apple.launchd[110] ([0x0-0x1a01a].com.teamxbmc.xbmc[267]) Exited with exit code: 255




22:52:32 T:2692204576 M:632942592 NOTICE: -----------------------------------------------------------------------
22:52:32 T:2692204576 M:632922112 NOTICE: Starting XBMC, Platform: Mac OS X. Built on Dec 26 2009 (SVN:26018)
22:52:32 T:2692204576 M:632922112 NOTICE: special://xbmc/ is mapped to: /Applications/XBMC.app/Contents/Resources/XBMC
22:52:32 T:2692204576 M:632922112 NOTICE: special://masterprofile/ is mapped to: /Users/stewartvassie/Library/Application Support/XBMC/userdata
22:52:32 T:2692204576 M:632922112 NOTICE: special://home/ is mapped to: /Users/stewartvassie/Library/Application Support/XBMC
22:52:32 T:2692204576 M:632922112 NOTICE: special://temp/ is mapped to: /Users/stewartvassie/.xbmc/temp
22:52:32 T:2692204576 M:632922112 NOTICE: The executable running is: /Applications/XBMC.app/Contents/MacOS/XBMC
22:52:32 T:2692204576 M:632922112 NOTICE: Log File is located: /Users/stewartvassie/Library/Logs/xbmc.log
22:52:32 T:2692204576 M:632922112 NOTICE: -----------------------------------------------------------------------
22:52:32 T:2692204576 M:632909824 NOTICE: Setup SDL
22:52:32 T:2692204576 M:632639488 INFO: Drives are mapped
22:52:32 T:2692204576 M:632639488 NOTICE: load settings...
22:52:32 T:2692204576 M:632627200 NOTICE: special://profile/ is mapped to: special://masterprofile/
22:52:32 T:2692204576 M:632627200 NOTICE: loading special://masterprofile/guisettings.xml
22:52:32 T:2692204576 M:632508416 NOTICE: Getting hardware information now...
22:52:32 T:2692204576 M:632504320 INFO: Using analog output
22:52:32 T:2692204576 M:632504320 INFO: AC3 pass through is enabled
22:52:32 T:2692204576 M:632504320 INFO: DTS pass through is enabled
22:52:32 T:2692204576 M:632504320 NOTICE: Checking resolution 12
22:52:32 T:2692204576 M:632414208 NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
22:52:32 T:2692204576 M:632401920 DEBUG: CPlayerCoreConfig::<ctor>: created player DVDPlayer for core 1
22:52:32 T:2692204576 M:632393728 DEBUG: CPlayerCoreConfig::<ctor>: created player oldmplayercore for core 1
22:52:32 T:2692204576 M:632393728 DEBUG: CPlayerCoreConfig::<ctor>: created player PAPlayer for core 3
22:52:32 T:2692204576 M:632381440 DEBUG: CPlayerSelectionRule::Initialize: creating rule: system rules
22:52:32 T:2692204576 M:632373248 DEBUG: CPlayerSelectionRule::Initialize: creating rule: rtv
22:52:32 T:2692204576 M:632373248 DEBUG: CPlayerSelectionRule::Initialize: creating rule: hdhomerun/myth/rtmp/mms/udp
22:52:32 T:2692204576 M:632373248 DEBUG: CPlayerSelectionRule::Initialize: creating rule: lastfm/shout
22:52:32 T:2692204576 M:632373248 DEBUG: CPlayerSelectionRule::Initialize: creating rule: rtsp
22:52:32 T:2692204576 M:632373248 DEBUG: CPlayerSelectionRule::Initialize: creating rule: streams
22:52:32 T:2692204576 M:632369152 DEBUG: CPlayerSelectionRule::Initialize: creating rule: flv/aacp/sdp
22:52:32 T:2692204576 M:632369152 DEBUG: CPlayerSelectionRule::Initialize: creating rule: mp2
22:52:32 T:2692204576 M:632369152 DEBUG: CPlayerSelectionRule::Initialize: creating rule: dvd
22:52:32 T:2692204576 M:632369152 DEBUG: CPlayerSelectionRule::Initialize: creating rule: dvdfile
22:52:32 T:2692204576 M:632369152 DEBUG: CPlayerSelectionRule::Initialize: creating rule: dvdimage
22:52:32 T:2692204576 M:632369152 DEBUG: CPlayerSelectionRule::Initialize: creating rule: sdp/asf
22:52:32 T:2692204576 M:632369152 DEBUG: CPlayerSelectionRule::Initialize: creating rule: nsv
22:52:32 T:2692204576 M:632369152 NOTICE: Loaded playercorefactory configuration
22:52:32 T:2692204576 M:632369152 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
22:52:32 T:2692204576 M:632369152 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
22:52:32 T:2692204576 M:632369152 NOTICE: No advancedsettings.xml to load (special://masterprofile/advancedsettings.xml)
22:52:32 T:2692204576 M:632369152 NOTICE: Default DVD Player: dvdplayer
22:52:32 T:2692204576 M:632369152 NOTICE: Default Video Player: dvdplayer
22:52:32 T:2692204576 M:632369152 NOTICE: Default Audio Player: paplayer
22:52:32 T:2692204576 M:632352768 NOTICE: special://masterprofile/sources.xml
22:52:33 T:2692204576 M:626597888 FATAL: CApplication::Create: Unable to create window


Any suggestions you have will be gratefully received.

Thank you in advance.

Stewart
(This post was last modified: 2010-09-03 00:20 by svassie.)
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,390
Joined: Feb 2008
Reputation: 64
Post: #2
you might try the Dharma beta, see http://mirrors.xbmc.org/nightlies/osx/ppc/


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
svassie Offline
Junior Member
Posts: 2
Joined: Sep 2010
Reputation: 0
Post: #3
Thanks for the suggestion davilla.

I tried that but I got the same result. XBMC starts and then quits.

Here is the console log:

02/09/2010 23:44:57 XBMC[392] invalid pixel format
02/09/2010 23:44:57 XBMC[392] invalid context
02/09/2010 23:44:57 XBMC[392] *** _NSAutoreleaseNoPool(): Object 0x278cf40 of class SDL_QuartzWindow autoreleased with no pool in place - just leaking
Stack: (0x96e92dac 0x96dbfe14 0x906e366c 0x9dffa8 0x9e08ac 0x9d8144 0x9ad5e0 0x9ad64c 0x94ea2ac8 0x94ea2988 0xe350 0xe050)
02/09/2010 23:44:57 XBMC[392] *** _NSAutoreleaseNoPool(): Object 0x278ebb0 of class NSSelectionArray autoreleased with no pool in place - just leaking
Stack: (0x96e92dac 0x96dbfe14 0x907186a4 0x90605218 0x906f8964 0x906f88d0 0x9070b980 0x9e0900 0x9d8144 0x9ad5e0 0x9ad64c 0x94ea2ac8 0x94ea2988 0xe350 0xe050)
02/09/2010 23:44:57 XBMC[392] *** _NSAutoreleaseNoPool(): Object 0x278ebb0 of class NSSelectionArray autoreleased with no pool in place - just leaking
Stack: (0x96e92dac 0x96dbfe14 0x907186a4 0x90605218 0x906f8964 0x906f88d0 0x9070b980 0x9e0900 0x9d8144 0x9ad5e0 0x9ad64c 0x94ea2ac8 0x94ea2988 0xe350 0xe050)
02/09/2010 23:44:57 [0x0-0x2d02d].com.teamxbmc.xbmc[392] ERROR: Unable to create application. Exiting
02/09/2010 23:44:57 [0x0-0x2d02d].com.teamxbmc.xbmc[392] CRITSEC[0xeb17e0]: Trying to enter destroyed section.
02/09/2010 23:44:57 [0x0-0x2d02d].com.teamxbmc.xbmc[392] CRITSEC[0xeb17e0]: Trying to leave destroyed section.
02/09/2010 23:44:57 [0x0-0x2d02d].com.teamxbmc.xbmc[392] CRITSEC[0xeb17e0]: Trying to leave destroyed section.


and here is the (as far as I can tell) relevant line from the XBMC log:

23:44:57 T:2692204576 M:382128128 FATAL: CApplication::Create: Unable to create window

before that line everything seems OK and after that line XBMC uninstalls the items it installed at the beginning.

This may seem stupid but could this have anything to do with the fact that I'm accessing this PC via VNC? I can't see how it could be but I'm sure that the more information you have, the better.

Thanks again

Stewart
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,390
Joined: Feb 2008
Reputation: 64
Post: #4
svassie Wrote:TThis may seem stupid but could this have anything to do with the fact that I'm accessing this PC via VNC? I can't see how it could be but I'm sure that the more information you have, the better.

Ahh, yes. You need a real display connected to get a hardware accelerated opengl window. XBMC will not run if there is no physical display present. You can fake a display with a special adapter.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Russ3 Offline
Junior Member
Posts: 1
Joined: Sep 2010
Reputation: 0
Post: #5
I have a 'Apple DVI to Video Adapter' on my Mini hooked up to my tv. I still get the bouncing icon then it disappears.

Thanks!
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,390
Joined: Feb 2008
Reputation: 64
Post: #6
Russ3 Wrote:I have a 'Apple DVI to Video Adapter' on my Mini hooked up to my tv. I still get the bouncing icon then it disappears.

Thanks!

xbmc.log


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
phgalmel Offline
Junior Member
Posts: 2
Joined: Oct 2010
Reputation: 0
Location: Paris, France
Post: #7
Hello and sorry for my English...

I have the same problem with Mac Mini 2010 connected to a HD TV with the Apple HDMI to VGA in 1080i...
But if I switch the Mac resolution to 720p, XBMC start and run fine.

In 1080i, XBMC start but quit immediately. Same issue with Plex.

Tested with OS X 10.6.5 pre release.
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,390
Joined: Feb 2008
Reputation: 64
Post: #8
phgalmel Wrote:Hello and sorry for my English...

I have the same problem with Mac Mini 2010 connected to a HD TV with the Apple HDMI to VGA in 1080i...
But if I switch the Mac resolution to 720p, XBMC start and run fine.

In 1080i, XBMC start but quit immediately. Same issue with Plex.

Tested with OS X 10.6.5 pre release.

Please start a new thread, your problem has nothing to do with this one "XBMC doesn't start on Mac Mini PPC", you are running Mac Mini 2010. Also. post xbmc to a pastebin site when trying 1080i.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
phgalmel Offline
Junior Member
Posts: 2
Joined: Oct 2010
Reputation: 0
Location: Paris, France
Post: #9
Oops! Sorry.
find quote