"CDVDPlayerAudio" sometimes restarts while playing AC/3 tracks

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Hansvon Offline
Junior Member
Posts: 13
Joined: Aug 2009
Reputation: 0
Post: #1
HI,
I'm running Dharma svn 33532 on Fedora 13:
Code:
$ uname -r
   2.6.34.6-47.fc13.x86_64
$ rpm -q pulseaudio
   pulseaudio-0.9.21-6.fc13.x86_64
$ rpm -q alsa-lib
   alsa-lib-1.0.23-1.fc14.x86_64

On some of my clips, "CDVDPlayerAudio" crashes and restarts, causing audio+video to stop for a few seconds.
For example, it always happen in HBO shows, just before the HBO logo is displayed. I don't know what's wrong with the audio at this point... I've tried these clips on two different machines (but both running Fedora): always "crash" with same message.
I think all my clips that have similar problem have AC/3 audio (I'm not sure).

Here's a sample that always trigger the restart
And here's the log when this happens.

Is it a issue with Fedora? PulseAudio bug? Could someone using another distribution try?
VLC, MPlayer and Totem play the above clip without any problem...
Should I fill a bug in trac?
find quote
Hansvon Offline
Junior Member
Posts: 13
Joined: Aug 2009
Reputation: 0
Post: #2
I've just tried XBMC dharma beta1 live CD (ubuntu based) and the problem doesn't show up. So I guess something in wrong in Fedora.

Does someone know who to blame?
pulseaudio? alsa? sdl? Now, AC/3 is decoded by ffmpeg, right? On Fedora, the problem appears if I use the internal or external ffmpeg library...

I've also compiled the trunk branch on Fedora, and the problem does show up.

Any help would be appreciated!
find quote