Movie titles missing when adding or refreshing library

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
shadow5606 Offline
Junior Member
Posts: 22
Joined: Jul 2009
Reputation: 0
Post: #46
Scratch my last comment. I forgot you had to go into videos and set content to actually change your scraper. The scraper selected in settings has no effect from what I see.

Ok, for the other folks on this thread, if you're having issues with the IMDB scraper and you're confused by the process of updating the XML file or the XML update didn't work for you.....

Just switch to Themoviedb scraper

To do this you'll go to your main menu, select Videos, from there you'll highlight the source(s) where your movies are and hit C, then you'll select Set Content and change the scraper to themoviedb.org

At that point you should be able to scrape titles, thumbs, info, etc...

Olympia, thanks for the help and work on this but sometimes a simple end user with less technical background just needs a simple solution with clear direction.
find quote
thereddog Offline
Senior Member
Posts: 175
Joined: Nov 2009
Reputation: 0
Location: Buffalo, NY
Post: #47
OK....

For a XBMC on Windows, how do we update the IMDB scraper automatically?
find quote
olympia Offline
Team-Kodi Member
Posts: 2,499
Joined: May 2008
Reputation: 32
Post: #48
thereddog Wrote:OK....

For a XBMC on Windows, how do we update the IMDB scraper automatically?

There a more versions of XBMC:

Camelot: no automatic update is possible
Dharma Beta2: system menu on the main screen / add-ons
find quote
thereddog Offline
Senior Member
Posts: 175
Joined: Nov 2009
Reputation: 0
Location: Buffalo, NY
Post: #49
Thank you, I am using Camelot.

Can you link me to 2.0.8 so I can attempt to get the scraper working again?
find quote
olympia Offline
Team-Kodi Member
Posts: 2,499
Joined: May 2008
Reputation: 32
Post: #50
thereddog Wrote:Thank you, I am using Camelot.

Can you link me to 2.0.8 so I can attempt to get the scraper working again?

Scrapers are addons in Dharma, they are not compatible with Camelot. There is no 2.0.8 for Camelot.

What's wrong with imdb.xml I linked in the 4th post in this thread? It's not perfect but helps you survive until Dharma gets final. Although you'd better to upgrade to Dharma.
find quote
thereddog Offline
Senior Member
Posts: 175
Joined: Nov 2009
Reputation: 0
Location: Buffalo, NY
Post: #51
olympia Wrote:Scrapers are addons in Dharma, they are not compatible with Camelot. There is no 2.0.8 for Camelot.

What's wrong with imdb.xml I linked in the 4th post in this thread? It's not perfect but helps you survive until Dharma gets final. Although you'd better to upgrade to Dharma.

I would upgrade to the beta, but XBMC Remote for webOS doesn't work with it I don't think.


As for the other imdb.xml file, I shut down XBMC and replaced the file, but it didn't change anything for me. I will try again later tonight when I get home though.
(This post was last modified: 2010-10-06 21:54 by thereddog.)
find quote
thereddog Offline
Senior Member
Posts: 175
Joined: Nov 2009
Reputation: 0
Location: Buffalo, NY
Post: #52
So I found two imdb.xml files under the Roaming XBMC profile and I replaced both with the file olympia linked. Reset content on my movie directory, and not a single title was fetched.
find quote
olympia Offline
Team-Kodi Member
Posts: 2,499
Joined: May 2008
Reputation: 32
Post: #53
thereddog Wrote:So I found two imdb.xml files under the Roaming XBMC profile and I replaced both with the file olympia linked. Reset content on my movie directory, and not a single title was fetched.

Because you shouldn't have replaced the one in the common folder...
find quote
thereddog Offline
Senior Member
Posts: 175
Joined: Nov 2009
Reputation: 0
Location: Buffalo, NY
Post: #54
Oops... How can I fix?
find quote
ProfHawking Offline
Junior Member
Posts: 5
Joined: Jul 2010
Reputation: 0
Post: #55
Hitcher Wrote:Been posted many times now - use the search function.

i have the same issue, got here by a google search. could you be ever so helpful and just link to one of the afformentioned threads with a solution?

this is happening to my recently added films and i have not been able to find a fix.
find quote
petesmeat Offline
Junior Member
Posts: 1
Joined: Oct 2010
Reputation: 0
Post: #56
It seems like I'm having the same problem too. Previously all movie titles were being updated when scraping. Now it seems like all other meta-data is being updated (the description and the covers) but not the title.

I've searched the forum but can't find any other thread that has this specific problem, there are plenty of threads about file naming etc but in this case XBMC knows what the movies are but just doesn't update the title.

If there is another thread about this, could someone please point me to it - or tell me what I should search on as I've tried many different search terms without success.

Thanks.
find quote
Hitcher Offline
Skilled Skinner
Posts: 10,772
Joined: Aug 2007
Reputation: 100
Location: Eastleigh, UK
Post: #57
http://forum.xbmc.org/showthread.php?tid...lank+title
find quote
ProfHawking Offline
Junior Member
Posts: 5
Joined: Jul 2010
Reputation: 0
Post: #58
Thanks for the link Hitcher, much appreciated. I will give that fix a go!
find quote
musti Offline
Junior Member
Posts: 43
Joined: Nov 2009
Reputation: 0
Post: #59
Ooops!! I've replaced my common/imdb.xml with the new file, apparently you aren't supposed to this! Can someone post the common/imdb.xml for Camelot please? Thanks.
Jonathan
find quote
olympia Offline
Team-Kodi Member
Posts: 2,499
Joined: May 2008
Reputation: 32
Post: #60
musti Wrote:Ooops!! I've replaced my common/imdb.xml with the new file, apparently you aren't supposed to this! Can someone post the common/imdb.xml for Camelot please? Thanks.
Jonathan

https://xbmc.svn.sourceforge.net/svnroot...n/imdb.xml
find quote