Nvidia Geforce 9500 GT TV-out via the s-video [Solved!]

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Locutusweb Offline
Junior Member
Posts: 23
Joined: Aug 2010
Reputation: 0
Post: #1
After many long nights pulling my hair out and at the virtue of quiting. I finally got my Nvidia Geforce 9500 GT TV-out via the s-video output working!Laugh

I post here my /etc/X11/xorg.conf. Hopefully I can help someone with it:

(Please change setting: Option "TVStandard" according your country. See this page: https://help.ubuntu.com/community/NvidiaTVOut on the bottom)

Code:
# nvidia-settings: X configuration file generated by nvidia-settings

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       28.0 - 55.0
    VertRefresh     43.0 - 72.0
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
    Option         "DPI" "100x100"
    Option         "UseEvents" "1"
    Option         "AddARGBVisuals" "1"
    Option         "AddARGBGLXVisuals" "1"
    Option         "NoLogo" "1"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9500 GT"
    Option         "TVStandard" "PAL-B"
    Option         "TVOutFormat" "SVIDEO"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select" "1920x1080" "1280x720" "1024x768" "720x480" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0, TV: nvidia-auto-select +0+0; CRT: 1024x768 +0+0, TV: nvidia-auto-select +0+0; CRT: 800x600 +0+0, TV: nvidia-auto-select +0+0; CRT: 640x480 +0+0, TV: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

This morning I booted my XBMC again: you won't believe it. The dreaded black and white screen. Aaarrgh! In hind sight it was too easy; the s-video connector got a little bit loose. Pfiew!
find quote
nonob Offline
Senior Member
Posts: 102
Joined: Sep 2011
Reputation: 0
Post: #2
Hi,

Thanks for this tip.

It works fine for me but i don't have display as soon as my computer boot but only a few seconds later (i don't have preboot infos displayed).
Do you know how can i display that ?

thanks
find quote