[Live - DHb3] Immediate start after suspend

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
pita_lbc Offline
Junior Member
Posts: 3
Joined: Oct 2010
Reputation: 0
Post: #1
Hello,
I have HTPC with Pegatron motherboard IPX7A (Atom330+ION). I have Live Dharma beta 3 installed. I am not able to put the computer to sleep mode. According to log, I see, that the PC is going to sleep, but it starts again immediately:

14:20:29 T:3079092096 M:2997481472 DEBUG: DBus: Creating message to org.freedesktop.UPower on /org/freedesktop/UPower with interface org.freedesktop.UPower and method AboutToSleep
14:20:29 T:3079092096 M:2997481472 DEBUG: DBus: Creating message to org.freedesktop.UPower on /org/freedesktop/UPower with interface org.freedesktop.UPower and method Suspend
14:20:29 T:3079092096 M:2997481472 DEBUG: CAnnouncementManager - Announcement: Suspend from xbmc
14:20:29 T:3079092096 M:2997481472 DEBUG: CAnnouncementManager - Announcement: Sleep from xbmc
14:20:29 T:3079092096 M:2997481472 NOTICE: OnSleep: Running sleep jobs
14:20:29 T:3079092096 M:2997481472 ERROR: XLCDproc::SetBackLight - Unable to write to socket
14:20:31 T:3079092096 M:2996973568 DEBUG: CAnnouncementManager - Announcement: Wake from xbmc
14:20:31 T:3079092096 M:2996973568 NOTICE: OnWake: Running resume jobs
14:20:31 T:3079092096 M:2996973568 ERROR: GLX: Same window as before, refreshing context
14:20:31 T:3079092096 M:2996973568 INFO: GL: Maximum texture width: 8192
14:20:31 T:3079092096 M:2998972416 ERROR: GLX: Same window as before, refreshing context
14:20:31 T:3079092096 M:2998972416 INFO: GL: Maximum texture width: 8192
14:20:31 T:3079092096 M:2997194752 NOTICE: OnWake: Restarting lirc
14:20:31 T:3079092096 M:2997194752 NOTICE: OnWake: Restarting lcd
14:20:31 T:3079092096 M:2997194752 ERROR: XLCDproc::SetBackLight - Unable to write to socket
14:20:31 T:3079092096 M:2997194752 DEBUG: CAnnouncementManager - Announcement: Resume from xbmc
14:20:31 T:3004533616 M:2996862976 DEBUG: thread start, auto delete: 1

I found these threads:
http://forum.xbmc.org/showthread.php?tid=82741
http://forum.xbmc.org/showthread.php?tid=61172&page=6

but nothing helps.

Please, somebody has some idea or hint? I have already tried system updates.

Thanks for reply

Pita
find quote
speed32219 Offline
Fan
Posts: 410
Joined: Feb 2007
Reputation: 0
Post: #2
On Karmic 9,1 you had to Disable Usbcore Autosuspend by adding a entry into grub.


Add a boot option to grub to disable the usbcore autosuspend. This bug exhibits itself as immediately waking after suspension.

Edit /etc/default/grub and add usbcore.autosuspend=-1 to GRUB_CMDLINE_LINUX_DEFAULT. Example:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash xbmc=autostart,noredir usbcore.autosuspend=-1"

Update grub:

sudo update-grub

The above info taken directly from the wiki.

Try a serach for XBMC suspend resume wiki. Google is amazing sometimes.
That also applies to WOL.

Note, I'm running Karmic 9.1 so if your on Marverick, expect it to not work. Like a bucking maverick at a rodeo. Smile

Good luck.

FYI, I decided to try a live version DAH3 and have the same problem. I can shut down and suspend from terminal using cli but not from the live version. I am doing some more testing.
(This post was last modified: 2010-10-23 10:57 by speed32219.)
find quote
speed32219 Offline
Fan
Posts: 410
Joined: Feb 2007
Reputation: 0
Post: #3
Here is what I've done to get my Zotac Ion working with XBMClive DAH3. (This is with Lucid OS, latest XBMClive)
If you follow these steps you should have suspend/Wake using your remote.

Code:
Cmd for using nano or use what you are comfortable with
(CTRL O to write and Ctrl X to exit)

sudo nano /etc/PolicyKit/PolicyKit.conf  

ADD:
<config version="0.1">
    <match user="root">
        <return result="yes"/>
    </match>
    <match user="YOUR_USER_NAME">
        <return result="yes"/>
    </match>
    <define_admin_auth group="admin"/>
</config>

Make sure you change to your xbmc user login name above.

sudo apt-get install policykit pm-utils policykit-1 upower

sudo nano /var/lib/polkit-1/localauthority/50-local.d/custom-actions.pkla  

ADD:
[Actions for xbmc user]
Identity=unix-user:xbmc
Action=org.freedesktop.upower.*;org.freedesktop.consolekit.system.*
ResultActive=yes
ResultAny=auth_admin
ResultInactive=yes

Save and remember to change unix-user to your xbmc login name.

sudo apt-get remove policykit-1
THat was the[b] key for me[/b].

sudo nano /etc/default/grub
Add:

usbcore.autosuspend=-1      like the following:

#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash xbmc=autostart,nodiskmount,setvolume loglevel=0"
[b]GRUB_CMDLINE_LINUX="usbcore.autosuspend=-1"[/b]

Save:

sudo update-grub

sudo apt-get install hal  

Remember to change [b]xbmc_user_name [/b]below to your xbmc user name if different. All of them, one per line.

sudo polkit-auth --[b]user xbmc_user_name [/b]--grant org.freedesktop.hal.power-management.suspend
sudo polkit-auth --[b]user xbmc_user_name[/b] --grant org.freedesktop.hal.power-management.hibernate
sudo polkit-auth --[b]user xbmc_user_name [/b]--grant org.freedesktop.hal.power-management.reboot
sudo polkit-auth --user xbmc_user_name --grant org.freedesktop.hal.power-management.shutdown
sudo polkit-auth --user xbmc_user_name --grant org.freedesktop.hal.power-management.reboot-multiple-sessions
sudo polkit-auth --user xbmc_user_name --grant org.freedesktop.hal.power-management.shutdown-multiple-session

[b]REBOOT[/b]:

Now to find out which USB port will Wake up from suspend.  You should now be able to shutdown/suspend
if you have your shutdown set to suspend in the system_settings under power.

cat /proc/acpi/wakeup
Here is mine from an Zotac Ion 330

cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
SMB0      S4     disabled  pci:0000:00:03.2
USB0      S4     disabled  pci:0000:00:04.0
USB2      S4     disabled  pci:0000:00:04.1
US15      S4     enabled   pci:0000:00:06.0
US12      S4     disabled  pci:0000:00:06.1
NMAC      S5     disabled  pci:0000:00:0a.0
PBB0      S4     disabled  pci:0000:00:09.0
HDAC      S4     disabled  pci:0000:00:08.0
XVR0      S4     disabled  pci:0000:00:0c.0
XVR1      S4     disabled
P0P5      S4     disabled
P0P6      S4     disabled  pci:0000:00:15.0
P0P7      S4     disabled  pci:0000:00:16.0
P0P8      S4     disabled  pci:0000:00:17.0
P0P9      S4     disabled  pci:0000:00:18.0
PWRB      S4    *enabled

US15 was the device for my MB/IR combo, you can start at USB0, USB2, US15, US12, etc until
it powers up after you power into suspend.


All these steps except for removing policykit-1 after writing out the PKLA can be found at
http://wiki.xbmc.org/index.php?title=Ubuntu_Suspend_/_Wake.

Good Luck, and until the next release Maverick which should fix things right. Right? NOT!
(This post was last modified: 2010-10-25 14:37 by speed32219.)
find quote
pita_lbc Offline
Junior Member
Posts: 3
Joined: Oct 2010
Reputation: 0
Post: #4
Thanks for your support. I have downgraded to Live Dharma beta 2, where I had no problem.
I will try your hints this weekend. Thank you very much

Pita
find quote