audio delay at .asoundrc level

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bfix Offline
Junior Member
Posts: 4
Joined: Jun 2010
Reputation: 0
Question  audio delay at .asoundrc level
Post: #1
Hi guys

I hope one of you can help me, or point me in the right direction.

My situation is this:
I have an AsRock 330 connected to an Samsung plasma, and to a Denon receiver.
The TV is connected via HDMI and the receiver via optical.

My problem is that the TV introduces a 185ms delay between picture on the TV and receiver. If I use only TV and audio via the TV things are in sync.

I was wondering if it is possible to add a delay on the optical out in .asoundrc configuration. This would solve the lipsync issues I have. If it is possible, which commands would I use? (I'm a complete Linux novice, so an example would perfect)


Thanks in advance
find quote
prae5 Offline
Team-XBMC Forum Moderator
Posts: 2,072
Joined: Jan 2009
Reputation: 34
Location: Cambridge, UK
Post: #2
Not sure if you can tackle this via asound and to be honest its not where I would look at doing it. Your receiver should be able to do this, you should be able to set the audio delay of the input the asrock is connected to.
find quote
bfix Offline
Junior Member
Posts: 4
Joined: Jun 2010
Reputation: 0
Post: #3
Thank you.

To be honest I didn't think that my receiver had that option. I therefore always used the delay audio within xbmc. But after studying the manual I've found it.
find quote
fjgalesloot Offline
Junior Member
Posts: 3
Joined: Jun 2011
Reputation: 0
Post: #4
Hi bfix,

Sorry to comment on this somewhat older post. I'm trying to do the same, but cannot find how to do it system wide for a specific output. Did you manage to do this by delaying the output, or set your receiver to delay the input?
find quote
DaMizZa Offline
Senior Member
Posts: 110
Joined: Dec 2010
Reputation: 2
Location: Saskatchewan, Canada
Post: #5
It may be ugly, but couldn't you go to the audio settings via the Video OSD and set the audio delay, then apply it to all movies? Or does the audio delay in that menu not go far enough?

XBMCbuntu {Frodo} - Ubuntu 12.04 (Main):
Intel Q6600 [2.4GHz Quad Core], 4GB DDR3, nVidia GT-210, Antec Fusion Case (iMon LCD), PS3 BD Remote

XBMC Live {Frodo} - Ubuntu 10.04 (Bedroom): Intel Atom D510 [1.66GHz Dual Core], ION Graphics, 2GB DDR2, PS3 BD Remote
find quote