Release - Forum Browser - Programs Addon

  Thread Rating:
  • 5 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ruuk Offline
Skilled Python Coder
Posts: 1,498
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #136
(2012-04-05 23:06)dj_gerbil Wrote:  
(2012-04-05 22:22)ruuk Wrote:  
(2012-04-05 22:14)dj_gerbil Wrote:  It was earlier, but now no, it seems not to be green Sad

Well what I need to know is if it was green before you posted, then you posted, and then immediately after it was green or not. I'm trying to find out if the the session is staying logged in. It can after time expire, but what I'm wondering is if you are logging in and that is not being carried on to the next request at all.

Ok, sorry I just reread my comment and it was a little vague. When I first opened the Forum Browser after installing it the light was Green. I tried to post and got the error messages. I exited XBMC and went back to what I was doing when your next email came in and went back into XBMC and the light was grey.

What I'd like you to do is start forum browser and go to this forum. See if it turns green. Then attempt to do a post. Come back to the main window and see if it is still green. I need to know if it is staying green through the whole posting process, or if it's becoming not logged in before the actual post.

[Image: sig.jpg]
find quote
dj_gerbil Offline
Fan
Posts: 544
Joined: Jan 2009
Reputation: 10
Location: Cambridgeshire
Post: #137
Ok, It wasn't showing the green light so I uninstalled both the web-browser and the forum-browser addons, and removed any data and settings, reinstalled both and relaunched the web-browser addon. I set my username and password but no green light. Tried to post, but same error as earlier. I've posted my log here if you want it Smile

The new home for TVCatchup's XBMC plugin is in the Official TVCatchup Repository. Download it Here
If you're having trouble with any of the TVCatchup Plugins please visit here and submit your log to help us fix it.
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,498
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #138
(2012-04-06 00:14)dj_gerbil Wrote:  Ok, It wasn't showing the green light so I uninstalled both the web-browser and the forum-browser addons, and removed any data and settings, reinstalled both and relaunched the web-browser addon. I set my username and password but no green light. Tried to post, but same error as earlier. I've posted my log here if you want it Smile

I'm gonna have to put some more low level debugging in because I think something is going on below the surface. When I get on this forum the green indicator comes on and stays on and I can post just fine. I can't for the life of me figure out why it's not working for you. I can't test TVCatchup because I can't register there, since I'm not in the UK.

Anyway, I'll work on something that will give more info when testing.

[Image: sig.jpg]
(This post was last modified: 2012-04-06 01:28 by ruuk.)
find quote
dj_gerbil Offline
Fan
Posts: 544
Joined: Jan 2009
Reputation: 10
Location: Cambridgeshire
Post: #139
(2012-04-06 01:27)ruuk Wrote:  
(2012-04-06 00:14)dj_gerbil Wrote:  Ok, It wasn't showing the green light so I uninstalled both the web-browser and the forum-browser addons, and removed any data and settings, reinstalled both and relaunched the web-browser addon. I set my username and password but no green light. Tried to post, but same error as earlier. I've posted my log here if you want it Smile

I'm gonna have to put some more low level debugging in because I think something is going on below the surface. When I get on this forum the green indicator comes on and stays on and I can post just fine. I can't for the life of me figure out why it's not working for you. I can't test TVCatchup because I can't register there, since I'm not in the UK.

Anyway, I'll work on something that will give more info when testing.

If you want I have a test account I can give you access to so you can try TVCatchup. I can't let you have mine as I'm a mod over then and I think I'd get shot lol

The new home for TVCatchup's XBMC plugin is in the Official TVCatchup Repository. Download it Here
If you're having trouble with any of the TVCatchup Plugins please visit here and submit your log to help us fix it.
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,498
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #140
(2012-04-06 01:31)dj_gerbil Wrote:  
(2012-04-06 01:27)ruuk Wrote:  
(2012-04-06 00:14)dj_gerbil Wrote:  Ok, It wasn't showing the green light so I uninstalled both the web-browser and the forum-browser addons, and removed any data and settings, reinstalled both and relaunched the web-browser addon. I set my username and password but no green light. Tried to post, but same error as earlier. I've posted my log here if you want it Smile

I'm gonna have to put some more low level debugging in because I think something is going on below the surface. When I get on this forum the green indicator comes on and stays on and I can post just fine. I can't for the life of me figure out why it's not working for you. I can't test TVCatchup because I can't register there, since I'm not in the UK.

Anyway, I'll work on something that will give more info when testing.

If you want I have a test account I can give you access to so you can try TVCatchup. I can't let you have mine as I'm a mod over then and I think I'd get shot lol

That would be great. It would help to verify that whether I can login there and also if you have any other issues once we get this fixed.

[Image: sig.jpg]
find quote
dj_gerbil Offline
Fan
Posts: 544
Joined: Jan 2009
Reputation: 10
Location: Cambridgeshire
Post: #141
(2012-04-06 01:47)ruuk Wrote:  That would be great. It would help to verify that whether I can login there and also if you have any other issues once we get this fixed.

I've created you an account and PM'd you the details Smile

The new home for TVCatchup's XBMC plugin is in the Official TVCatchup Repository. Download it Here
If you're having trouble with any of the TVCatchup Plugins please visit here and submit your log to help us fix it.
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,498
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #142
Version 0.9.8

Changes:
- Fixed/Changed progress bar and improved progress updating
- Added 'Enable Debug Logging' option in settings which turns on more detailed logging
- Empty forums now show a 'Empty Forum' dialog instead of the error dialog
- Fix handling of failed forum change
- Added some missing images that I removed in the last version and didn't notic. Damn the XBMC image cache! Smile

Get it here:

http://forumbrowserxbmc.googlecode.com/f...-0.9.8.zip

dj_gerbil: As I'm sure you can see I was able to post in TVCatchup. This new version has an 'Enable Debug Logging' option in the settings. Please enable that and try posting again and get me a log and hopefully we can find what's up.

[Image: sig.jpg]
find quote
dj_gerbil Offline
Fan
Posts: 544
Joined: Jan 2009
Reputation: 10
Location: Cambridgeshire
Post: #143
Yep saw your post. Still not working for me though. It looks like it's not signing me in, even though I've set the setting to allow it to do so. My log is here

The new home for TVCatchup's XBMC plugin is in the Official TVCatchup Repository. Download it Here
If you're having trouble with any of the TVCatchup Plugins please visit here and submit your log to help us fix it.
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,498
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #144
(2012-04-06 20:11)dj_gerbil Wrote:  Yep saw your post. Still not working for me though. It looks like it's not signing me in, even though I've set the setting to allow it to do so. My log is here

I think I see the problem. The debug logging for the important bit that handles saving the session cookies is not showing up. This means that that function is not being called, which means that most likely the class I'm using is different between python versions. I'll try to figure out how I can change what I'm doing so that it works regardless of what Python version is running.

If you happen to be able to figure out your python version that might be helpful. I might ask you to try another version that prints the Python version to the log if I find I need to know it.

[Image: sig.jpg]
find quote
dj_gerbil Offline
Fan
Posts: 544
Joined: Jan 2009
Reputation: 10
Location: Cambridgeshire
Post: #145
As far as I know i'm running Python 2.6 but feel free to send over a version to test.

The new home for TVCatchup's XBMC plugin is in the Official TVCatchup Repository. Download it Here
If you're having trouble with any of the TVCatchup Plugins please visit here and submit your log to help us fix it.
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,498
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #146
Version 0.9.9

Changes:
- Changed session cookie handling so it will hopefully work across python versions
- Added post count, activity and status to posts
- Changed online indicator in posts to an icon

Get it here:

http://forumbrowserxbmc.googlecode.com/f...-0.9.9.zip

(2012-04-06 21:44)dj_gerbil Wrote:  As far as I know i'm running Python 2.6 but feel free to send over a version to test.

I think this may fix your issue, if not it will log the version which I would like to know in that case Smile

[Image: sig.jpg]
find quote
dj_gerbil Offline
Fan
Posts: 544
Joined: Jan 2009
Reputation: 10
Location: Cambridgeshire
Post: #147
Ouch, that's even worse. Now it can't even load XBMC or TVC's forums. Log file's here

The new home for TVCatchup's XBMC plugin is in the Official TVCatchup Repository. Download it Here
If you're having trouble with any of the TVCatchup Plugins please visit here and submit your log to help us fix it.
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,498
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #148
(2012-04-07 00:30)dj_gerbil Wrote:  Ouch, that's even worse. Now it can't even load XBMC or TVC's forums. Log file's here

It's not as bad as all that. This confirms the problem is what I thought it was. The function that wasn't getting called is now getting called. This time there was an error because of a conflict with your python version.

This new version probably won't make it work, but the error was masking the original error so this will get the actual error. Errors are good - I prefer an error any day to a mystery behavior Smile

Please try this version and send me the log:

http://forumbrowserxbmc.googlecode.com/f...0.9.10.zip

If this doesn't work I'm going to just drop the whole module into my addon.
Test

[Image: sig.jpg]
(This post was last modified: 2012-04-08 00:53 by ruuk.)
find quote
dj_gerbil Offline
Fan
Posts: 544
Joined: Jan 2009
Reputation: 10
Location: Cambridgeshire
Post: #149
I'll have to test it tomorrow only I've got an early start and I need some sleep.

Edit: I've just tested it and still not even loading the forums. Log File's here

The new home for TVCatchup's XBMC plugin is in the Official TVCatchup Repository. Download it Here
If you're having trouble with any of the TVCatchup Plugins please visit here and submit your log to help us fix it.
(This post was last modified: 2012-04-07 07:25 by dj_gerbil.)
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,498
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #150
Version 0.9.11

This should fix (I hope) the failure to keep a login session on XBMC installs with older python versions (ie Windows)
I've also added the ability to edit posts. It works but for some reason when you save the post it un-subscribes you from the thread in this forum. I tried from my phone with the same result so it's not the addon.

Changes:
- Fix for xmlrpclib for older python versions (I dropped in the whole module. Take that python 2.6!)
- Minor skin adjustments in message view for links/images overlays
- Fix progress bar not showing on posts view
- Added the ability to edit your own posts

Get it here:

http://forumbrowserxbmc.googlecode.com/f...0.9.11.zip

[Image: sig.jpg]
find quote
Post Reply