Release - Forum Browser - Programs Addon

  Thread Rating:
  • 5 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ruuk Offline
Skilled Python Coder
Posts: 1,508
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #301
test3

test 4

test 5

[Image: sig.jpg]
(This post was last modified: 2012-05-08 23:27 by ruuk.)
find quote
hasselhof Offline
Donor
Posts: 578
Joined: Jul 2008
Reputation: 34
Location: UK
Post: #302
Hi ruuk

I've done some more testing :-

Help for message view is working ok
Version number is a great addition
With mouse support off, the image viewer focus now works a treat, and the red cross dissappears & pictures that I previously couldn't see I can now, in the dark skin thanks.
Skin default option has now gone Smile
Image viewer help is ok.
Activity splash at "add from online database" is working ok.
Online logo chooser is a lot better.

I've noticed that there are some images not working in forum browser, but are working from pc browser, at the following location
XBMC.org > Artwork packs > ITV Player, Demand 5, and 4OD background images......if you go to post 2, push left on full screen view these images don't show in light or dark skin, but I'm sure thay did in one on the versions of forum browser before.

XBMC hub is working great now, but im sure you know this, I think I added it to the online database, or maybe it was you, either way it works a treat.

Did you see your new PM ? .I could log in with my phone, with the details in the new PM, but not in forum browser. I will have to try and become a member with another forumrunner forum and see what happens.

Thanks ruuk for all you hard work, I love it when a new version comes out Smile
(This post was last modified: 2012-05-10 11:01 by hasselhof.)
find quote
hasselhof Offline
Donor
Posts: 578
Joined: Jul 2008
Reputation: 34
Location: UK
Post: #303
Hi ruuk

Did some testing also on windows xp, with a script error on start up one of the logs is with default settingsFrown

See logs http://homepage.ntlworld.com/john.hanselman/
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,508
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #304
Version 0.9.39

Changes:
- Tapatalk: Private message list users online statuses now show correctly
- After submitting a new post, now goes to the page with the new post and jumps to it
- Logo chooser dialog now properly gets images with '/' prefixed urls
- Fixes for issues when not using skin mods
- Finished applying custom font usage to all windows
- Changed forumrunner icon... again Smile
- Link images now work in the image viewer again, plus image viewer will now show all images (normal and link)
- Added advanced settings option to disable SSL for Forumrunner (default=true). None of the forums I've tested seem to work with it and it just causes a delay on startup

On my REPO.

All of the items on my pre-main-repo-release TODO list are done except for finishing Boxee and making a better fanart.
To anyone: While I'm working on those, please let me know of any remaining issues or bugs I should attend to before the final release.

[Image: sig.jpg]
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,508
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #305
Version 0.9.40

Changes:
- Fixed a bug on startup when an old unused setting was set

On my REPO.

(2012-05-09 22:04)hasselhof Wrote:  Did some testing also on windows xp, with a script error on start up one of the logs is with default settingsFrown

See logs http://homepage.ntlworld.com/john.hanselman/

This should fix that Smile

[Image: sig.jpg]
(This post was last modified: 2012-05-09 22:25 by ruuk.)
find quote
hasselhof Offline
Donor
Posts: 578
Joined: Jul 2008
Reputation: 34
Location: UK
Post: #306
(2012-05-09 22:24)ruuk Wrote:  Version 0.9.40

Changes:
- Fixed a bug on startup when an old unused setting was set

On my REPO.

(2012-05-09 22:04)hasselhof Wrote:  Did some testing also on windows xp, with a script error on start up one of the logs is with default settingsFrown

See logs http://homepage.ntlworld.com/john.hanselman/

This should fix that Smile
That did the trick
;-)
find quote
hasselhof Offline
Donor
Posts: 578
Joined: Jul 2008
Reputation: 34
Location: UK
Post: #307
Hi ruuk

Tapatalk private message online indicator works fine, not checked the offline status yet.
Forumrunner icon is top notchSmile Thank you.
Link images now work fine.
The new advanced setting for ssl for forumrunner I have set to off. I will look out for any speed increases at my end.
I've made myself a member on the Roobarb forum which is a forumrunner forum, and I can login no problemSmile
I noticed a web viewer update as well todaySmile

Quite intrested to see what you come up with for the fanart.



Thank you.

Just noticed when I edited my post, when hitting submit post, nothing happened.
I pressed escaped to get out of message editor, then had to click full screen post to see if edit was ok.
There wasn't any confirmation window
When I edited the same post for the second time it gave me a confirmation window

The offline indicator in the subscriptions window also works fine.

I also keep losing my subscription to the Forum browser thread.
Cant pinpoint when it goes, I think it was after I edited my post
(This post was last modified: 2012-05-10 23:04 by hasselhof.)
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,508
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #308
(2012-05-10 22:51)hasselhof Wrote:  Just noticed when I edited my post, when hitting submit post, nothing happened.
I pressed escaped to get out of message editor, then had to click full screen post to see if edit was ok.
There wasn't any confirmation window
When I edited the same post for the second time it gave me a confirmation window
I've had some issues there and done a bunch of fixes. When I get the next version up, we'll see how it works and if you still have issues, send me a log.
(2012-05-10 22:51)hasselhof Wrote:  I also keep losing my subscription to the Forum browser thread.
Cant pinpoint when it goes, I think it was after I edited my post
That's the MyBB plugin bug that I made a workaround for. My workaround basically checked if you were subscribed to the thread and then re-subscribed you after an edit. I recently realized that the data I get with the threads list wasn't reliable when it comes to it's 'is_subscribed' value. So I made a workaround for that basically gets the list of subscribed threads and checks that, but I didn't think about the MyBB plugin fix. I'll apply it to that and that should fix it.

EDIT: I was just going to fix this, and it looks like I was already doing it that way with the fix. Could you make sure the MyBB plugin fix is checked in advanced settings?

EDIT2: So I tested it and there was a bug (I got an error dialog). I fixed the bug, hopefully that was the issue.

[Image: sig.jpg]
(This post was last modified: 2012-05-11 01:29 by ruuk.)
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,508
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #309
Version 0.9.41

Changes:
- Logo chooser now also extracts images from stylesheets
- Fixed some issues with adding new/current forum
- Fixed a bug where some links were being detected as links to images when the were not
- Now properly handles [url] tags containing [img] tags (images ti the images list, and the links to the links list with a thumbnail to the image)
- Fixed some issues with context menu subscription option visibility on threads view
- Boxee: subscribe to/unsubscribe from threads and forums, plus added forums to subscriptions view
- Boxee: Create post, delete post, quote post
- Boxee: Code, HTML, PHP, color and size handling
- Added activity splashes for subscribing/unsubscribing
- Added caption to activity splash
- After many years of programming in python, I just found out "def function(x={}): self.y = x" or similar is a bad idea. Changed instances of that throughout
- In context menu, now shows name for subscribe/unsubscribe for the forum/thread you are in. example Subscribe to forum: Forum Name
- Added VBulletin forum to show off the new parsing engine used with Boxee. It works for both without any modification
- New fanart

On my REPO.

As you can see VBulletin was added. This uses the new parsing engine I made for Boxee and works without modifiaction on VBulletin. This is really just to demonstrate that it works Smile It may not be perfect on VBulletin because I did all the major testing with Boxee, but it does a pretty good job considering that. I will likely remove it for the main repo release.
One of the things I hope to do after the release is to get it working for VBulletin forums in general and make it easy for users to add VBulletin forums themselves. In the further future I may be able to do this for other forum systems. We'll see Smile

I've finished my TODO list. Now it's just bug/usability testing and issue fixing. I guess the next release will be RC1 Smile

[Image: sig.jpg]
(This post was last modified: 2012-05-11 05:06 by ruuk.)
find quote
hasselhof Offline
Donor
Posts: 578
Joined: Jul 2008
Reputation: 34
Location: UK
Post: #310
Hi ruuk

I get the following script error on start up (linux)

http://homepage.ntlworld.com/john.hanselman/xbmc.log

(I've had the clutch go on my wife's car so will be messing with that for most of the day)



Edit - test to see if forum browser subscription stays in my local list after editing post

test

test 123
(This post was last modified: 2012-05-11 17:08 by hasselhof.)
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,508
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #311
Version 0.9.42

Changes:
- None - some files were missing from the zip on the repo

On my REPO.

Don't know why some of the files were missing from the zip, weird...

[Image: sig.jpg]
find quote
hasselhof Offline
Donor
Posts: 578
Joined: Jul 2008
Reputation: 34
Location: UK
Post: #312
Hi ruuk

Have tested the new v 0.9.42, it now doesn't have a script error on startup thanks

After editing a post for the 1st 2nd 3rd times my subscription to that thread stays active on my machine, and I also get a green confirmation window Smile
Just for your info myBB plugin fix was enabled when I was losing the subscription.

There are two entries for the celeb forum on the online database by the way.

Context menu subscription captions are great and informative.

VBulletin forum is really smooth as is Boxee, great work on your new parsing engine
I couldn't on the surface find any major if any problems with the VBulletin forum, good job.

When clicking options button we get a nice solid black background, could this be taken onto the settings screen, to possibly fix the Transparency skin problem where by you can see through the layers making the screen hard to read because you can see the screen underneath (Hope that makes sence)

When adding & removing a forum to favs the confirmation window is black should it be green?
Also the following confirmation windows are all black should these be green :- "Forum removed from local list", "Forum added from online database", "Login set"?
The addition of colour to the confirmation windows etc really gives it a lift.

Boxee - I can login ok, I can post ok, I can delete post ok, Captions in activity splash are very good.
When I've logged into Boxee I have to refresh to see green light
Have to refresh to see the unsubscription of thread/post/forum
I couldn't find an edit option to edit my posts in boxee

Red contrast seems to be pulseing, from very dark red to very light red, can this be made a constant contrast, of very dark red upon very light red], (This was also like this in previous versions, maybe that was your intention)

The message editor white board when filled in with text doesn't shift up screen when full, so you are typing of the screen blind until you click done and go down to the preview pane to see your input

The fanart is a masterpiece...........but...how much of a problem would it be to have a go with the following, just to see what it would look like, if it's no good revert back to it........The forum browser square turned into a long blue icon like the rest twisted also, then all the icons halfed in length to fit more icons on screen to included the Boxee, xbmc4xbox & tvcatchup icons.?

Thanks for the great update, keep up the top work.Smile

Also inside your repo when you click your way to the screen where you can uninstall forum browser, your description still says "Translate via Google translate"
(This post was last modified: 2012-05-11 18:42 by hasselhof.)
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,508
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #313
(2012-05-11 18:32)hasselhof Wrote:  There are two entries for the celeb forum on the online database by the way.
Yeah, I improved the logo parsing and saved it to the online database. One of the problems with the database though, is that it doesn't recognize things such as http://www.site.com and site.com as the same. I'll delete the extra one. I'll doing some sort of fix to prevent those sorts of duplicates.
(2012-05-11 18:32)hasselhof Wrote:  When clicking options button we get a nice solid black background, could this be taken onto the settings screen, to possibly fix the Transparency skin problem where by you can see through the layers making the screen hard to read because you can see the screen underneath (Hope that makes sence)
The settings screen appearance is controlled by the XBMC skin, so I can't change it. I'll add a full screen overlay when opening settings which will sit under the settings.
(2012-05-11 18:32)hasselhof Wrote:  When adding & removing a forum to favs the confirmation window is black should it be green?
Also the following confirmation windows are all black should these be green :- "Forum removed from local list", "Forum added from online database", "Login set"?
Well, the idea was to only add color to things that could possibly fail. I considered the others as information. For instance making a post could fail so green on success yellow on fail and red on script error. Removing a forum from the local list should always work so the message is just information. I'll think on it though Smile
(2012-05-11 18:32)hasselhof Wrote:  When I've logged into Boxee I have to refresh to see green light
I'm assuming you mean when you add login details when already on Boxee? That's the only time I could get it not to show when set. Anyway I'll look at it
(2012-05-11 18:32)hasselhof Wrote:  Have to refresh to see the unsubscription of thread/post/forum
I'll check it out
(2012-05-11 18:32)hasselhof Wrote:  I couldn't find an edit option to edit my posts in boxee
I'll add that
(2012-05-11 18:32)hasselhof Wrote:  Red contrast seems to be pulseing, from very dark red to very light red, can this be made a constant contrast, of very dark red upon very light red], (This was also like this in previous versions, maybe that was your intention)
The transparency skin seems to pulse all buttons. I'll see if setting pulse to false in the addon skin will override that.
(2012-05-11 18:32)hasselhof Wrote:  The message editor white board when filled in with text doesn't shift up screen when full, so you are typing of the screen blind until you click done and go down to the preview pane to see your input
Unfortunately that has been a limitation of the text view in XBMC. It has a method 'scroll()' which allows you to scroll to a certain line, but I've never gotten it to work. Perhaps I will test it again and if it still doesn't work, report the bug to the XBMC team.
(2012-05-11 18:32)hasselhof Wrote:  The fanart is a masterpiece...........but...how much of a problem would it be to have a go with the following, just to see what it would look like, if it's no good revert back to it........The forum browser square turned into a long blue icon like the rest twisted also, then all the icons halfed in length to fit more icons on screen to included the Boxee, xbmc4xbox & tvcatchup icons.?
Well, I'm not going to do it before the main release, but it seems like a nice idea. If you want to gather the images for me that would help Smile

[Image: sig.jpg]
find quote
ruuk Offline
Skilled Python Coder
Posts: 1,508
Joined: Aug 2005
Reputation: 182
Location: Bremerton, WA USA
Post: #314
(2012-05-11 18:32)hasselhof Wrote:  Have to refresh to see the unsubscription of thread/post/forum

Not sure exactly what your referring to here. Where is this happening and in what way? I can't find it Smile
Edit Test

[Image: sig.jpg]
(This post was last modified: 2012-05-12 20:49 by ruuk.)
find quote
hasselhof Offline
Donor
Posts: 578
Joined: Jul 2008
Reputation: 34
Location: UK
Post: #315
(2012-05-11 19:43)ruuk Wrote:  
(2012-05-11 18:32)hasselhof Wrote:  Have to refresh to see the unsubscription of thread/post/forum

Not sure exactly what your referring to here. Where is this happening and in what way? I can't find it Smile

Sorry ruuk

covered in previous post, sorry to have wasted your time.Blush Ignore.

Regarding the fanart, don't be too dejected by my comment about it, it is well impressive, might even be one of the best i've seen aroundNod
find quote
Post Reply