help firefox fonts way too big and window not centred

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
roddyguk Offline
Junior Member
Posts: 7
Joined: Apr 2007
Reputation: 0
Post: #1
hi,

im running xbmc live installed to hdd on my revo.

everything is working fine accept firefox, which as the title says, fonts are way too big and window is not centred.

i installed launcher via the "install from zip" in dharma
and installed firefox by just doing "sudo apt-get install firefox"
as far as i know i dont have any window mangers installed

ive tried settings dpi to various values in xorg.conf as i read in some other posts but with no joy.

any help in fixing this would be much appreciated

cheers rod...
find quote
vikjon0 Offline
---
Posts: 2,502
Joined: Apr 2009
Reputation: 8
Location: Sweden
Post: #2
If you follow a working guide it should be fine. At least of you run it in fluxbox.
BTW, I think you should use the executer in dharma. It is included in the repository and pre-installed in live.
find quote
vikjon0 Offline
---
Posts: 2,502
Joined: Apr 2009
Reputation: 8
Location: Sweden
Post: #3
Quote:and window is not centred.
DPI will not fix that. I guess you have an overscan problem. I dont know how that is fixed in xorg since I have not had it yet. I have a small issue when testing beta4 but I hope a different driver version will put it back to normal.
find quote
roddyguk Offline
Junior Member
Posts: 7
Joined: Apr 2007
Reputation: 0
Post: #4
ok cheers il give the fluxbox method a go.

also what do you mean by "use the executer in dharma"?

cheers
find quote
Temar Offline
Senior Member
Posts: 264
Joined: Nov 2008
Reputation: 8
Post: #5
roddyguk Wrote:ok cheers il give the fluxbox method a go.

If you don't want to use a window manager, you can always install the "Autohide" firefox extension. This extension adds a new command line option which allows firefox to be started in fullscreen mode.

Quote:also what do you mean by "use the executer in dharma"?

Executor and Launcher are both plugins to launch external applications.
find quote
roddyguk Offline
Junior Member
Posts: 7
Joined: Apr 2007
Reputation: 0
Post: #6
cheers Temar, i just figured out what Executor was.
i dont think the autohide extension will fix my problem as it is already fullscreen, its just that everything is way too big (the toolbars take up around 1/3 of the screen!)

i will give vikjon0's fluxbox guide a go in a bit and hope that sorts it
find quote
Temar Offline
Senior Member
Posts: 264
Joined: Nov 2008
Reputation: 8
Post: #7
roddyguk Wrote:cheers Temar, i just figured out what Executor was.
i dont think the autohide extension will fix my problem as it is already fullscreen, its just that everything is way too big (the toolbars take up around 1/3 of the screen!)

i will give vikjon0's fluxbox guide a go in a bit and hope that sorts it

You only have to fix your DPI settings. I don't know about the fluxbox guide, but look out for an explanation how to fix DPI. This will fix your problem with huge fonts and buttons.
find quote
roddyguk Offline
Junior Member
Posts: 7
Joined: Apr 2007
Reputation: 0
Post: #8
cheers to both of you for the help.

i found an add-on (NoSquint) that resizes websites, so now i can view pages properly.

im using all-in-one sidebar to take up the space lost on the left, now i can see the far left of web pages.

still have massive toolbar but thats not really a problem as i have removed most of it, i only really wanted a browser on my htpc for StumbleUpon anyways

cheers again...
find quote