[RELEASE] Missing Movie Plugin - Find Movies and TV Shows that are not in the library

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Japaja Offline
Fan
Posts: 513
Joined: May 2010
Reputation: 2
Location: Croatia
Post: #256
Movies search gives script error. TV shows work properly. Luckily there is another add-on that works for movies so I have to use them both to get the full effect. Smile
find quote
rockrazz Offline
Junior Member
Posts: 4
Joined: Jun 2010
Reputation: 0
Post: #257
updated to eden and all is ALMOST working. it lists my movies, but will only let me play them. how do I add them into
the movie library? Right click lists everything except 'add movie'. How do I do this. Thanks
find quote
Sentir101 Offline
Junior Member
Posts: 34
Joined: Feb 2012
Reputation: 1
Post: #258
(2012-03-30 22:26)fbi1970 Wrote:  I got this error searching for movies. TV Shows search runs ok.
(2012-04-02 21:22)Japaja Wrote:  Movies search gives script error. TV shows work properly. Luckily there is another add-on that works for movies so I have to use them both to get the full effect. Smile
(2012-04-02 00:01)crimsonfury Wrote:  Then I click on missing movies and it gives me an error; script failed.
Yeah, I made a mistake in the latest version, a new version with a (hopefully) fix will be released ASAP.

(2012-04-02 00:01)crimsonfury Wrote:  How do I add them to my library?
(2012-04-03 08:13)rockrazz Wrote:  updated to eden and all is ALMOST working. it lists my movies, but will only let me play them. how do I add them into
the movie library? Right click lists everything except 'add movie'. How do I do this. Thanks
I agree that adding the missing ones to the library from inside the add-on would be a very useful feature (and fun to implement), but this is not possible at the time and you can only see which files have not been scraped into the library. You can then fix the naming of the file on your own than so that the XBMC scrapers do scrape the file correctly. Unfortunately I do not have the time, now and in the foreseeable future, to implement this feature.

(2012-04-02 00:01)crimsonfury Wrote:  This is very confusing to setup.... Newest download isn't on front page, u have to search for it and no instructions on how to set it all up.
As you can see I am not the OP (original poster) I just updated the (seemingly abandoned) add-on to work with eden and added some features since then, as such I have no control over the first post.
(2012-04-02 00:01)crimsonfury Wrote:  But I got the newest one installed and I found it finally, under video not programs(strange).
I agree that this is strange but this is how the original version also worked, I would have to research how to get it in the programs menu. However, I will not have the time to do this until after Wednesday next week.
(This post was last modified: 2012-04-03 20:01 by Sentir101.)
find quote
xak944 Offline
Junior Member
Posts: 4
Joined: Aug 2011
Reputation: 0
Post: #259
(2012-03-30 22:26)fbi1970 Wrote:  22:21:04 T:3732 ERROR: Traceback (most recent call last):
File "C:\Users\XBMC\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 420, in <module>
ok = show_movie_submenu()
File "C:\Users\XBMC\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 317, in show_movie_submenu
trailer = m['trailer']
TypeError: string indices must be integers

Same issue here, TV Shows scan works okay but Movies crashes quickly with a similar error. XBMC Eden Final XBMCBuntu fresh install, Missing Movie 2.2.3.

Here's the full debug log: http://dpaste.com/728755/

Let me know if I can be of help doing additional testing or gathering more logs. Smile

ASUS AT3IONT-I | 4GB DDR3 | 20GB SATA | XBMCBuntu 11.0 Eden
Onkyo TX-SR606 | Polk RM6750 | Samsung LN40A550
9TB Ubuntu file server
find quote
fedearne Offline
Junior Member
Posts: 2
Joined: Jul 2011
Reputation: 0
Post: #260
Apparently the problem is when movies have multiple source files.

If you comment out lines 312 - 322 in default.py with a '#' before each line, the the plugin runs, but skips any movies with multiple source files.

You can find the path to default.py in the error log.
find quote
fedearne Offline
Junior Member
Posts: 2
Joined: Jul 2011
Reputation: 0
Post: #261
After looking at the issue a little closer you only have to comment out or remove line 315 of default.py

'for m in stack:'

The next lines 316 - 322 has to be "unindented".

Or you can get my default.py here: http://pastebin.com/9DWBp6c3
find quote
errornumber419 Offline
Junior Member
Posts: 29
Joined: Dec 2011
Reputation: 0
Location: Wisconsin
Post: #262
Does this work with password protected ftp locations?
find quote
fbi1970 Offline
Junior Member
Posts: 16
Joined: Jan 2011
Reputation: 0
Post: #263
Any news about new release?
find quote
qwertyjjj Offline
Member
Posts: 93
Joined: Jan 2012
Reputation: 0
Post: #264
is a new release available on another site?
find quote
Raytestrak Offline
Donor
Posts: 299
Joined: Sep 2011
Reputation: 2
Post: #265
Can I add a feature request for 2.2.4?

Can it be made possible to rescan a missing movie from within the plugin? Right now, I can open the context menu, but there's no refresh option and info or 'I' does nothing.

OpenElec on an Intel NUC (DC3217IYE). Onkyo NR-717. Canton Movie CD-1000. LG 42LM760S

If it ain't broke: break it, fix it, repeat
find quote
puntloos Offline
Senior Member
Posts: 127
Joined: Jul 2007
Reputation: 2
Post: #266
Sorry, I didn't read the entire 27 pages of the thread but as far as I can tell from github and the thread here this plugin still doesn't support SMB:// - is there any way to get the development on this going? I understand this is possibly not the plugin's fault but perhaps we can start taking steps to fix it inside XBMC somehow?
find quote
Raytestrak Offline
Donor
Posts: 299
Joined: Sep 2011
Reputation: 2
Post: #267
(2012-08-23 14:56)puntloos Wrote:  Sorry, I didn't read the entire 27 pages of the thread but as far as I can tell from github and the thread here this plugin still doesn't support SMB:// - is there any way to get the development on this going? I understand this is possibly not the plugin's fault but perhaps we can start taking steps to fix it inside XBMC somehow?

SMB works fine.

OpenElec on an Intel NUC (DC3217IYE). Onkyo NR-717. Canton Movie CD-1000. LG 42LM760S

If it ain't broke: break it, fix it, repeat
find quote
keibertz Offline
Senior Member
Posts: 263
Joined: Oct 2010
Reputation: 2
Post: #268
just installed Version 2.2.3 but i only get syntax errors

Episodes:
Quote:12:04:34 T:1164 NOTICE: Getting episodes for Drop Dead Diva
12:04:35 T:1164 ERROR: Error Type: <type 'exceptions.UnicodeDecodeError'>
12:04:35 T:1164 ERROR: Error Contents: 'utf8' codec can't decode byte 0xfc in position 12: invalid start byte
12:04:35 T:1164 ERROR: Traceback (most recent call last):
File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 422, in <module>
ok = show_tvshow_submenu()
File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 370, in show_tvshow_submenu
tv_sources = remove_duplicates(get_tv_sources(progress, done))
File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 162, in get_tv_sources
files = get_tv_files(False, progress, done)
File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 143, in get_tv_files
show_name = clean_path(tv_show['label'])
File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 49, in clean_path
s = unicode(s, 'utf-8')
UnicodeDecodeError: 'utf8' codec can't decode byte 0xfc in position 12: invalid start byte
12:04:35 T:3336 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.missingmovies/?mode=20
12:04:35 T:3336 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.missingmovies/?mode=20) failed

Movies:
Quote:12:05:29 T:1512 NOTICE: SEARCHING MOVIES
12:05:29 T:1512 ERROR: Error Type: <type 'exceptions.TypeError'>
12:05:29 T:1512 ERROR: Error Contents: string indices must be integers
12:05:29 T:1512 ERROR: Traceback (most recent call last):
File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 420, in <module>
ok = show_movie_submenu()
File "C:\Users\xbmc\AppData\Roaming\XBMC\addons\plugin.video.missingmovies\default.py", line 317, in show_movie_submenu
trailer = m['trailer']
TypeError: string indices must be integers
12:05:29 T:3336 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.missingmovies/?mode=10
12:05:29 T:3336 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.missingmovies/?mode=10) failed

XBMC 11 Final
Win7 64 Bit
SMB Shares
Any other infos u need ?

ASUS F2A85-M LE | A6-5400K | 4 GB DDR3-1866 | 128GB SSD | Windows 8 64 bit | XBMC 12 | Cirrus EV3
Onkyo TX-NR509 5.1 + Teufel Consono 35
Samsung UE55ES6300 55"
Harmony 785

http://www.MyXBMC.de
find quote
puntloos Offline
Senior Member
Posts: 127
Joined: Jul 2007
Reputation: 2
Post: #269
Just one comment (ha, even before I ever used this script, but I intend to..)
(2012-04-03 20:01)Sentir101 Wrote:  I agree that adding the missing ones to the library from inside the add-on would be a very useful feature (and fun to implement), but this is not possible at the time and you can only see which files have not been scraped into the library. You can then fix the naming of the file on your own than so that the XBMC scrapers do scrape the file correctly. Unfortunately I do not have the time, now and in the foreseeable future, to implement this feature.

Would there be some way to output the found files to either a file on the XBMC filing system, or simply to the log? Ideally in CSV or similar format?

That way someone could fairly easily run their own magic somehow, and auto-move or auto-tag the files into the rightful places?

What is the #1 cause of video files not showing in the library? For audio I'm sure its improper tagging but afaik video tagging is relatively in its infancy.
find quote
magic_merkin Offline
Junior Member
Posts: 32
Joined: Apr 2012
Reputation: 0
Post: #270
Great work guys, works a treat.

Anyway to filter out sample videos? Like below? I had dozens.

smb://SERVER/Videos/Movies/Drama/American.Gangster.2007/Sample/dmd-americang-sample.avi
smb://SERVER/Videos/Movies/Drama/Don.McKay.2009/sample.avi
smb://SERVER/Videos/Movies/Drama/Moneyball.2011.BRRip XviD-FTW/Moneyball 2011 BRRip XviD-FTW.sample.avi
smb://SERVER/Videos/Movies/Drama/Munich.(2005).bluray.720p.HDTV.x264-DON/SAMPLE.Munich.2005.720p.HDTV.x264-DON.mkv
smb://SERVER/Videos/Movies/Drama/No.Country.for.Old.Men.2007/Sample/dmd-nocountry-sample.avi
smb://SERVER/Videos/Movies/Drama/Requiem for a Dream 2000 720p BluRay DTS x264-DON/sample/SAMPLE.Requiem.for.a.Dream.2000.720p.BluRay.DTS.x264-DON.mkv
(2012-08-28 14:55)puntloos Wrote:  Just one comment (ha, even before I ever used this script, but I intend to..)
(2012-04-03 20:01)Sentir101 Wrote:  I agree that adding the missing ones to the library from inside the add-on would be a very useful feature (and fun to implement), but this is not possible at the time and you can only see which files have not been scraped into the library. You can then fix the naming of the file on your own than so that the XBMC scrapers do scrape the file correctly. Unfortunately I do not have the time, now and in the foreseeable future, to implement this feature.

Would there be some way to output the found files to either a file on the XBMC filing system, or simply to the log? Ideally in CSV or similar format?

That way someone could fairly easily run their own magic somehow, and auto-move or auto-tag the files into the rightful places?

What is the #1 cause of video files not showing in the library? For audio I'm sure its improper tagging but afaik video tagging is relatively in its infancy.

The latest version a page back works fine when using the default.py file from fedearne above.

It also outputs to file.
(This post was last modified: 2012-09-27 11:07 by magic_merkin.)
find quote
Post Reply