[REQUEST] Help with playing PPStream on XBMC

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
360ps3wii Offline
Junior Member
Posts: 2
Joined: Jan 2011
Reputation: 0
Post: #1
Hello I am trying to play videos from PPStream with XBMC as a front end for my HTPC.

After digging around in the forums, I know it is possible by adding a plug in to XBMC, but I can't find one anywhere.

I would write a plug in myself (well.. I would have to learn Python first but I am willing to do that!) but I would need the local stream URL of PPStream for that and I can't find that either...

If anyone could help me with this, or know of another way of playing PPStream videos on XBMC, it would be greatly appreciated!
find quote
carabalb Offline
Junior Member
Posts: 26
Joined: Aug 2010
Reputation: 0
Location: Boston, MA
Post: #2
http://forum.xbmc.org/showthread.php?tid=64250

That thread should have the link to the xbmc-addons-chinese repo which has a few different plugins including pps. To be honest I haven't been able to get it to work but then again I don't have PPS installed. Let me know if you get it to work.
find quote
xmbc Offline
Junior Member
Posts: 16
Joined: Jan 2011
Reputation: 0
Post: #3
carabalb Wrote:http://forum.xbmc.org/showthread.php?tid=64250

That thread should have the link to the xbmc-addons-chinese repo which has a few different plugins including pps. To be honest I haven't been able to get it to work but then again I don't have PPS installed. Let me know if you get it to work.

I did get PPS working just by installing the addon and ppstream. However, I dont seem to be able to control playback when played through xbmc.
find quote
360ps3wii Offline
Junior Member
Posts: 2
Joined: Jan 2011
Reputation: 0
Post: #4
Thanks for the replies guys.

Just to update, I have successfully installed the PPStream plugins with the link provided. The PPStream video links now shows up in my XBMC under "Video>Video Add-Ons>PPStream", although I still have to configure XBMC to display Chinese characters (it is displaying white squares instead of the Characters atm.)

More importantly, the video links only play for about one second before XBMC froze. I checked task manager while it's freezing and found that there's a "ppstream4XBMC" process running while the XBMC process itself is not responding. I am assuming the PPStream plugin is using the native player from PPStream (WMP?) and not XBMC's, and somehow this is causing a conflict for XBMC so the video is not playing. I am really not sure why it's not working, but it *seems* to me the video links are not broken (since it did play.. even just for one second) and it is a compatibility issue between XBMC and PPStream. Maybe it's because I am using XBMC 10.0 and the PPStream plugin is meant for older versions?

Is there a stable XBMC build you guys can recommend me to try that might fix this? Thanks in advance!
find quote
18000rpm Offline
Member
Posts: 50
Joined: Dec 2009
Reputation: 0
Post: #5
I have a really weird problem.

I installed the ppstream plugin on my Windows XBMC HTPC and browsing the ppstream hierarchy works fine, but when I actually want to play a video nothing happens.

Doing some debugging I see that the Python script stops after adding the final page with video playback links:

17:21:42 T:5684 M:2212663296 DEBUG: XBPyThread::Process - Entering source directory C:\Users\Bryan\AppData\Roaming\XBMC\addons\plugin.video.ppstream
17:21:43 T:3076 M:2211700736 DEBUG: ------ Window Init (DialogBusy.xml) ------
17:21:44 T:1396 M:2211962880 INFO: Loading skin file: DialogProgress.xml
17:21:44 T:1396 M:2211958784 DEBUG: ------ Window Init (DialogProgress.xml) ------
17:21:44 T:3076 M:2211958784 DEBUG: ------ Window Deinit (DialogBusy.xml) ------
17:21:46 T:1396 M:2209947648 DEBUG: XFILE::CPluginDirectory::WaitOnScriptResult- plugin returned successfully
17:21:46 T:5684 M:2209947648 INFO: Scriptresult: Success
17:21:46 T:3076 M:2209947648 DEBUG: Saving fileitems [plugin://plugin.video.ppstream/?mode=15&name=%E4%BA%BA%E5%9C%A8%E6%B1%9F%E6%B9%96&url=http%3A%2F%2Fkan.pps.tv%2Fplay%2F263867_2414710.html]
17:21:46 T:5684 M:2209947648 INFO: Python script stopped
17:21:46 T:5684 M:2209947648 DEBUG: Thread 5684 terminating

Any idea why?
find quote