[AppleTV2] MySQL database / library support?

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
vicbitter Offline
Donor
Posts: 253
Joined: Jan 2011
Reputation: 3
Post: #61
transcender Wrote:yep found that other thread w/ skip-resolve-name got me up and running thanks (weird as i was using IPs)
I think the sql setup could use a more slight refined write up then the ones I've seen.
but i cant get thumbnails path subs to work.
I created script to backup /xbmc to Windows server and then shared out the thumbnails folder as thumbnails.

I've tried putting the credentials in


<to>smb://user:credentials@192.168.0.1/c/Thumbnails/Thumbnails</to>

is the "c/Thumbnails/Thumbnails " native to your share? not sure why the c/thumbnails....

Finally got MySQL install working
Got backup / sync script (backup and centrally locate/share thumbnails) working
Got my WATCHED status sync script working
Got my DSN to mySQL database so this would be last step of system migration to central mySQL store...would love to hammer this home, insights apprecriated.

i still get
21:03:08 T:805208064 M:113704960 ERROR: Create - Error( No such file or directory )
21:03:08 T:805208064 M:113704960 ERROR: Create - Error creating special://masterprofile/Thumbnails
21:03:08 T:805208064 M:113700864 ERROR: Create - Error( No such file or directory )
21:03:09 T:805208064 M:113700864 ERROR: Create - Error creating special://masterprofile/Thumbnails/Music
21:03:09 T:805208064 M:113700864 ERROR: Create - Error( No such file or directory )
21:03:09 T:805208064 M:113700864 ERROR: Create - Error creating special://masterprofile/Thumbnails/Music/Artists
21:03:09 T:805208064 M:113700864

In the substitution <to>smb://user:credentials@192.168.0.1/c/Thumbnails/Thumbnails</to> after the IP address is the share (and directory) of your Thumbnails which will be unique to your set up.
find quote
cgravelle Offline
Donor
Posts: 18
Joined: Feb 2011
Reputation: 0
Post: #62
turbinez Wrote:what are the benefits of having your xbmc database on a mysql server as oppose to the default way? Is it easy to setup?

If you have multiple instances of xbmc, they all refer to the same database. Therefore, if one gets marked as watched, or you stop a video part way through (lets say in the living room), then all other instances will show that first show as watched, and you can resume watching the paused video from the same spot in another instance (lets say living room).

It also means that if you add another xbmc device or wipe a device and start from scratch while testing, you don't loose your watched markings and it doesn't have to do all the scraping again.
find quote
transcender Offline
Donor
Posts: 233
Joined: Mar 2010
Reputation: 2
Post: #63
vicbitter Wrote:In the substitution <to>smb://user:credentials@192.168.0.1/c/Thumbnails/Thumbnails</to> after the IP address is the share (and directory) of your Thumbnails which will be unique to your set up.

I shared out the /thumbnails folder on my WIN server
<to>smb://xbmc:credentials@IP/Thumbnails</to>
not working though :/

Search first, provide details and keep forums clean. Mark things solved, to close them out and acknowledge helpful volunteers who share. If I have helped, click the plus button.
find quote
vicbitter Offline
Donor
Posts: 253
Joined: Jan 2011
Reputation: 3
Post: #64
transcender Wrote:I shared out the /thumbnails folder on my WIN server
<to>smb://xbmc:credentials@IP/Thumbnails</to>
not working though :/

Are you able to post your log file (via pastebin)? Have the Thumbnails already been generated via another XBMC client?
find quote
transcender Offline
Donor
Posts: 233
Joined: Mar 2010
Reputation: 2
Post: #65
Yes, I will try to post when I get home as my ipad is with me currently
I scraped w/ main machine Acer Revo on linux.

On windows server hosting media and MySQL
I've scripted backup of /xbmc folder from Revo via WinSCP to Win server
I shared the /thumbnails folder wide open even to XBMC user

on ipad i put path subsitution to the shared thumbnail folder on the win server

My logs looks much like the others whom have posted snippets, but I'll try to post that pastebin.

Search first, provide details and keep forums clean. Mark things solved, to close them out and acknowledge helpful volunteers who share. If I have helped, click the plus button.
find quote
transcender Offline
Donor
Posts: 233
Joined: Mar 2010
Reputation: 2
Post: #66
vicbitter Wrote:Are you able to post your log file (via pastebin)? Have the Thumbnails already been generated via another XBMC client?
Its either pretty slow or still buggy but i got it at least pulling some images by using just 'profile' vs 'masterprofile'

Even w/ 802.11n its kinda slow to pull thumbs, fanarts fairly quick on iPad.

But I've finally fully migrated from local myvideos.mdb to centralized MySQL dbase it wasn't easy but now that its over, I'm fairly happy :
Problematic windows install MySQL install resolved by manually adding entry to windows firewall (even though its not enabled?)
MySQL required strange DNS setting even though I was using fixed IPs.
WinSCP script to backup Revo (thumbnails) with binary and ascii mode for xml/logs
Script to parse NFOs and update database directly finally converted from previous one that was running against the myvideos.mdb ported to version that will run vs MySQL this is easier now as I can update/correct now without transerring the mdb back/forth
Resolved path substition to iPad w/ the above.

Thanks to those whom provided insight.
Note with iPad is using a centralized database and no real easy way to access the file system easily makes XBMC hang/crash
So using it to watch local vids would be problematic. Obviously on a plane ride or somethign nice to transfer vids w/ converting and watch on XBMC ...Would be nice to put a hard timeout or something?

Search first, provide details and keep forums clean. Mark things solved, to close them out and acknowledge helpful volunteers who share. If I have helped, click the plus button.
(This post was last modified: 2011-02-12 11:39 by transcender.)
find quote
tmmurri Offline
Junior Member
Posts: 8
Joined: Feb 2011
Reputation: 0
Post: #67
WisdomWolf Wrote:I created an advancedsettings.xml on my iPad and it shows my mySQL library correctly (although no thumbs, obviously). However it won't play anything. Every time I go to play a video it just says that it's no longer available. I don't get it, I can access the shares via the file view (videos) and I know the database has the right SMB links because I use it with a revo and two MacBooks as well. Any ideas?


I am having the same problem. Can someone PLEASE help me with this issue?
find quote
joshua.lyon Offline
Donor
Posts: 87
Joined: Dec 2009
Reputation: 1
Location: North Texas
Post: #68
tmmurri Wrote:I am having the same problem. Can someone PLEASE help me with this issue?
I'm also struggling to get remote thumbnails working. My main box is an XBMC (Live) setup on Ubuntu 10.10. I have the thumbnails exposed via a samba share and I've tried a number of different path substitution setups, but still can't get it to work. I would prefer to get the thumbnails working over samba, but I'm going to try out an rsync setup to see if that will at least get me by for the time being...
find quote
matbor Offline
Senior Member
Posts: 147
Joined: Jun 2004
Reputation: 0
Location: Melbourne, Australia
Post: #69
Hi all, hoping someone can clarify something for me about the remote thumbnails. If all my TVShow and Movie folders have the NFO, TBN, JPG files in each folder already, because I use a 3rd party scrapper (sickbread/couchpotato) then I don't need to worry about having an additional remote thumbnail directory!>?

Thx

4x ATV2's (v4.3) XBMC Frodo12.2. Raspberry Pi running MYSQL 5.5.31-0+wheezy1. NAS is a Drobo FS
find quote
transcender Offline
Donor
Posts: 233
Joined: Mar 2010
Reputation: 2
Post: #70
matbor Wrote:Hi all, hoping someone can clarify something for me about the remote thumbnails. If all my TVShow and Movie folders have the NFO, TBN, JPG files in each folder already, because I use a 3rd party scrapper (sickbread/couchpotato) then I don't need to worry about having an additional remote thumbnail directory!>?

Thx

False. I think if you read from the nature of this thread's 7 pages thus far, this is not correct. More generic info can be found on the wikis.
http://wiki.xbmc.org/index.php?title=Thumbnails
Many people use 3rd party scrapers. That just gives you a static place to pull from the LAN vs WAN when scraping initially but that information is still cached locally in the databases as well as the images, which are NOT in the database.
The images and library information shown in XBMC don't come from those 3rd party files. The information comes from the database and the images the locally cached images on the client.
Those nfos/jpgs....blah blah are just there for the scrape into XBMC and not used again. If you watch a file and it gets 'mark as watched', its marked as watched in the database NOT your NFO.

Search first, provide details and keep forums clean. Mark things solved, to close them out and acknowledge helpful volunteers who share. If I have helped, click the plus button.
(This post was last modified: 2011-02-14 04:36 by transcender.)
find quote
matbor Offline
Senior Member
Posts: 147
Joined: Jun 2004
Reputation: 0
Location: Melbourne, Australia
Post: #71
transcender Wrote:False. I think if you read from the nature of this thread's 7 pages thus far, this is not correct. More generic info can be found on the wikis.
http://wiki.xbmc.org/index.php?title=Thumbnails
Many people use 3rd party scrapers. That just gives you a static place to pull from the LAN vs WAN when scraping initially but that information is still cached locally in the databases as well as the images, which are NOT in the database.
The images and library information shown in XBMC don't come from those 3rd party files. The information comes from the database and the images the locally cached images on the client.
Those nfos/jpgs....blah blah are just there for the scrape into XBMC and not used again. If you watch a file and it gets 'mark as watched', its marked as watched in the database NOT your NFO.

Cool thx, understand it better now, will re-read the thread now and have a better understanding, just in the middle of mysql setup, so will look into all this now.

4x ATV2's (v4.3) XBMC Frodo12.2. Raspberry Pi running MYSQL 5.5.31-0+wheezy1. NAS is a Drobo FS
find quote
Advocate Offline
Senior Member
Posts: 117
Joined: Mar 2009
Reputation: 0
Location: Hartlepool, United Kingdom
Post: #72
None of the path substitutions posted here are working for me on my ATV2, it seems to be regenerating the local Thumbnails folder as I type this....

[Image: widget][Image: widget]
find quote
cgravelle Offline
Donor
Posts: 18
Joined: Feb 2011
Reputation: 0
Post: #73
Yah. I never did get it to work either. I tried special://masterprofile, special://profile, and /var/mobile ....

I had another thread at http://forum.xbmc.org/showthread.php?tid=93524 where I discussed that for the write operation special://masterprofile works because it actually writes the thumbnails to my smb shared folder correctly while scraping, but then couldn't see them when I actually browse them.

I have resulted to updating the library on my PC (using symlinked folder to nas) and then rsyncing to my ATV2 boxes.
find quote
transcender Offline
Donor
Posts: 233
Joined: Mar 2010
Reputation: 2
Post: #74
Advocate Wrote:None of the path substitutions posted here are working for me on my ATV2, it seems to be regenerating the local Thumbnails folder as I type this....

curious those whom are still failing do you acutally have multiple 'profiles' or use profiles or logon to xbmc? I dont. just using //profile vs masterprofile seemed to finally work for me on the iPad.

Search first, provide details and keep forums clean. Mark things solved, to close them out and acknowledge helpful volunteers who share. If I have helped, click the plus button.
(This post was last modified: 2011-02-15 21:13 by transcender.)
find quote
Advocate Offline
Senior Member
Posts: 117
Joined: Mar 2009
Reputation: 0
Location: Hartlepool, United Kingdom
Post: #75
If I scrape on my main machine then i get everything showing on my ATV2 but without thumbs or fan art. I then have to rescrape on the ATV2 to get thumbnails etc to show....most frustrating

[Image: widget][Image: widget]
find quote
Post Reply