How to solve the SMB Linux character problem!

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Antimon51 Offline
Junior Member
Posts: 10
Joined: Jan 2004
Reputation: 0
Thumbs Up   
Post: #1
(editSmilei will get back to this thread...
it would simply not work anymore...

a shared folder in windows xp home, works ok
with international/swedish characters, i.e, åäöåäö
but i can't get it to work with linux samba 2.2.7

funny things happens,
some .jpg-files shows up as _folders_ when they contain åäöåäö (shown as small squares), and when entering the folder, it's empty.

what's the code page xbmc expects for smb shares?



----------------------------------------------------
if you don't get the international characters right, using windows file sharing and linux, then there might be that you do not have the correct config settings for the linux smb (version 2) file server character sets.
enter, (in the [global] section), two lines in the file /etc/samba/smb.conf;
Quote:client code page = 850
character set = iso8859-1
(or iso8859-15 depending your special character needs)
this will fix the file names for the files u r going to create from here after, but what about the 2000+ files u already have in the wrong character set?

well, use the linux program convmv (find it with google convmv)
Quote:convmv -f cp850 -t iso8859-1 -r -i ./*
will convert file names from cp850 to iso8859-1
this nifty program will in fact convert to/from almost any character sets there is.
hope this helps for the one in need...
/51
find quote