[AppleTV2] ATV2 4.1 XBMC Crashes after few minutes

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
root2 Offline
Junior Member
Posts: 26
Joined: Jan 2011
Reputation: 0
Post: #31
i can confirm the problem with 4.1 ... I have fixed the problem with updateing to 4.2.1 (tethered)... but now i can watch a 2h movie without a crash!
find quote
cletus Offline
Junior Member
Posts: 5
Joined: Jan 2011
Reputation: 0
Post: #32
yozh Wrote:Oh wow I didnt even think of that. I did disable update notification using NitoTV because it was annoying me and right about after that it started working..... So that might be it.

I can confirm that installing NitoTV and disabling the updates fixed it on my ATV as well.
find quote
Dense Offline
Junior Member
Posts: 6
Joined: Dec 2003
Reputation: 0
Post: #33
That's a really good point! I've also disabled update notifications. I wonder if that has something to do with it.

Trying making this change.

/etc/hosts
127.0.0.1 mesu.apple.com
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,479
Joined: Feb 2008
Reputation: 64
Post: #34
update notifications causing general misbehavior is a 'known issue'.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
automat Offline
Junior Member
Posts: 1
Joined: Jan 2011
Reputation: 0
Post: #35
cletus Wrote:I can confirm that installing NitoTV and disabling the updates fixed it on my ATV as well.


same here Nod
find quote
hssxbmc Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Post: #36
Hi

I've tried this too with NitoTV but to no avail. The update notification still appears and therefore causes XBMC to kick out after 10mins or so of usage

Has anyone else experienced this? I am on 4.1 (4.0 aka)
find quote
nxn_swe Offline
Junior Member
Posts: 5
Joined: Jan 2011
Reputation: 0
Location: Stockholm
Post: #37
Hi,

I think i might have found a temporary fix.
Thing is, when you disable the update notification with NitoTV, it points mesu.apple.com to 127.0.0.1 (localhost) in /etc/hosts

However, it adds a empty line first and then the above configuration.
When i manually edit the file and remove the empty line it works.

To easily check this, try disable with NitoTV, ping mesu.apple.com, check the round-trip time, edit the file manually, ping again and compare the results.

After this, i haven't had a single crash.
Hope this works for you as well.
(This post was last modified: 2011-01-24 18:39 by nxn_swe.)
find quote
hssxbmc Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Post: #38
nxn_swe Wrote:Hi,

I think i might have found a temporary fix.
Thing is, when you disable the update notification with NitoTV, it points mesu.apple.com to 127.0.0.1 (localhost) in /etc/hosts

However, it adds a empty line first and then the above configuration.
When i manually edit the file and remove the empty line it works.

To easily check this, try disable with NitoTV, ping mesu.apple.com, check the round-trip time, edit the file manually, ping again and compare the results.

After this, i haven't had a single crash.
Hope this works for you as well.


Hi - thanks for this. Will try out later this eve and report back
find quote
hssxbmc Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Post: #39
nxn_swe Wrote:Hi,

I think i might have found a temporary fix.
Thing is, when you disable the update notification with NitoTV, it points mesu.apple.com to 127.0.0.1 (localhost) in /etc/hosts

However, it adds a empty line first and then the above configuration.
When i manually edit the file and remove the empty line it works.

To easily check this, try disable with NitoTV, ping mesu.apple.com, check the round-trip time, edit the file manually, ping again and compare the results.

After this, i haven't had a single crash.
Hope this works for you as well.

It didn't but might be more me than you :-)

contents are like this

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
127.0.0.1 mesu.apple.com

when I ping I get
C:\Users\Harinder>ping mesu.apple.com

Pinging a97.g.akamai.net [213.120.161.146] with 32 bytes of data:
Reply from 213.120.161.146: bytes=32 time=141ms TTL=54
Reply from 213.120.161.146: bytes=32 time=153ms TTL=54
Reply from 213.120.161.146: bytes=32 time=155ms TTL=54
Reply from 213.120.161.146: bytes=32 time=156ms TTL=54
find quote
disastertje Offline
Junior Member
Posts: 3
Joined: Jan 2011
Reputation: 0
Post: #40
Dense Wrote:That's a really good point! I've also disabled update notifications. I wonder if that has something to do with it.

Trying making this change.

/etc/hosts
127.0.0.1 mesu.apple.com

Has done the job for me. Installed nano using apt-get and editted the hosts file. After a reboot, my xbmc doesnt crash anymore Big Grin
find quote
nxn_swe Offline
Junior Member
Posts: 5
Joined: Jan 2011
Reputation: 0
Location: Stockholm
Post: #41
hssxbmc Wrote:It didn't but might be more me than you :-)

contents are like this

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
127.0.0.1 mesu.apple.com

when I ping I get
C:\Users\Harinder>ping mesu.apple.com

Pinging a97.g.akamai.net [213.120.161.146] with 32 bytes of data:
Reply from 213.120.161.146: bytes=32 time=141ms TTL=54
Reply from 213.120.161.146: bytes=32 time=153ms TTL=54
Reply from 213.120.161.146: bytes=32 time=155ms TTL=54
Reply from 213.120.161.146: bytes=32 time=156ms TTL=54

I think your'e pining from your PC.
Try from the AppleTV.
As i said, you should see the round-trip be much lower and the reply should come from 127.0.0.1.
find quote
hssxbmc Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Post: #42
nxn_swe Wrote:I think your'e pining from your PC.
Try from the AppleTV.
As i said, you should see the round-trip be much lower and the reply should come from 127.0.0.1.

tried that too


Apple-TV:~ root# ping mesu.apple.com
PING a97.g.akamai.net (213.120.161.146): 56 data bytes
64 bytes from 213.120.161.146: icmp_seq=0 ttl=54 time=32.512 ms
64 bytes from 213.120.161.146: icmp_seq=1 ttl=54 time=30.404 ms
64 bytes from 213.120.161.146: icmp_seq=2 ttl=54 time=29.831 ms
64 bytes from 213.120.161.146: icmp_seq=3 ttl=54 time=29.610 ms
--- a97.g.akamai.net ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max/stddev = 29.610/30.589/32.512/1.147 ms
Apple-TV:~ root#

then used brain - press enter after last line entry in hosts file :rolleyes2:
find quote
nxn_swe Offline
Junior Member
Posts: 5
Joined: Jan 2011
Reputation: 0
Location: Stockholm
Post: #43
very strange...

my /etc/hosts...


##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
127.0.0.1 mesu.apple.com

resulting in...

Apple-TV:~ root# ping mesu.apple.com
PING mesu.apple.com (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.225 ms
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.172 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.228 ms
^C--- mesu.apple.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.172/0.208/0.228/0.026 ms


your result shouldn't be possible :confused2:
find quote
hssxbmc Offline
Junior Member
Posts: 7
Joined: Jan 2011
Reputation: 0
Post: #44
nxn_swe Wrote:very strange...

my /etc/hosts...


##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
127.0.0.1 mesu.apple.com

resulting in...

Apple-TV:~ root# ping mesu.apple.com
PING mesu.apple.com (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.225 ms
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.172 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.228 ms
^C--- mesu.apple.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.172/0.208/0.228/0.026 ms


your result shouldn't be possible :confused2:

Hi - resolved. Should have been clearer in my previous post rather than the rolling eyes Big Grin

I just had to hit return after the last line in the hosts file and then it worked and I get the same ping response as you. Thanks for all your help kind sir - couldn't have got this far without you!
find quote
nxn_swe Offline
Junior Member
Posts: 5
Joined: Jan 2011
Reputation: 0
Location: Stockholm
Post: #45
hssxbmc Wrote:Hi - resolved. Should have been clearer in my previous post rather than the rolling eyes Big Grin

I just had to hit return after the last line in the hosts file and then it worked and I get the same ping response as you. Thanks for all your help kind sir - couldn't have got this far without you!


I see now what you meant. Smile

(My XBMC has been up and running close to 24hrs now)
find quote