Audio settings during playback possible bug?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
maxinc Offline
Senior Member
Posts: 299
Joined: Oct 2010
Reputation: 0
Location: London, UK
Post: #1
Symptoms: Audio option menu pops up but no items are selectable. Black horizontal band is not shown and pressing up / down does nothing. I can't change audio streams or subtitles.

Only happens with audio over HDMI 5.1 when AC3 and DTS capable receiver is selected. Only on reFocus and only in XBMC Live.

I've tried XBMC, same settings, same skin on Windows 7, works fine.
XBMC Live with DTS and AC3 capable receiver deselected, works fine.
XBMC Live with other skins (confluence for example) works fine as expected.

My temporary workaround was to disable DTS and AC3 passthrough but I am really keen of finding the source of this strange behaviour so any help is greatly appreciated.

XBMC Live: i3 530 / GT210 / 2GB / SSD + 2 x Zotac HD01 / 2GB / SSD
unRAID Pro: 6 x 1TB + 2 x 1.5TB + 2 x 2TB + 2 x 500G over GbE
HP Micro Server: SABnzbd+, Sickbeard, Couchpotato, uTorrent, Media Companion, MySQL, MKV Toolnix
find quote
Amelandbor Offline
Fan
Posts: 328
Joined: Oct 2009
Reputation: 9
Location: Netherlands
Post: #2
Known bug and should be fixed in the next release
find quote
maxinc Offline
Senior Member
Posts: 299
Joined: Oct 2010
Reputation: 0
Location: London, UK
Post: #3
That's a relief. Thanks! I guess I should have searched better. Is there any other workaround like editing a XML file or something?

XBMC Live: i3 530 / GT210 / 2GB / SSD + 2 x Zotac HD01 / 2GB / SSD
unRAID Pro: 6 x 1TB + 2 x 1.5TB + 2 x 2TB + 2 x 500G over GbE
HP Micro Server: SABnzbd+, Sickbeard, Couchpotato, uTorrent, Media Companion, MySQL, MKV Toolnix
find quote
Jeroen Offline
Skilled Skinner
Posts: 2,483
Joined: Feb 2008
Reputation: 22
Location: The Netherlands
Post: #4
Yep, in VideoOSDSettings.xml, change line 2 into:

<defaultcontrol>5</defaultcontrol>
find quote
maxinc Offline
Senior Member
Posts: 299
Joined: Oct 2010
Reputation: 0
Location: London, UK
Post: #5
Great stuff! Works perfectly, thanks!

XBMC Live: i3 530 / GT210 / 2GB / SSD + 2 x Zotac HD01 / 2GB / SSD
unRAID Pro: 6 x 1TB + 2 x 1.5TB + 2 x 2TB + 2 x 500G over GbE
HP Micro Server: SABnzbd+, Sickbeard, Couchpotato, uTorrent, Media Companion, MySQL, MKV Toolnix
find quote