Please help! Frame drops @50 Hz on ION/VDPAU

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Hammi Offline
Senior Member
Posts: 164
Joined: Dec 2009
Reputation: 0
Post: #1
There are numerous threads out here on stutter, judder, frame drops... with 24 and/or 60 Hz. I have implemented the settings from this thread and others, but I cannot get rid of stuttering cause by frame drops on my Atom/ION machine (Zotac IONITX-A-E, Atom 330, 2 GB RAM, 512kb dedicated to video) playing back 1080i material (with no deinterlacer turned on) at 50Hz.

CPU load is low (10 to 20%). Stuttering does not always occur at the same scene, but it does occur with every 1080 movie (all interlaced 50 fps, recorded with mythtv from DVB-S2, h.264 material, mpeg container) I play. SD and 720p play ok.

I tried, without any luck:
  • Installing XBMC on a full Ubuntu desktop (worked with 9.11)
  • Installing XBMCbuntu onto the internal HD
  • Installing XBMCbuntu onto an internal SSD
  • Running XBMC live from an USB stick
  • Playing media from the internal HDD or an USB HDD
  • Upgrading to the latest nVidia drivers from the x-swat ppa
  • Flashing the BIOS to the newest version
  • Applying new microcode to fix the Atom PSE erratum

I have included log files from my recent test below.

The 1080i movie started at 21:39 local time, with 16 frame drops. at 21:51, the movie stuttered, taking me to 57 frame drops. At 22:10, the next stutter, 154 frame drops. There were additional stutters thereafter, taking me to 185 and then 241 dropped frames. At 22:34, there was another stutter, taking me to 268 dropped frames. I then stopped the movie.

Debug log - as you can see, the only entries in this log from the relevant times were me pressing some key (after the stutter) to see the machine's time and dropped frames. But the dropped frames as such are not logged...

I also traced IO load on the machine, but could not see anything unusual:

iotop log

My current xorg.conf:

Code:
Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option         "TwinView" "False"
    Option         "DynamicTwinView" "False"
    Option         "FlatPanelProperties" "Scaling = Native"
    Option         "SWCursor" "on"
    Option         "HWCursor" "off"
    Option         "ColorSpace" "RGB"
    Option         "ColorRange" "Limited"
    SubSection     "Display"
        Depth      24
        Modes      "1920x1080_50" "1920x1080_60_0" "1920x1080_24"
    EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Disable"
EndSection

Is something in my hardware broken? Should I try different RAM modules or a different ION board? (Not cheap, but if it's broken...)

PLEASE HELP!
(This post was last modified: 2011-02-06 09:41 by Hammi.)
find quote
WWWilco Offline
Member
Posts: 65
Joined: Nov 2009
Reputation: 0
Post: #2
Bad news: ION + xbmc will never be stutter free. ION is too slow sometimes (especially with m2ts files) and xbmc just does not support every file type perfectly.

Good news: your setup is fine. A lot of stutter can be removed by using the newest XBMC + Nvidia drivers. But the real benefit comes from adding the correct modelines to your xorg.conf. Search the forums, lost of info, these are mine:
Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Sony"
    ModelName      "Bravia 40WK5500"
    HorizSync       14 - 70
    VertRefresh     48 - 62
    Option         "DPMS"
    # These modelines are needed so the 24 fps movies can run without stuttering. Extract as root with:
    # X -verbose 6 > ~/xlog.txt 2>&1
    ModeLine "1920x1080@50p" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    ModeLine "1920x1080@60p" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    ModeLine "1920x1080@24p" 74.16 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
    Option "ExactModeTimingsDVI" "TRUE"
    # Set the correct DPI manually, it somehow defaults to 32x32"
    Option  "DPI" "96 x 96"
EndSection
Also, Ubuntu sucks for a mediacenter, too much crap you don't need hugging up CPU cycles. Just run a minimal distro like Arch, no window manager and start xbmc from boot.
find quote
Hammi Offline
Senior Member
Posts: 164
Joined: Dec 2009
Reputation: 0
Post: #3
WWWilco Wrote:Bad news: ION + xbmc will never be stutter free.

Interesting... :confused2: I had thought from many threads that ION as such is sufficiently powerful to play HD material stutter-free, if the video conf is right.

WWWilco Wrote:ION is too slow sometimes (especially with m2ts files) and xbmc just does not support every file type perfectly.

So you mean that transcoding the movies to some other format could help? Which one would you recommend?

WWWilco Wrote:But the real benefit comes from adding the correct modelines to your xorg.conf.

According to all I read, the modelines are specifically required for 24fps - which typically comes without frame drops. My issue is with 50 fps movies and a TV which can plays 50 fps movies (external HW player) without stutter.

WWWilco Wrote:Also, Ubuntu sucks for a mediacenter, too much crap you don't need hugging up CPU cycles.

Yep, that's why I tried Ubuntu server minimal and XBMC live after I could not get rid of the stutters on Ubuntu desktop. But neither of these has really changed anything about the frame drops - and CPU load is constantly (far) below 30%.

That's what's really confusing me: Frame drops although IO load and CPU load are far below what the machine could handle.
find quote
kees667 Offline
Fan
Posts: 713
Joined: Oct 2004
Reputation: 6
Post: #4
You state in quotes "worked with 9.11". Did these exact files play fine in 9.11? if you are unsure you can easily try with a live version of 9.11.

Don't get your hopes up though on a solution from me. Have the same issues, downgraded to 9.11 and everything now plays fine again. I know downgrading is not an option for everyone but for me the opportunity to play all files exceeds my need for all the (very nice!) enhancemenents made in Dharma. All the files that don't work anymore with Dharma are now again playable. I use an asrock 330.

Tried all the things you have, updating vdpau, moving files from NAS to internal SSD etc but nothing helped. I have a silent hope that 10.1 solves this but I don't see too much response on all the stutter/framedrop threads to indicate so.
find quote
zenani Offline
Junior Member
Posts: 28
Joined: Sep 2009
Reputation: 0
Post: #5
I have the same problem with xbmc 10.0 and Zotac ion ITX-A, with xbmc 9.11 everything is ok without framedrops.
http://forum.xbmc.org/showthread.php?p=710272

And this problem has nothing to do with modeline. I use exactly the same modelines in 10.0 and 9.11. With the wrong modelines you get permanent stutter and not framedrops every x minutes.
And it has also nothing to do with the source files. In my case any video i test has the same problem. And the problem is also always on different positions. When the problem occurs and i jump back the same scene playes without framedrops.
find quote
Hammi Offline
Senior Member
Posts: 164
Joined: Dec 2009
Reputation: 0
Post: #6
Where can I download XBMC 9.11 live? xbmc.org dowload options for live just take me to Dharma.
find quote
WWWilco Offline
Member
Posts: 65
Joined: Nov 2009
Reputation: 0
Post: #7
Hammi Wrote:Interesting... :confused2: I had thought from many threads that ION as such is sufficiently powerful to play HD material stutter-free, if the video conf is right.
It isn't that bad, on my system, 90% of HD movies play fine, without stuttering or other problems. Having said that, 10% still give some problems and the occasional hickup.
Hammi Wrote:So you mean that transcoding the movies to some other format could help? Which one would you recommend?
It seems MKV and MPG are the most resilient formats for XBMC, you can try to play an MKV file to see if that solves your problems.
Hammi Wrote:According to all I read, the modelines are specifically required for 24fps - which typically comes without frame drops. My issue is with 50 fps movies and a TV which can plays 50 fps movies (external HW player) without stutter.
I would definitely add a modeline for 1920x1080@50p, to make sure the mediacenter can only output 50Hz. Try to eliminate the possibility of XBMC using 24 or 25 Hz for some reason.
Hammi Wrote:Yep, that's why I tried Ubuntu server minimal and XBMC live after I could not get rid of the stutters on Ubuntu desktop. But neither of these has really changed anything about the frame drops - and CPU load is constantly (far) below 30%.
I use Arch linux, IceWM as windowmanager and XBMC. Version 10.0 has definitely removed a lot of stutter for me.
find quote
kees667 Offline
Fan
Posts: 713
Joined: Oct 2004
Reputation: 6
Post: #8
I found one through google, link is from sourceforge so looks fine.

http://sourceforge.net/projects/xbmc/fil...0-%209.11/

Hammi Wrote:Where can I download XBMC 9.11 live? xbmc.org dowload options for live just take me to Dharma.
find quote
Hammi Offline
Senior Member
Posts: 164
Joined: Dec 2009
Reputation: 0
Post: #9
Thanks. It seems that I have found the cause - it appears to be the driver for my wireless keyboard. When that keyboard is switched off, the driver seems to scan for it every 10 mins, and this scan sometimes appears to cause stutters. I just watched a movie with a PS/2 keyboard connected instead - and saw no stuttering.
find quote
Hammi Offline
Senior Member
Posts: 164
Joined: Dec 2009
Reputation: 0
Post: #10
Ok, the keyboard was (sadly) not the cause for frame drops.

I ran the test with the keyboard after having stopped and then resuming the movie. In this case, frame drops are (interestingly) significantly lower. The type of keyboard doesn't make a difference, the issue persists unchanged with a plain PS/2 keyboard.
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,435
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #11
I have been working on patches for this problem. Unfortunately they don't work on every system, yet Sad
I would be interested if setting TripleBuffer to true in your xorg will lower your frame drops.
find quote
giskard78 Offline
Junior Member
Posts: 16
Joined: Nov 2009
Reputation: 0
Post: #12
Sorry for my English

Same problem.

I was wondering one thing:

This problem exists only on systems based on ion?

If the answer is yes, the problem is the driver or the management or hardware accelerator.

If everything was ok in 9.11 What has changed?
Ascolta
Trascrizione fonetica
Dizionario - Visualizza dizionario dettagliato
find quote
gott_sei_dank Offline
Member
Posts: 85
Joined: Sep 2009
Reputation: 0
Post: #13
It might be worth checking what video scaling method you are using, when watching HD satellite channels I have to switch to bilinear otherwise the frame rate chokes at around 20, 23 fps causing stuttering.
find quote
Hammi Offline
Senior Member
Posts: 164
Joined: Dec 2009
Reputation: 0
Post: #14
FernetMenta Wrote:I have been working on patches for this problem. Unfortunately they don't work on every system, yet Sad
I would be interested if setting TripleBuffer to true in your xorg will lower your frame drops.

I tried that, but it doesn't seem to make any difference, sadly. Frown
find quote
Hammi Offline
Senior Member
Posts: 164
Joined: Dec 2009
Reputation: 0
Post: #15
gott_sei_dank Wrote:It might be worth checking what video scaling method you are using, when watching HD satellite channels I have to switch to bilinear otherwise the frame rate chokes at around 20, 23 fps causing stuttering.

Would that scaling method still be relevant if I played 1080i content on a FullHD screen, with XBMC set to "normal" (not "zoom" or anything)?

But I'm happy to try that as well.
find quote
Post Reply