Imac streaming to ATV2 problems

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
sideshow82 Offline
Junior Member
Posts: 4
Joined: Feb 2011
Reputation: 0
Post: #1
Ok not sure where to start, sorry for the novel.

My setup is an Imac with a 1T external WD drive, with all of my movies, music, and photos, and I want to stream to my newly purchased ATV2 with XBMC. I also want to run the Aeon skin. ATV2 was JB with greenpoison, the used nitoTV to install XBMC. not sure if this is even possible, god I hope so....

My issues are...
1. how do I get the ATV to "see" my imac? I've gone into the sharing preferences and added all the folders i want to stream to the ATV, but it won't show up in XBMC.

2.I would have JB it with seasonpass, and ssh xbmc onto the ATV, but i cannot for the life of me ssh into the ATV. I've JB my iphone, and had no problem, but everytime I type in $ ssh root@<your ATV2 IP address> into terminal I get an error -bash: syntax error near unexpected token `newline'

3. Is it even possible to run the Aeon skin on the ATV2? I was using yummy ftp to access the ATV but can't find where to put the skins, and when i would try to install from zip, it would just return with an error.

4. I wanted to JB with greenpoison then just ssh XBMC onto the ATV but again i cannot ssh the ATV for some reason, am I doing something wrong?

Answers to any of these issues is hugely appreciated.

Thank
find quote
sideshow82 Offline
Junior Member
Posts: 4
Joined: Feb 2011
Reputation: 0
Post: #2
ok so i got aeon mq running, its sluggish but its on there, got the atv to see the imac, but I am having issues with the movieDB scraper, keeps coming back unable to connect to network. anything I can do?
find quote
analogsenses Offline
Junior Member
Posts: 1
Joined: Feb 2011
Reputation: 0
Post: #3
Do you have your ATV2 connected to the router by Ethernet? If so, you need to configure the DNS/IP settings before your ATV2 can "see" the Internet. You can do that in the standard configuration menu of the ATV2, not inside XBMC .

That's what happened to me, WiFi worked great, but with Ethernet I could only reach the other computers on my network, but not the Internet. Which means, no YouTube, no iTunes Store, nothing from the outside world.

And since the scrapers need access to the Internet to retrieve the info, they could not connect and I got that error.

Manually setting the IP and DNS fixed this. If you don't know which values to put, check the values on your computer and put the same ones for the DNS and the Router's IP, and change the last digit for the AppleTV's IP address.

Hope this helps. I would look at it even if you're running on WiFi, just in case the configuration got messed up somehow.

Cheers!
find quote
sideshow82 Offline
Junior Member
Posts: 4
Joined: Feb 2011
Reputation: 0
Post: #4
Ok so I got the moviedb scraper to work, what I did was run the Imdb scraper, which worked better than I thought, but then I tried the moviedb scraper and it worked on the first try.

now my only problem is why the cover art for movies looks really...."crappy" not pixelated, almost like someone used the sharpen tool on them in photoshop I guess, they look good on my mac, so i'm not sure, its a new 46" sony Edge LED, so i'm not sure if its supposed to look like that.
find quote
Petapaw Offline
Junior Member
Posts: 1
Joined: Feb 2011
Reputation: 0
Post: #5
Ok I am having the same problem. I actually have the same setup.

Imac with external 1TB HD. I JB my ATV and installed XBMC and I can't get it to see my Imac Hard drive.

Can you please .. please tell me how you got it working ?
find quote
sideshow82 Offline
Junior Member
Posts: 4
Joined: Feb 2011
Reputation: 0
Post: #6
I hooked the ATV2 up to ethernet first, then i set up the SMB sharing on the mac, and then in Xbmc, when looking for sources I went to SMB and it finally managed to see the mac.
find quote