How to compile a PVR branch for iOS.

  Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rivo Offline
Member
Posts: 57
Joined: Feb 2011
Reputation: 0
Post: #46
Hi.
I've two questions.

Is PVR for atv2 compilation compatible with 4.3.x IOS firmwares?
Is possible to use Media Portal like tv server or only works with Tvheadend?

Thanks for all.
find quote
amet Offline
Retired Team-Kodi Member
Posts: 4,113
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #47
rivo Wrote:Hi.
I've two questions.

Is PVR for atv2 compilation compatible with 4.3.x IOS firmwares?
Is possible to use Media Portal like tv server or only works with Tvheadend?

Thanks for all.

1. yes

2. not sure, try it and let us know

Always read the XBMC_Online_Manual,Frequently_Asked_Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log_file.
find quote
rivo Offline
Member
Posts: 57
Joined: Feb 2011
Reputation: 0
Post: #48
I've tested take 3 ios version in Iphone 4 and 3GS and atv2.
Tv server is MediaPortal TV-Server and the result is always the same: xbmc crash when I activate "enable" box in Settings/Live TV/General.
Previously I enable MediaPortal addon and configure it writting the IP server.

If I disable MediaPortal addon and enable Tvheadend addon and try enable Live TV again, same behavior, XBMC crash.

Firewall in server is previously disabled.

Thanks.
find quote
hakensline Offline
Junior Member
Posts: 35
Joined: Mar 2009
Reputation: 0
Post: #49
Hello Amet,

Works for me with take3 and tvheadend ! I have ios 4.2.2 (2203) on my atv2

Mini sound crash and pixel on the screen.

Cpu is on 90% !

Possible to decrease this ?

Tanks for your release ! you use this git for your build ?

https://github.com/opdenkamp/xbmc

Tanks for your reply

Chears

Hak
(This post was last modified: 2011-05-31 20:29 by hakensline.)
find quote
Shoesy Offline
Donor
Posts: 184
Joined: Jan 2010
Reputation: 1
Location: UK
Post: #50
I'm not sure if anyone is going to be doing bug fixes for pvr on appletv but if thats a thing- here is my issues...

Live TV in the viewing window (i.e. not full screen) is very slow and generally makes the whole system unresponsive.

Live TV in fullscreen is better, but nowhere near the quality of just using the 'built in' tvheadend support (i.e. through files view)

Setting the TVheadend plugin was for me very glitchy on ipad - took multiple attempts before it worked, eventually had to reboot and then it was just working.

Timeline EPG view crashes system every time.

Attached is the log for the pvr crashes if anyones interested. (Amet's 'Take three' build

XBMC.log
http://pastebin.com/PRnyJTeC

Crash Log
http://pastebin.com/myDxDRZg

Thanks Wink

Check out my stationery blog- http://www.tailormadeinvites.co.uk
find quote
rivo Offline
Member
Posts: 57
Joined: Feb 2011
Reputation: 0
Post: #51
MediaPortal pvr client works in Xbmc for Atv2 and IOS. I forgot to include TVServerXBMC plugin in TV-Server.

Works streaming, recording scheduled, EPG... but video shows continuous pixelated and freezes.

The server is configured correctly and works fine with XBMC pvr + MediaPortal pvr client on another Windows 7 pc, without freezes

Atv2 is connected to backend system by ethernet cable, so there is not a bandwidth problem.
Live TV in Atv2 works fine by Upnp when I use another tv server (DVBViewer Recording Service). Streaming data are the same for both (Mpeg2 video, 15000 kbps, mp2 audio, 128 kbps...) so I think could be a problem in atv2 MediaPortal pvr client.

Thanks.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #52
what do we say about Mpeg2 video ?


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Shoesy Offline
Donor
Posts: 184
Joined: Jan 2010
Reputation: 1
Location: UK
Post: #53
Is it yay Scott?

I'm thinking it may well be that MPEG2 is not hardware accelerated.

I'm just reporting back as requested, IMO fullscreen is fine for Sd - windowed is a problem. I don't receive hd channels so I can't comment, but I get the feeling they will be a no go.

I've been using .ts streams from tvh for a while now and they work fine using the built in support. But when viewed through the pvr section they stop out, audio gets out of sync and ui gets unresponsive. Sd mpeg2 streams will work even out of xbmc given the right player - I use 'oplayer' on my iPad and even non jail broken iPhone - result is fine, interface is rubbish.

Check out my stationery blog- http://www.tailormadeinvites.co.uk
(This post was last modified: 2011-06-02 00:20 by Shoesy.)
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,478
Joined: Feb 2008
Reputation: 64
Post: #54
MPEG2 is not hardware accelerated.

what's oplayer ?


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Shoesy Offline
Donor
Posts: 184
Joined: Jan 2010
Reputation: 1
Location: UK
Post: #55
Just a crappy media player - http://itunes.apple.com/gb/app/oplayer/id344784375?mt=8
But it let's me watch my tvheadend streams on my non jailbreaked iPhone, so it comes in handy.

Check out my stationery blog- http://www.tailormadeinvites.co.uk
find quote
rivo Offline
Member
Posts: 57
Joined: Feb 2011
Reputation: 0
Post: #56
davilla Wrote:what do we say about Mpeg2 video ?

When I say "freezing", don't talk about buffering problems.
Video is show like a television with a low signal problem (freezes, clicks, pixels..)
However live tv (Mpeg2 video) by Upnp works fine.
Maybe it's a MediaPoral pvr client problem, or rtsp protocol used by MediaPortal TV-Server. I don't know.

Thanks
find quote
hakensline Offline
Junior Member
Posts: 35
Joined: Mar 2009
Reputation: 0
Post: #57
Where is the take 4 ? :-) Tanks amet
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #58
rivo Wrote:When I say "freezing", don't talk about buffering problems.
Video is show like a television with a low signal problem (freezes, clicks, pixels..)
However live tv (Mpeg2 video) by Upnp works fine.
Maybe it's a MediaPoral pvr client problem, or rtsp protocol used by MediaPortal TV-Server. I don't know.

Thanks

This is caused by the build-in RTSP code from FFMPEG. The same signal problems occur also under Windows/Linux on some (not too powerful) systems.
That is why I am working on a better addon that uses Live555 for RTSP stream decoding. This version (called MediaPortal TSReader) performs much better but in its current state it is only available for Windows. Making it cross platform is work-in-progress. After that, I will send a pull request to Dushmaniac to include it.

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
hakensline Offline
Junior Member
Posts: 35
Joined: Mar 2009
Reputation: 0
Post: #59
Do you think one day we will run as pvr xbmc client tvheadend without lag?
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,219
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #60
hakensline Wrote:Do you think one day we will run as pvr xbmc client tvheadend without lag?
what are you talking about?

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
Post Reply