Startup in windows goes back to desktop ?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
HansP Offline
Senior Member
Posts: 291
Joined: Mar 2011
Reputation: 0
Location: Belgium
Post: #1
i set Xbmc in my startupfolder in my start menu but when windows starts it first goes to xbmc , than back to desktop and stays there ... any tips ?
find quote
piipes Offline
Donor
Posts: 120
Joined: Oct 2010
Reputation: 0
Location: Helsinki
Post: #2
You have to set startup delay to xbmc.
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,248
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #3
HansP Wrote:i set Xbmc in my startupfolder in my start menu but when windows starts it first goes to xbmc , than back to desktop and stays there ... any tips ?

By default XBMC uses a DirectX mode that is fast, but that won't share the display with any other app, and if another app gets the focus it forces XBMC to minimise.

In your case the problem is likely to be apps starting and appearing in the tray. If they're slower to start than XBMC they may grab the focus when they start and force XBMC to minimise.

The usual way to get round this is to go into the properties for the XBMC icon in the Startup folder and add the argument -d nnn to the target i.e. the target could be:

"C:\program Files\XBMC\XBMC.exe" -d 10

The number tells XBMC to wait for (in this example) 10 seconds before starting. This gives time for all the other apps to finish their startup. You may need to increase or decrease the number. Try it and see.

You might want to look at what other apps are starting, and maybe uninstall them or configure them not to show a tray icon.

JR
find quote
getafix Offline
Senior Member
Posts: 175
Joined: Nov 2010
Reputation: 0
Post: #4
Try setting your system settings to "use full screen window rather than full screen"

This sorted the problem out for me.
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,248
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #5
getafix Wrote:Try setting your system settings to "use full screen window rather than full screen"

This will fix the problem, because the "full screen window" mode will share the display so XBMC doesn't get forced to minimise. However "full screen window" mode is substantially slower than true fullscreen, and depending on your hardware you may notice the performance hit. A typical symptom is image tearing.

JR
find quote
HansP Offline
Senior Member
Posts: 291
Joined: Mar 2011
Reputation: 0
Location: Belgium
Post: #6
i tried both but 10secs is not enough it seems Confused
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,248
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #7
HansP Wrote:i tried both but 10secs is not enough it seems Confused

Have a look at what else is running on startup. On my Windows XP HTPC I don't need any delay, but the PC is only used for XBMC so nothing else runs at startup.

JR
find quote