[PATCH] Global AV delay support via advancedsettings.xml

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Hack_kid Offline
Fan
Posts: 644
Joined: Jan 2007
Reputation: 4
Post: #31
Oh ok, and no I'm not using the dual audio it wont compile yours is fine though
find quote
sebj Offline
Senior Member
Posts: 181
Joined: Nov 2008
Reputation: 0
Thumbs Up   
Post: #32
@a11599 (weird nickname by the wayLaugh)
Quote:So it does work for you correctly? Eden is in feature freeze so I doubt it will get in, but I can still try to submit a pull to see what others are thinking about it.


Wanted to test this more thoroughly before replying, and I've found a couple things.

First off, my asound.conf was wrong (happens when you spend months on end getting this damn sync to work Tongue)

I'd like to share, this might come up in google, thus helping a fella out.

my asound.conf for hdmi on the geforce 210 is this

Code:
pcm.!default {
type plug
slave {
pcm "hw:0,3"
}
}

I had this :

Code:
pcm.!default {
type plug
slave {
pcm "hw:0,3"
rate 48000
}
}

I put 48000 hoping it would help a while back, but it turns out that for content at 44100hz a delay would seep in. (ie: Bad internet tv rips)

Playing around with sync to display, but I've got modelines in place now so I'll leave it as such until I see a judder.

Pass-through content @23.976 (DTS & AC-3) are way more predictably in sync now, and more importantly for WAF, no need to manually enter a -250ms delay.

About the delay, I'm coming to the same conclusion as you are. I'm leaning to -125ms. This after way too many tests reading lips at 10 inches from a 50inch Kuro. Shocked

Using a AVR-2600 from Harman Kardon.

About the pull, do what you can! Not sure it's a feature actually, it's just another advanced setting for AV nerds to play with.Cool
find quote
Hack_kid Offline
Fan
Posts: 644
Joined: Jan 2007
Reputation: 4
Post: #33
Really 125? I just left it at 250 seems alright to me what do others think
find quote
sebj Offline
Senior Member
Posts: 181
Joined: Nov 2008
Reputation: 0
Post: #34
Yeah really, been at 250 for a hell of a long time.

Gave 125 a shot and it's all around closer for my setup for most videos

44100 and 48000.

But this is with this patch you know.

Lemme explain, if I put -250 some videos I have that have mono sound at 44100 would be a bit out, just going in the audio delay part of the skin, bringing it up would put the sound 100% sync.

Now, with -125 don't have to bring up the gui, which really, is the whole point of putting time in this patch! Laugh
find quote
esprit Offline
Junior Member
Posts: 26
Joined: Apr 2011
Reputation: 0
Location: France
Thumbs Up   
Post: #35
a11599 Wrote:So it does work for you correctly? Eden is in feature freeze so I doubt it will get in, but I can still try to submit a pull to see what others are thinking about it.
I support this Nod
Using it since Sunday, works like a charm, and this will increase the lifetime ot my remote batteries (options => Audio => Audio delay => ....)
And as long as there is no side-effects for people who don't need it (or are ignoring that they do Big Grin )...

A big thanks so !
(This post was last modified: 2012-01-19 21:57 by esprit.)
find quote
sebj Offline
Senior Member
Posts: 181
Joined: Nov 2008
Reputation: 0
Post: #36
Quote:and this will increase the lifetime ot my remote batteries (options => Audio => Audio delay => ....)

Laugh

Man speaks the truth here!
find quote
ashlar Offline
Donor
Posts: 2,093
Joined: Mar 2006
Reputation: 27
Post: #37
Considering AE didn't get through, I would love for this to be included in Eden. Or at least in the following nightlies.

For troubleshooting and bug reporting please make sure you read this first.
find quote
Hack_kid Offline
Fan
Posts: 644
Joined: Jan 2007
Reputation: 4
Post: #38
hey just so everyone knows, i applyed this patch to the AudioEngine branch and it WORKS!!! i really didnt think it would but it still works as the 24htz oos bug is still present in AudioEngine although many said it was to fix it. but this patch is a good work around if anyone wants to try it checkout my github git://github.com/Albinoman887/xbmc.git then git checkout master+AE+AVDelay (wont actually be pushed for a few mins)
find quote
sebj Offline
Senior Member
Posts: 181
Joined: Nov 2008
Reputation: 0
Post: #39
Quote:the 24htz oos bug is still present in AudioEngine

Now that's dissapointing.... Sad
find quote
a11599 Offline
Team-XBMC Member
Posts: 298
Joined: Sep 2010
Reputation: 3
Location: Budapest, Hungary
Post: #40
Actually I am pretty confident it is not the current audio subsystem causing the delay but something else. So I am not actually surprised that the delay is still required...
find quote
sebj Offline
Senior Member
Posts: 181
Joined: Nov 2008
Reputation: 0
Post: #41
Well the first step to recovery is admitting you have a problem I guess Smile

Here's a serious +1 to roll this advancedsetting in eden.

Who can push this through?
find quote
Bonzi Offline
Member
Posts: 50
Joined: Feb 2011
Reputation: 0
Post: #42
+1 for me too. I would love to see this get fixed in time for Eden.
find quote
Hack_kid Offline
Fan
Posts: 644
Joined: Jan 2007
Reputation: 4
Post: #43
OK so I think recent commits to the AE branch broke this patch its now applying the AV delay for 24 htz a cross all refresh rates can you help me fix it as aeae is going to be merged very soon anyway
find quote
Hack_kid Offline
Fan
Posts: 644
Joined: Jan 2007
Reputation: 4
Post: #44
disregard previous post, i figured it out, using the diff patch no longer worked but merging your commit in directly did the trick i'm asuming because i was using a diff patch and the code base had changed too much. now it seems to be working as it should, thanks
find quote
ashlar Offline
Donor
Posts: 2,093
Joined: Mar 2006
Reputation: 27
Post: #45
Is there anyone playing back 24fps material without needing to adjust the delay? If there is, fine. If there isn't, I really think this should make it into heaven. It is a bug, why not fixing it? Definitely not a feature request.

For troubleshooting and bug reporting please make sure you read this first.
find quote
Post Reply