[RELEASE] Pneumatic

  Thread Rating:
  • 8 Votes - 4.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
for4saken Offline
Junior Member
Posts: 7
Joined: Oct 2012
Reputation: 0
Post: #1636
Sorry for the late reply - traveling.

(2014-02-05 00:39)Popeye Wrote:  All I can think of is some sort of naming mismatch between the strm, the nzb and SAB causing pneumatic not to find the nzb in the SAB queue...

But it does find it, after restarting XBMC and re-initiating playback, it will stream from the nzb send to SAB in the first time.
find quote
RavRob Offline
Junior Member
Posts: 40
Joined: Dec 2012
Reputation: 0
Post: #1637
Pneumatic stopped working in Gotham Beta 1. Anything I can do to fix this or will only an update will get this going again?
find quote
Popeye Offline
Posting Freak
Posts: 909
Joined: Aug 2009
Reputation: 26
Location: Sweden
Post: #1638
(2014-03-05 15:46)RavRob Wrote:  Pneumatic stopped working in Gotham Beta 1. Anything I can do to fix this or will only an update will get this going again?

I haven't bothered to look at Gotham yet Big Grin Guess it's time to take a look now when Beta1 is out. Please PM a log/log link and I'll take look a can do a work load estimate..

sverigesradio | Pneumatic | SABnzbd | XBMC that just works - openelec
find quote
RavRob Offline
Junior Member
Posts: 40
Joined: Dec 2012
Reputation: 0
Post: #1639
Thanks Popeye. Log sent via PM
find quote
versus Offline
Member
Posts: 74
Joined: Aug 2011
Reputation: 0
Post: #1640
Gotham 2
Search gives "malformed result"
Site ID and NZB key to nzb.su copied correctly to addon settings
Any chances to fix this?


from log

ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.AttributeError'>
Error Contents: Cache instance has no attribute 'path'
Traceback (most recent call last):
File "C:\Users\Toni\AppData\Roaming\XBMC\addons\xbmc-newznab-master\default.py", line 577, in <module>
newznab('1')
File "C:\Users\Toni\AppData\Roaming\XBMC\addons\xbmc-newznab-master\default.py", line 153, in newznab
table = site_caps(index)
File "C:\Users\Toni\AppData\Roaming\XBMC\addons\xbmc-newznab-master\default.py", line 78, in site_caps
doc, state = load_xml(url)
File "C:\Users\Toni\AppData\Roaming\XBMC\addons\xbmc-newznab-master\default.py", line 481, in load_xml
return CACHE.fetch(url)
File "C:\Users\Toni\AppData\Roaming\XBMC\addons\xbmc-newznab-master\cache.py", line 44, in fetch
url = Url(url_in, self.path, self.seconds)
AttributeError: Cache instance has no attribute 'path'
-->End of Python script error report<--
14:47:36 T:7112 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.newznab/
14:47:36 T:7112 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.newznab/) failed
(This post was last modified: 2014-03-23 16:52 by versus.)
find quote
versus Offline
Member
Posts: 74
Joined: Aug 2011
Reputation: 0
Post: #1641
EDIT: New site URL is api.nzb.su not nzb.su anymore. That was the problem.
find quote
for4saken Offline
Junior Member
Posts: 7
Joined: Oct 2012
Reputation: 0
Post: #1642
(2014-02-05 00:39)Popeye Wrote:  All I can think of is some sort of naming mismatch between the strm, the nzb and SAB causing pneumatic not to find the nzb in the SAB queue...

The missing from the queue thing was due to a SABnzbd option called Check before download - Try to predict successful completion before actual download (slower!)

After SAB checked the download, Pneumatic would consider it as missing until restarting XBMC. Disabling it works (but the optimal behavior would be if it were compatible).

Anyhow, the other issue still stands, i.e. choosing 'Just download' or 'Delete' makes XBMC unresponsive.
(This post was last modified: 2014-03-26 00:27 by for4saken.)
find quote
pengocha Offline
Junior Member
Posts: 19
Joined: May 2012
Reputation: 0
Post: #1643
Can someone tell me what to put in the site id and site key? Can't seem to figure it out with binsearch.info & nzbindex.com. Also keep getting 'malformed result' and from what information i've gathered that could be causing the problem?
find quote
ursli Offline
Senior Member
Posts: 284
Joined: Nov 2011
Reputation: 7
Post: #1644
I'm having trouble with the sab category vanishing when repairing a file. When I do manual download category is set, normal streaming category is set too. As soon as a download is finished and I need to repair the file in the delete/repair dialog that pops up the category is lost.

Not sure if logs would help, but I can PM those if needed, I can reproduce it every time though.

@pengocha those are nzb search engines not newznab indexers, you wont make it work with those.
find quote
tomas123100 Offline
Junior Member
Posts: 1
Joined: Apr 2014
Reputation: 0
Post: #1645
Hi everyone I am having some problems adding https://api.nzb.su to newznab. I tried changing all http adresses in default.py to https but still it didn't work.
Do anyone have the same problem? And maybe knows how to fix it?
(This post was last modified: 2014-04-18 16:27 by tomas123100.)
find quote
Post Reply