PVR vnsi Plugin not workling anymore.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
voyager_mp Offline
Junior Member
Posts: 30
Joined: Apr 2009
Reputation: 0
Post: #1
<code>
ERROR: AddOnLog: xbmc.pvrclient/VDR VNSI Client: cVNSISession::Open - failed to read greeting from server
ERROR: ADDON: Dll VDR VNSI Client - Client returned bad status (1) from Create and is not usable
INFO: Called Add-on status handler for '1' of clientName:VDR VNSI Client, clientID:pvr.vdr.vnsi (same Thread=no)
ERROR: PVR - LoadClients - can't initialise client 'VDR VNSI Client'
</code>

after updateing to Version: 2:11.0-pvr+odk14~git20110324.28a2544~ppa+odk14~maverick
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,209
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #2
you'll probably have to update the vnsi plugin:
https://github.com/pipelka/vdr-plugin-vnsiserver

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
voyager_mp Offline
Junior Member
Posts: 30
Joined: Apr 2009
Reputation: 0
Post: #3
Sorry, does not solve the problem.
Going back to git20110313 worked. Found the .deb in backup.

If anyone need's them, just post.
find quote
succo Offline
Fan
Posts: 361
Joined: Mar 2008
Reputation: 0
Location: Taranto, Italy
Post: #4
look at this... i noticed that, even if i changed VNSIProtocolVersion to 1 it changed back so it was not working anymore and, in syslog, there were calls to unknown protocol version 2
so, change that line of code and it will work again Smile

edit: btw, did you really update the vnsi vdr plugin? in github there is protocol version 2, but i'm too lazy to update it, i am waiting for the ppa i'm using to update it for me Smile
(This post was last modified: 2011-03-26 20:56 by succo.)
find quote
voyager_mp Offline
Junior Member
Posts: 30
Joined: Apr 2009
Reputation: 0
Post: #5
problem solves, I had to rebuild the vdr, not just the vnsi plugin. Now it works, beside the recordings. Here only this {} apears. Since I dont need this, its fine with me.

thx
find quote
Krautmaster Offline
Senior Member
Posts: 204
Joined: Jul 2010
Reputation: 1
Post: #6
i have a problem with live tv and vnsi too...

i installed vdr 1.7.16 with this tutorial:
http://schnere.bveml.net/de/content/howt...idmaverick

and checkt out the latest xbmc ink Tv from

https://github.com/opdenkamp/xbmc

Works finde so far but after one hour of TV xbmc crashes without any action from my side:

Crashlos last lines:

Quote:22:04:18 T:140611065227008 M:390955008 DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/Alle TV Kanäle/1.pvr)
22:04:18 T:140610736400128 M:390959104 WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 5223, consumed: 0
22:04:18 T:140610736400128 M:390959104 WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 2753, consumed: 0
22:04:18 T:140611065227008 M:390959104 DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 0:0 with codec_id 28
22:04:18 T:140611065227008 M:390959104 DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 1:1 with codec_id 86016
22:04:18 T:140611065227008 M:390959104 DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 2:2 with codec_id 86016
22:04:18 T:140611065227008 M:390959104 DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 3:3 with codec_id 86019
22:04:18 T:140611065227008 M:390959104 DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 4:4 with codec_id 94215
22:04:18 T:140610736400128 M:390959104 WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 6756, consumed: 0
22:04:18 T:140610736400128 M:390959104 WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 6593, consumed: 0
22:04:19 T:140611065227008 M:390959104 DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/Alle TV Kanäle/1.pvr)
22:04:19 T:140610736400128 M:390959104 WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 4803, consumed: 0
22:04:19 T:140610736400128 M:390959104 WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 3888, consumed: 0
22:04:19 T:140610736400128 M:390959104 WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 4361, consumed: 0
22:04:19 T:140610736400128 M:390959104 WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 4557, consumed: 0
22:04:20 T:140611065227008 M:390705152 DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/Alle TV Kanäle/1.pvr)


############### END LOG FILE ################

############ END XBMC CRASH LOG #############

any ideas? VSNI Plugin, VDR, XBMC or tv card driver? xD
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,209
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #7
probably the add-on.
could you post the full crashlog?

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote