[LINUX] Tearing on Nvidia? Read this.

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Information  [LINUX] Tearing on Nvidia? Read this.
Post: #1
When XBMC is used with Nvidia hardware, tearing will occur when the X composite extension is used.


Solution 1: (thanks to chessplayer for pointing this out)

Enable "Unredirect Fullscreen Window" in Compiz Config Settings Manager.

An easy solution for this is described in the following thread on ubuntuforums.org. This is actually quite easy.

In short, what must be done is

  1. Install CCSM (Compiz Config Settings Manager)
    Code:
    sudo apt-get install compizconfig-settings-manager
  2. Check the option "Unredirect Fullscreen Window"


For Ubuntu, this option is found in the "General" section of CCSM until 10.10 (Maverick). In Natty (due to Unity), it has been moved to the "Composite" section.


Solution 2:

Disable the composite extension.

Add this to the end of /etc/X11/xorg.conf: (make a new file if xorg.conf doesn't exist)
Code:
Section "Extensions"
  Option "Composite" "Disable"
EndSection

Then log in with a gnome classic session (without the composite extension compiz doesn't work).

Also make sure to set Vertical blank sync to Always enabled in XBMC.
(This post was last modified: 2012-05-08 12:35 by zag.)
find