Is Apple TV 2g Software version 4.2.1 (2100) running on iOS 4.3?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Arturito.net Offline
Junior Member
Posts: 3
Joined: Apr 2011
Reputation: 0
Post: #1
Can someone confirm if this is true?

I had XBMC running on Apple TV 2G software version 4.1.1 which is iOS 4.2.1
Than it was updated to software version 4.2.1 (2100).

Does it mean that iOS was also updated to 4.3 or it is possible that only software version was updated and iOS is still 4.2.1 ?
find quote
Maetrik Offline
Donor
Posts: 417
Joined: Jan 2011
Reputation: 1
Location: Berlin, Germany
Post: #2
4.2.1 (2100) for ATV2 is iOS 4.3.1
find quote
jd2157 Offline
Fan
Posts: 642
Joined: Jan 2011
Reputation: 0
Location: Nova Scotia
Post: #3
Arturito.net Wrote:Can someone confirm if this is true?

I had XBMC running on Apple TV 2G software version 4.1.1 which is iOS 4.2.1
Than it was updated to software version 4.2.1 (2100).

Does it mean that iOS was also updated to 4.3 or it is possible that only software version was updated and iOS is still 4.2.1 ?

Yes, I'm pretty sure if you're running Apple TV software 4.2.1 you're also running iOS 4.3. There's a lot of confusion re: the latest iOS version but from what I'm reading it's 4.3 and not 4.3.1 yet. Setting > General > Apple TV software says 4.2.1 (2100) and clicking Select says 4.3 (8F202). Someone here said that's because Apple TV doesn't display the last digit in the iOS build (i.e. so we don't see the .1) but I don't think that's the case.

http://www.iclarified.com/entry/index.php?enid=970
http://support.apple.com/kb/HT4448
http://en.wikipedia.org/wiki/IOS_version...:_Apple_TV
find quote
Arturito.net Offline
Junior Member
Posts: 3
Joined: Apr 2011
Reputation: 0
Post: #4
Thanks for the prompt reply.

My friend has updated his Apple TV 2G to software version 4.2.1 (2100). So it means that iOS version got updated to 3.4.x. Jailbreak and XBMC was gone.

I used Sn0wBreeze to jailbreak it again but XBMC was giving Audio Device Error and it wasn't able to play MKV files.

I managed to restore to software version 4.1.1 (iOS 4.2.1) and jailbreak it with Green Pois0n RC6.1. Jailbreak worked and installed XBMC without any problem.

The interesting thing is that I did not need SHSH blobs.
XBMC works as normal!

How is that possible?

I described the whole process here:

http://arturito.net/2011/04/12/apple-tv-...3-working/
find quote
Arturito.net Offline
Junior Member
Posts: 3
Joined: Apr 2011
Reputation: 0
Post: #5
Arturito.net Wrote:Thanks for the prompt reply.

So it means that iOS version got updated to 3.4.x.

Sorry I mean 4.3.x
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,219
Joined: Feb 2011
Reputation: 114
Location: germany
Post: #6
Apple still signs 4.2.1 ... so you don't need the blobs for now ... but this could change every second now *g*
find quote
jd2157 Offline
Fan
Posts: 642
Joined: Jan 2011
Reputation: 0
Location: Nova Scotia
Post: #7
Arturito.net Wrote:I used Sn0wBreeze to jailbreak it again but XBMC was giving Audio Device Error and it wasn't able to play MKV files.

I managed to restore to software version 4.1.1 (iOS 4.2.1) and jailbreak it with Green Pois0n RC6.1. Jailbreak worked and installed XBMC without any problem.

The interesting thing is that I did not need SHSH blobs.
XBMC works as normal!

How is that possible?

The most important things to note from what you've written are:
- Sn0wbreeze = problems, at least for now, Greenpois0n/pwnagetool are the best options for iOS 4.2.1 and Seas0npass for iOS 4.3.

- You don't need SHSH blobs to restore at the moment because Apple's still signing iOS 4.2.1 for atv2 so when iTunes checks with Apple's servers to see if you're allowed to install 4.2.1 it lets you.

- Apple could stop signing iOS 4.2.1 at ANY time and as soon as they do you'll no longer be able to save your 4.2.1 SHSH blobs and if you don't have them saved you'll never be able to install iOS 4.2.1 onto your atv2 ever. Once Apple stops signing, those with SHSH blobs saved can use Tiny Umbrella's TSS server to install iOS 4.2.1... those without them saved can't.
find quote