XBMC Community Forum
[RELEASE] XBMC Subtitles - Addon Script - Printable Version

+- XBMC Community Forum (http://forum.xbmc.org)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Subtitle Add-ons (/forumdisplay.php?fid=143)
+---- Thread: [RELEASE] XBMC Subtitles - Addon Script (/showthread.php?tid=126495)



[RELEASE] XBMC Subtitles - Addon Script - amet - 2012-03-25 14:22

This Addon will search, display and then download subtitles for the currently running movie from various subtitle sites.

this thread will replace 207 page thread we had before. A lot of issues have been fixed there and there is no use having the thread that size.

#########################################################

please understand that we cant even begin to help without Debug Log, do not post "do you need Debug Log". YES, we always need Debug Log to debug the addon.

1. if you dont provide Debug Log, we cannot provide any help.
2. did you provide Debug Log?
3. did you read this?
4. did you provide Debug Log?
5. FULL Debug Log is always needed


#########################################################

Broken Service?? --> http://forum.xbmc.org/showthread.php?tid=126495&pid=1205052#pid1205052

if you are looking for Addic7ed service --> http://forum.xbmc.org/showthread.php?tid=75437&pid=717657#pid717657

#########################################################

Set it up by selecting the required subtitle languages to search for

[Image: s1.jpg]

Choose services you would like to use for your search

[Image: s2.jpg]

You can also set various Advanced settings, like default service for movie/tvshow search and subtitle download folder

[Image: s3.jpg]

After you start the move, start the addon by selecting the subtitle button

[Image: r1.jpg]

Addon will display the list of subtitles and you can now select the one you like

[Image: r2.jpg]


RE: [RELEASE] XBMC Subtitles - Addon Script - Delocaz - 2012-03-25 15:04

Can you add support for TVSubtitles? It has a lot of subs for The Simpsons.

Also, first Smile


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-03-25 15:06

(2012-03-25 15:04)Delocaz Wrote:  Can you add support for TVSubtitles? It has a lot of subs for The Simpsons.

Also, first Smile

I dont usually honor the requests to add sites unless the request comes from the site administrator.


RE: [RELEASE] XBMC Subtitles - Addon Script - Delocaz - 2012-03-25 15:24

I found Addic7ed as an alternative to TVSubtitles, how would i go about adding that? The link you posted doesn't help...


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-03-25 15:26

(2012-03-25 15:24)Delocaz Wrote:  I found Addic7ed as an alternative to TVSubtitles, how would i go about adding that? The link you posted doesn't help...

the link I posted about Addic7ed service has all I have to say about that service, let me know if I need to clarify it further


RE: [RELEASE] XBMC Subtitles - Addon Script - flippamike - 2012-03-25 16:04

Quote:
Quote: flippamike Wrote: Hallo,

Sometimes when i want a subtitle to be found xbmc subtitles is giving this error.

Error : 'ascii' codec can't decode byte 0xe9 in position 115: ordinal not in range (128)

Can someone help me with this error ?


not without debug log

Dir amet,

Here you can find my log http://pastebin.com/NCXym6D4

Thank you!!


RE: [RELEASE] XBMC Subtitles - Addon Script - tebicenter - 2012-03-25 18:39

Pulled changes to github, thanks!


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-03-25 19:07

(2012-03-25 16:04)flippamike Wrote:  
Quote:
Quote: flippamike Wrote: Hallo,

Sometimes when i want a subtitle to be found xbmc subtitles is giving this error.

Error : 'ascii' codec can't decode byte 0xe9 in position 115: ordinal not in range (128)

Can someone help me with this error ?


not without debug log

Dir amet,

Here you can find my log http://pastebin.com/NCXym6D4

Thank you!!

I dont see that error in the log, please reproduce it and attach the log of that session


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-03-25 19:07

(2012-03-25 18:39)tebicenter Wrote:  Pulled changes to github, thanks!

thx a lot, will push it in soon


RE: [RELEASE] XBMC Subtitles - Addon Script - helcik - 2012-03-26 03:08

hey, I will revert back to the problem of opensubtitles.org (did not check other providers, may be a general issue). The TXT files do not work on Windows machines.
The casue of the problem is the line Unix/Linux line separator CR (0x0D) instead windows CRLF (0x0D0A). The subtitles are not displayed, just one line at the beginning.

IT will not revile on OSX as most probably is it Unix based.
SRT files are OK.
2.9.38

Pls, let me know how to handle this.


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-03-26 08:38

(2012-03-26 03:08)helcik Wrote:  hey, I will revert back to the problem of opensubtitles.org (did not check other providers, may be a general issue). The TXT files do not work on Windows machines.
The casue of the problem is the line Unix/Linux line separator CR (0x0D) instead windows CRLF (0x0D0A). The subtitles are not displayed, just one line at the beginning.

IT will not revile on OSX as most probably is it Unix based.
SRT files are OK.
2.9.38

Pls, let me know how to handle this.

not sure what to tell you, I cant see that error on OSX Sad

also, we dont do anything to the file itself, we just unzip it after we download from OpenSubtitles... so if the error is in the file, the error comes from the way OpenSubtitles does it or how someone uploaded it.


RE: [RELEASE] XBMC Subtitles - Addon Script - helcik - 2012-03-26 17:36

any simple code to replace 0x0D with 0x0D0A at the end of each line on downloaded file?
alternatively, is there a global setting for XBMC to set the line separator for text files?


RE: [RELEASE] XBMC Subtitles - Addon Script - snowatom - 2012-03-27 17:59

Hi all

Don't know if you can help me, without further information. But here goes.

I have installed XBMC eden 11.0 on my ATV2. And everything works great, but no matter what movie I choose, and no matter what service I use to search for subtitles, I get the messege "No subtitles found!", which could be through, but it says so, even if i manually put in movie filename.

On my pc with same search terms, I will find subtitles on the same sites.

What can I do to fix this ? - I have searched around, and it does not seem that others are experiensing same problem as me. My ATV2 is running latest unteathered hack on version 4.4.4.

Thank you in advance

snowatom


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-03-28 00:00

(2012-03-27 17:59)snowatom Wrote:  Hi all

Don't know if you can help me, without further information. But here goes.

I have installed XBMC eden 11.0 on my ATV2. And everything works great, but no matter what movie I choose, and no matter what service I use to search for subtitles, I get the messege "No subtitles found!", which could be through, but it says so, even if i manually put in movie filename.

On my pc with same search terms, I will find subtitles on the same sites.

What can I do to fix this ? - I have searched around, and it does not seem that others are experiensing same problem as me. My ATV2 is running latest unteathered hack on version 4.4.4.

Thank you in advance

snowatom

Debug Log please


RE: [RELEASE] XBMC Subtitles - Addon Script - snowatom - 2012-03-28 16:58

Hi amet

Thanks for pointing out the location of the XBMC log file, that gave me a chance for a little debuggin on my own. Seems like the subtitle addon only accepts raw media file formats, and not media files contained in a RAR file structure which XBMC is plays just fine.

So in order to use the subtitle addon, I have to extract movies first.

Is this a known limit in the ATV2 XBMC version, or should it work ? If so I will upload a logfile.

snowatom