Install XBMC double list

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Siggelito Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #1
Hello,

I got a problem when trying to install XBMC after I have jailedbreaked it. When i'm going to run apt-get update it goes all fine until i get this message.

Apple-TV:~ root# apt-get install wget
Reading package lists... Done
Building dependency tree... Done
wget is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Apple-TV:~ root# wget -O- http://apt.awkwardtv.org/awkwardtv.pub | apt-key add -
/usr/bin/apt-key: line 161: run-parts: command not found
--2011-12-29 16:21:52-- http://apt.awkwardtv.org/awkwardtv.pub
Resolving apt.awkwardtv.org... 74.208.75.216
Connecting to apt.awkwardtv.org|74.208.75.216|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1698 (1.7K) [text/plain]
Saving to: `STDOUT'

100%[===============================================================>] 1,698 --.-K/s in 0s

2011-12-29 16:21:53 (11.9 MB/s) - `-' saved [1698/1698]

OK
Apple-TV:~ root# echo "deb http://apt.awkwardtv.org/ stable main" > /etc/apt/sources.list.d/awkwardtv.li st
Apple-TV:~ root# echo "deb http://mirrors.xbmc.org/apt/atv2 ./" > /etc/apt/sources.list.d/xbmc.list
Apple-TV:~ root# apt-get update
Get:1 http://apt.awkwardtv.org stable Release.gpg [198B]
Ign http://mirrors.xbmc.org ./ Release.gpg
Get:2 http://apt.thebigboss.org stable Release.gpg [197B]
Get:3 http://apt.saurik.com tangelo-3.7 Release.gpg [189B]
Get:4 http://nitosoft.com Release.gpg [487B]
Get:5 http://apt.awkwardtv.org stable Release [1033B]
Get:6 http://apt.thebigboss.org stable Release [12.5kB]
Ign http://mirrors.xbmc.org ./ Release
Get:7 http://apt.saurik.com tangelo-3.7 Release [630B]
Get:8 http://nitosoft.com Release [295B]
Get:9 http://cydia.zodttd.com stable Release.gpg [189B]
Get:10 http://mirrors.xbmc.org ./ Packages [527B]
Get:11 http://apt.modmyi.com stable Release.gpg [189B]
Get:12 http://apt.awkwardtv.org stable/main Packages [12.2kB]
Get:13 http://apt.saurik.com tangelo-3.7/main Packages [24.2kB]
Get:14 http://nitosoft.com Packages [3583B]
Get:15 http://cydia.zodttd.com stable Release [1616B]
Get:16 http://apt.thebigboss.org stable/main Packages [852kB]
Get:17 http://cydia.zodttd.com stable/main Packages [1328kB]
Get:18 http://apt.modmyi.com stable Release [1331B]
Get:19 http://apt.modmyi.com stable/main Packages [1808kB]
Fetched 4047kB in 1min 20s (50.0kB/s)
Reading package lists... Done
W: Duplicate sources.list entry http://apt.awkwardtv.org stable/main Packages (/var/lib/apt/lists/apt.aw kwardtv.org_dists_stable_main_binary-iphoneos-arm_Packages)
W: You may want to run apt-get update to correct these problems

Anyone know if this problem is something that is gonna interfere with the usage of the ATV2?

Best regards
Siggelito
find quote
jhonny30 Offline
Senior Member
Posts: 153
Joined: Jan 2009
Reputation: 1
Post: #2
had the same and i continued with apt-get update a few times...after 6 or 7 times it was ok
find quote
Siggelito Offline
Junior Member
Posts: 6
Joined: Dec 2011
Reputation: 0
Post: #3
jhonny30 Wrote:had the same and i continued with apt-get update a few times...after 6 or 7 times it was ok


It worked after I have done that command after like 10 times so thank you so much!
(This post was last modified: 2011-12-30 13:13 by Siggelito.)
find quote
fritzboyle Offline
Donor
Posts: 44
Joined: Apr 2011
Reputation: 0
Location: Oakland CA
Post: #4
OMG. I was searching all over the interwebs to solve this problem....I had done the apt-get update several times in relation to other (more complex) solutions.

Then I get back here, to our newly updated XBMC forums and I read jhonny30's post and did apt-get update one more time....BOOM! seems to be solved.

Thanks, people.

Peace,
Fritz Boyle

ATV2 iOS 5.2 XBMC 13.0
USB SmartStick android 4.1.1 XBMC 12.3
OUYA XBMC 12.3
MBP OSX Mavericks XBMC 12.3
find quote
BlackPanther Offline
Junior Member
Posts: 28
Joined: Feb 2012
Reputation: 0
Location: The Jungle
Post: #5
W: Duplicate sources.list entry http://apt.awkwardtv.org stable/main Packages (/var/lib/apt/lists/apt.aw kwardtv.org_dists_stable_main_binary-iphoneos-arm_Packages)
W: You may want to run apt-get update to correct these problems

I have taken the time to pose these exact same issues in APTVForums, with no response as of yet...will update with any new infoBig Grin

I too am having Duplicates issue, which began after upgrading my nitoTV to latest update(march/02/2012)...this has not had an effect on XBMC at all, but has been causing multiple crashes in native menu screen (which i also like to use): nitoTv>manage>sources>while in sources you will see at the very top 2 identical copies of AwkwardTV sources as you toggle down to mirrors.xbmc>once you enter seatbeltunlock or try to move select or exit, you will crash back to native screen(not by choice)...another crash occurs while in Internet>Radio in native menu...while listening to a radio channel everything is fine, but when you try changing to various other radio channels it will also crash back to native menu screen...it never did this before, not until the latest NitoTV update...without nitoTv installed at all the radio channels can be switched and play perfectly...with nitoTV installed and updated/upgraded is when the duplicates W: message appears and causes the APTV2 to act finnicky and odd throughout the native screen...if possible can someone also please confirm these findings....As have been instructed to use apt-get update to correct this....Although i have used apt-get update at lest 7 times and reboot in ssh and crashes/returns to native screen still occurs leading me to believe that the apt-get update has not fully corrected the duplicates issue...thank-you all for your time...
(This post was last modified: 2012-03-16 03:52 by BlackPanther.)
find quote
fritzboyle Offline
Donor
Posts: 44
Joined: Apr 2011
Reputation: 0
Location: Oakland CA
Post: #6
(2012-03-12 18:48)fritzboyle Wrote:  OMG. I was searching all over the interwebs to solve this problem....I had done the apt-get update several times in relation to other (more complex) solutions.

Then I get back here, to our newly updated XBMC forums and I read jhonny30's post and did apt-get update one more time....BOOM! seems to be solved.

Thanks, people.

FYI- when I recently updated my ATV2 to 5.3 and was pushing XBMC via terminal commands, I ran into this "issue" again. I was trying to remember what it meant, did a search and BOOM (to use my old term) this post came up. I went back to the terminal and sent the apt-get update command one more time and it resolved.

I am reposting to bubble up the issue for others as well as to thank the XBMC forum once again for your continued help over the years.

Peace,
Fritz Boyle

ATV2 iOS 5.2 XBMC 13.0
USB SmartStick android 4.1.1 XBMC 12.3
OUYA XBMC 12.3
MBP OSX Mavericks XBMC 12.3
find quote