Bob Deinterlacing

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Brent212 Offline
Member
Posts: 83
Joined: Oct 2009
Reputation: 0
Post: #1
I've seen posts where a bob deinterlacing option is mentioned. Is this not available in the Windows version, or am I missing something? I installed Eden and there's no bob option as far as I can tell.
find quote
PatK Offline
Donor
Posts: 3,445
Joined: Mar 2010
Reputation: 75
Location: Canada
Post: #2
Didn't see the context of the message talking about DXVA Bob, but it can be found when playing a video, accessing video settings>deinterlacing 'on' next item is method; DXVA Bob is now a choice in Eden.
find quote
Brent212 Offline
Member
Posts: 83
Joined: Oct 2009
Reputation: 0
Post: #3
The only options I have there are auto, deinterlace, and something like "software".
find quote
PatK Offline
Donor
Posts: 3,445
Joined: Mar 2010
Reputation: 75
Location: Canada
Post: #4
If you're not using DXVA and hardware acceleration (option in settings), you will not see DXVA Bob in the video OSD
find quote
StinDaWg Offline
Fan
Posts: 587
Joined: Jul 2011
Reputation: 1
Post: #5
Bob deinterlacing sucks. Hopefully you have a graphics card that can do at least motion adaptive or preferably vector adaptive.
find quote
Brent212 Offline
Member
Posts: 83
Joined: Oct 2009
Reputation: 0
Post: #6
I'll be happy with anything that doubles the framerate.
find quote
a11599 Offline
Team-Kodi Member
Posts: 305
Joined: Sep 2010
Reputation: 3
Location: Budapest, Hungary
Post: #7
You need to enable DXVA rendering. Then you will have the DXVA deinterlacing options for all your videos.

My patches (source code) :: Windows installer builds
These builds are unofficial! If you find a bug, make sure it is also present in a recent official build and you can reproduce it before filing a ticket.
find quote
Brent212 Offline
Member
Posts: 83
Joined: Oct 2009
Reputation: 0
Post: #8
Thanks! I had rendering set to "auto" with hardware acceleration checked, so I thought it would use whatever rendering method produces the highest quality video, but apparently whatever it chose wasn't dxva. When I changed "auto" to dxva, I got the extra deinterlacing options. "DXVA Best" seems to do the best job.
find quote
Livin Offline
Posting Freak
Posts: 3,548
Joined: May 2004
Reputation: 17
Location: above ground
Post: #9
(2012-04-10 16:12)a11599 Wrote:  You need to enable DXVA rendering. Then you will have the DXVA deinterlacing options for all your videos.

I set to DXVA but there are no additional settings under Settings/Video to choose the deinterlacing method... why?

I'm not an expert but I play one at work.
find quote
steelman1991 Offline
Donor
Posts: 2,434
Joined: Jan 2009
Reputation: 10
Post: #10
Livin - what build are you using? I'm using a nightly build - nobody else has mentioned their build here, wonder if its been recently introduced - don't remember seeing it in 11.0, but might just have missed it because I wasn't looking for it. Only started digging after StinDaWg queried my set-up for interlaced content.

EDIT - sorry Livin misread your post. That's not where you'll find the options - they're under the OSD while playing a video. They can be amended there and set as default for all movie playback.
(This post was last modified: 2012-06-17 12:11 by steelman1991.)
find quote