newest nightly build - 3 new BUGS

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
PKOneTwo Offline
Senior Member
Posts: 145
Joined: Jan 2008
Reputation: 1
Post: #1
Hi i think i found 3 bugs:

Compiled newest build (80e7c22d9e) and deleted database and let it build it up again:
- it downloads the actors photos (for movies database) although i have disable that in the config -> Video meu
- if you press the info button on a mvie in your databes, you now don't see the plot anymore
- tv shows is COMPLETELY messed up: it founds them, but it oesn't download fanrt or banner anymore...you have to do that yurself or it does it veeeeeeeeeeeeeeeeeeery slowly, when you select a show

BTW: i use thetvdb.com and themoviedb.com, both scraper working fine with and older nightly (3 days ago).

Dind't know where too post this, so did it here.
find quote
PKOneTwo Offline
Senior Member
Posts: 145
Joined: Jan 2008
Reputation: 1
Post: #2
Just asking because i think this is a serious problem for library management in XBMC (newest nightly build 80e7c22d9e and after that perhaps).
find quote
drivesoslow Offline
Fan
Posts: 467
Joined: Aug 2008
Reputation: 4
Post: #3
I would open a trac ticket rather than posting here: http://trac.xbmc.org/

Or at least post it either the Linux or Windows subforum
(This post was last modified: 2012-05-10 01:30 by drivesoslow.)
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #4
Thanks for testing.

Please don't open a trac ticket until we've confirmed there's actually an issue.

1. Actor photos no longer download, so that one is already fixed.

2. Yup - I see it. You'll note it comes back if you toggle between cast + plot. Probably an uninited var - will fix.
EDIT: fixed in 15b0586142a5edbb58e9781291f5b900f2094d59.

3. This is because we have to refetch all the art due to the changed layout. It takes a while, particularly if there's a lot queued up (in particular, if there's some links that are stale - they take a while to timeout). If things REALLY don't ever load, then get a Debug Log.

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
(This post was last modified: 2012-05-10 02:36 by jmarshall.)
find quote
PKOneTwo Offline
Senior Member
Posts: 145
Joined: Jan 2008
Reputation: 1
Post: #5
(2012-05-10 01:26)drivesoslow Wrote:  I would open a trac ticket rather than posting here: http://trac.xbmc.org/

Or at least post it either the Linux or Windows subforum

This is why :-)

(2012-05-10 02:29)jmarshall Wrote:  Thanks for testing.

Please don't open a trac ticket until we've confirmed there's actually an issue.

1. Actor photos no longer download, so that one is already fixed.

2. Yup - I see it. You'll note it comes back if you toggle between cast + plot. Probably an uninited var - will fix.
EDIT: fixed in 15b0586142a5edbb58e9781291f5b900f2094d59.

3. This is because we have to refetch all the art due to the changed layout. It takes a while, particularly if there's a lot queued up (in particular, if there's some links that are stale - they take a while to timeout). If things REALLY don't ever load, then get a debug log.

Cheers,
Jonathan

Allright, thx, thats good news.
I'll check the third point again. Making a new nightly build and a complete fresh install of xbmc.
Will report back.
find quote
PKOneTwo Offline
Senior Member
Posts: 145
Joined: Jan 2008
Reputation: 1
Post: #6
(2012-05-10 02:29)jmarshall Wrote:  Thanks for testing.

Please don't open a trac ticket until we've confirmed there's actually an issue.

1. Actor photos no longer download, so that one is already fixed.

2. Yup - I see it. You'll note it comes back if you toggle between cast + plot. Probably an uninited var - will fix.
EDIT: fixed in 15b0586142a5edbb58e9781291f5b900f2094d59.

3. This is because we have to refetch all the art due to the changed layout. It takes a while, particularly if there's a lot queued up (in particular, if there's some links that are stale - they take a while to timeout). If things REALLY don't ever load, then get a debug log.

Cheers,
Jonathan

So now i can tell more (since dddamian managed to fix the start crash):

1.) Actor fotos ARE BEING downloaded (still) (although IT IS OFF in settings)!!!

2.) yep that is fixed!

3.) what was the meaning of this (in regard to Eden where the fanart /banners were downloaded directly?)
a.) I mean: for the movies the art is downloaded directly, but not for the tv-shows? why?
b.) and BUG: if it gets the wrong tv-show and i select the right one, well it scrapes the correct info (plot etc) but NOT the correct banner and fanart, it still uses the old ones (from the mistakenly took show)!!!
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #7
1. It's important to be specific. It only happens if you're in the video info dialog, correct? If you'd told me that I wouldn't have just spent 20 minutes trying to reproduce it elsewhere. This is now fixed.

3. a. No idea what you're talking about. Again, be specific. Make sure you explain any problems clearly.
b. Thanks - found and fixed.

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
PKOneTwo Offline
Senior Member
Posts: 145
Joined: Jan 2008
Reputation: 1
Post: #8
(2012-05-12 12:54)jmarshall Wrote:  1. It's important to be specific. It only happens if you're in the video info dialog, correct? If you'd told me that I wouldn't have just spent 20 minutes trying to reproduce it elsewhere. This is now fixed.

3. a. No idea what you're talking about. Again, be specific. Make sure you explain any problems clearly.
b. Thanks - found and fixed.

Cheers,
Jonathan

Sorry, my fault. thought actor thumbnails (once downloaded) would be everywhere where there is a reference to the actor.

to point 3:
i mean: in eden, when i "set content" to a folder, it fecthes all the data with the scraper (movie and tv-shows), all at once! This is a clean way. Everything you need is being downloaded, no download in background (that may or may not happen). If any problems occur: you see them directly.

But in nightly: things changed: for movies all the data (fanrts, plot, banners, etc.) is fetched directly. For tv-shows: thze fanart/banners are fetched, but in background and continously:

a.) why? why did you choose this way: is less reliable in IMHO. What happesn if the art isn't downloaded: no message or anything. In Eden when it can't fetch data: you get an error message. And everythig is done at once, not background. I personally am not a fan of such unrealiable and not visible to the user things. But this is a bit too much imho
(This post was last modified: 2012-05-12 13:27 by PKOneTwo.)
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #9
All artwork is fetched offthread now during scan. Movies, Shows, Episodes and Music Videos. It's exactly the same as it was before (i.e. the same logic is used to obtain the image URLs) the difference is the art is downloaded in a separate thread. This makes scanning finish much more quickly, and as you view the scanned items, if no art is downloaded yet (i.e. it's still queued up) it'll be downloaded at that point (jumping the queue).

Eden would only fail to scrape if the info could not be downloaded - not if art could not be downloaded.

Thus, reliability has not changed at all. What has changed is you now have a much faster scanner.

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
PKOneTwo Offline
Senior Member
Posts: 145
Joined: Jan 2008
Reputation: 1
Post: #10
(2012-05-13 03:03)jmarshall Wrote:  All artwork is fetched offthread now during scan. Movies, Shows, Episodes and Music Videos. It's exactly the same as it was before (i.e. the same logic is used to obtain the image URLs) the difference is the art is downloaded in a separate thread. This makes scanning finish much more quickly, and as you view the scanned items, if no art is downloaded yet (i.e. it's still queued up) it'll be downloaded at that point (jumping the queue).

Eden would only fail to scrape if the info could not be downloaded - not if art could not be downloaded.

Thus, reliability has not changed at all. What has changed is you now have a much faster scanner.

Cheers,
Jonathan

Yes the scan is much faster, but now: there is no visible "progress bar" for example..how do we know that the art (not the info, the info is fetched directly) is being downloaded correctly?

and 2 strange things:

1.) I did now scraped 4-5 times my tv-shows, just to be sure: it seems to me it fecthes the info directly (fast), but the art ist being downloaded ONLY if i go to the tv-shows library, stay there and go over (highlight) every tv-show. It seems to me it just downloads them if there needed to be visible!

2.) since i scraped my movies 4-5 times, i can say: Nope, info/art, everything is downloaded DIRECTLY, not in background (when a a movie is scraped). Only tv-shows are being handled in background.

is that intended?
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #11
This is incorrect. You're welcome to read the code yourself if you wish. VideoInfoScanner.cpp - see GetArtwork, and note that it only ever calls CTextureCache::BackgroundCacheImage(), which does exactly what it says it does.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
PKOneTwo Offline
Senior Member
Posts: 145
Joined: Jan 2008
Reputation: 1
Post: #12
not that i don't trust you, don't get me wrong here. Only trying to help (since i did with a few other bugs).
But yeah i can do that.

Anyway: this is what i get (fresh xbmc, no userdata or whatsoever):

- Movies: everythings fetched directly, no background work
- tv-shows: backgrounded/queued, but only if they are shown (big list (confluence skin), 3 pages long, 1 page of the list being shown)

I let it scrape, after 30 mins he was still there where i left the tv-show library (my connection is good, 16mbit, no downloads or whatsoever running parellely, tested it with eden on other pc, scraped everything directly, was done in less then 2 mins)!

Don't trust me: try it yourself (fresh install, scrape a few movies, then a few empty folders (tv-shows))
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 175
Post: #13
The Debug Log will show you that it was downloading art off-thread.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
PKOneTwo Offline
Senior Member
Posts: 145
Joined: Jan 2008
Reputation: 1
Post: #14
I'll check that (it wasn't necessary till now, since it obviously didn't)!

30mins vs. 2mins: doesn't make any sense to me.
find quote
negge Offline
Team-XBMC Member
Posts: 2,116
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #15
@jmarhsall: I recently "lost" almost all my movie fanart and posters, meaning when I browse the library there's no pictures showing. Looking at the log I'm getting a lof of these:

PHP Code:
00:28:29 T:2968177520   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/backdrops/e03/4dcc342b7b9aa151ff004e03/2012-original.jpg
00:28:29 T:2889874288   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/posters/e78/4cd10b8d5e73d65020000e78/2012-original.jpg
00:28:30 T:3025889808   DEBUGLIRCUpdate - NEW at 98257:000000037ff07be0 00 Down mceusb (Down)
00:28:30 T:3025889808   DEBUGOnKey167 (a7pressedaction is Down
00
:28:31 T:2968177520   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/posters/dec/4e166acc5e73d67b6d000dec/a-lonely-place-for-dying-original.jpg
00:28:31 T:2864884592   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/backdrops/e89/4e166cfe5e73d67b67000e89/a-lonely-place-for-dying-original.jpg
00:28:36 T:3025889808   DEBUGLIRCUpdate - NEW at 104357:000000037ff07be0 00 Down mceusb (Down)
00:28:36 T:3025889808   DEBUGOnKey167 (a7pressedaction is Down
00
:28:37 T:2889874288   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/backdrops/f18/4bc97ff6017a3c57fe03af18/the-a-team-original.jpg
00:28:37 T:2987060080   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/posters/d3f/4ccfe7415e73d65021000d3f/the-a-team-original.jpg
00:28:38 T:3025889808   DEBUGUPowerRecieved an unknown signal DeviceChanged
00
:28:43 T:3025889808   DEBUGLIRCUpdate - NEW at 110942:000000037ff07be0 00 Down mceusb (Down)
00:28:43 T:3025889808   DEBUGOnKey167 (a7pressedaction is Down
00
:28:43 T:2864884592   DEBUGDoWork took 148 ms to load special://masterprofile/Thumbnails/7/7c7f871c.jpg
00:28:43 T:2968177520   DEBUGDoWork took 409 ms to load special://masterprofile/Thumbnails/e/ecb62cdc.jpg
00:28:46 T:3025889808   DEBUGLIRCUpdate - NEW at 114727:000000037ff07be1 00 Up mceusb (Up)
00:28:46 T:3025889808   DEBUGOnKey166 (a6pressedaction is Up
00
:28:47 T:2987060080   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/backdrops/f18/4bc97ff6017a3c57fe03af18/the-a-team-original.jpg
00:28:47 T:2889874288   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/posters/d3f/4ccfe7415e73d65021000d3f/the-a-team-original.jpg
00:28:50 T:3025889808   DEBUGLIRCUpdate - NEW at 118115:000000037ff07be1 00 Up mceusb (Up)
00:28:50 T:3025889808   DEBUGOnKey166 (a6pressedaction is Up
00
:28:50 T:2864884592   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/backdrops/e89/4e166cfe5e73d67b67000e89/a-lonely-place-for-dying-original.jpg
00:28:50 T:2968177520   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/posters/dec/4e166acc5e73d67b6d000dec/a-lonely-place-for-dying-original.jpg
00:28:52 T:3025889808   DEBUGLIRCUpdate - NEW at 120424:000000037ff07be0 00 Down mceusb (Down)
00:28:52 T:3025889808   DEBUGOnKey167 (a7pressedaction is Down
00
:28:53 T:2889874288   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/backdrops/f18/4bc97ff6017a3c57fe03af18/the-a-team-original.jpg
00:28:53 T:2987060080   DEBUGGetImageHash unable to stat url http://cf1.imgobject.com/posters/d3f/4ccfe7415e73d65021000d3f/the-a-team-original.jpg
00:28:54 T:3025889808   DEBUGLIRCUpdate - NEW at 122024:000000037ff07be0 00 Down mceusb (Down

The reason for the "unable to stat url" is that it returns a 403 (in XML). Is this in any way related to the recent scraping updates?[/php]
find quote
Post Reply