[FIXED] Ubuntu 12.04 + Nvidia VDPAU and ION

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
unkuser Offline
Member
Posts: 53
Joined: Sep 2009
Reputation: 0
Post: #1
Has anybody figure how to get VDPAU working with XBMC, ION and Ubuntu 12.04

I have installed XBMC multiple times in linux systems and never had so many issues trying to get xbmc playing videos with VDPAU.

It seems it's not using the drivers at all to play any videos. I get a black screen and very choppy sound, CPU is spike up at 80-90%.
I can revert to Ubuntu 11.x, but just finished building a new htpc and this is the last piece missing.

Anybody got it working with an ION video graphics card? I tried a few Nvidia drivers and they all have the same problem. I am on 302.x something now.

By the way I am running XUBUNTU.

Thanks.
(This post was last modified: 2012-05-29 14:47 by unkuser.)
find quote
Plaguester Offline
Senior Member
Posts: 262
Joined: May 2010
Reputation: 7
Post: #2
Post the output of
Code:
dmesg | grep -i nvidia

Also post your /etc/X11/xorg.conf file.

HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
find quote
wiz561 Offline
Senior Member
Posts: 219
Joined: Feb 2009
Reputation: 0
Post: #3
I had the same problem, and got it working just fine with a little tweaking. Turns out that the nvidia driver wasn't being loaded, even though I had it installed. I found this out by checking the x11 log file in /var/log.

After that, I did an 'enable restricted driver' command thing from the command line. I forget what it exactly was, but it's the equivalent to the popup you get in the GUI after you install telling you to enable the restricted hardware. After that, things worked.
find quote
unkuser Offline
Member
Posts: 53
Joined: Sep 2009
Reputation: 0
Post: #4
(2012-05-21 04:00)Plaguester Wrote:  Post the output of
Code:
dmesg | grep -i nvidia

Also post your /etc/X11/xorg.conf file.

[ 14.086651] nvidia: module license 'NVIDIA' taints kernel.
[ 17.960319] input: HDA NVidia Line as /devices/pci0000:00/0000:00:08.0/sound/card0/input6
[ 17.960757] input: HDA NVidia Front Mic as /devices/pci0000:00/0000:00:08.0/sound/card0/input7
[ 17.961112] input: HDA NVidia Rear Mic as /devices/pci0000:00/0000:00:08.0/sound/card0/input8
[ 17.961460] input: HDA NVidia Front Headphone as /devices/pci0000:00/0000:00:08.0/sound/card0/input9
[ 17.961803] input: HDA NVidia Line-Out as /devices/pci0000:00/0000:00:08.0/sound/card0/input10
[ 17.965192] nvidia 0000:00:03.5: PCI INT B -> Link[LPMU] -> GSI 23 (level, low) -> IRQ 23
[ 17.966429] nvidia 0000:03:00.0: PCI INT A -> Link[SGRU] -> GSI 22 (level, low) -> IRQ 22
[ 17.966460] nvidia 0000:03:00.0: setting latency timer to 64
[ 18.008532] NVRM: loading NVIDIA UNIX x86 Kernel Module 302.07 Fri Apr 27 10:55:55 PDT 2012

--------------------------------------------------------------------------------
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 302.07 (buildmeister@swio-display-x86-rhel47-03.nvidia.com) Fri Apr 27 12:00:59 PDT 2012


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection
(2012-05-21 14:43)wiz561 Wrote:  I had the same problem, and got it working just fine with a little tweaking. Turns out that the nvidia driver wasn't being loaded, even though I had it installed. I found this out by checking the x11 log file in /var/log.

After that, I did an 'enable restricted driver' command thing from the command line. I forget what it exactly was, but it's the equivalent to the popup you get in the GUI after you install telling you to enable the restricted hardware. After that, things worked.

I checked my X11 logs. The drivers seems to be loading fine.
(This post was last modified: 2012-05-21 16:47 by unkuser.)
find quote
khaoohs Offline
Donor
Posts: 75
Joined: Oct 2006
Reputation: 0
Post: #5
Did you install the libvdpau package?
find quote
unkuser Offline
Member
Posts: 53
Joined: Sep 2009
Reputation: 0
Post: #6
I have version 0.4.1-3 Ubuntu1 installed. Don't believe there is a newer one.
(This post was last modified: 2012-05-21 21:20 by unkuser.)
find quote
unkuser Offline
Member
Posts: 53
Joined: Sep 2009
Reputation: 0
Post: #7
Almost wiped my system. But decided to try this first.
Installed XBMC nightly unstable build
Installed Nvidia Drivers 302.11 unstable.

VDPAU is fixed now and videos are playing fine.
find quote
calev Offline
Fan
Posts: 445
Joined: May 2010
Reputation: 8
Post: #8
Is this first generation ion? Ive tested the second generation ion with ubuntu 12.04 and it works great with the 295 driver.
find quote
Csimbi Offline
Member
Posts: 83
Joined: Jan 2010
Reputation: 0
Post: #9
I just installed Precise and XBMC from this repository:
Code:
sudo add-apt-repository ppa:wsnipex/xbmc-xvba
No VDPAU acceleration on my Zotac 9300 ITX board.
I tried searching many places, this seems to be the right one - but I could not figure out how to install the 302.11 drivers.
Could you help me out?
Thanks.
(This post was last modified: 2012-09-09 07:36 by Csimbi.)
find quote