XBMC not reading .avi format (Solved)

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
slonn Offline
Junior Member
Posts: 5
Joined: Jul 2012
Reputation: 0
Post: #1
I have XBMCbuntu set up on an Asrock ios and stream media content from my QNAP NAS. But XBMC can only see the .mkv files and not the .avi files. If it's a folder with only .avi files in it the folder simply does not show up in the menu in XBMC.

The hard drive which holds all the media files is formatted in EXT4. Would that have anything to say? I've tried googling for EXT4 and .avi but can't seem to find any info on it.
(This post was last modified: 2012-08-30 16:58 by slonn.)
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,355
Joined: Jul 2010
Reputation: 111
Location: USA
Post: #2
Is your folder with the avi files defined as a media source to XBMC?
find quote
slonn Offline
Junior Member
Posts: 5
Joined: Jul 2012
Reputation: 0
Post: #3
(2012-08-30 11:48)artrafael Wrote:  Is your folder with the avi files defined as a media source to XBMC?

Think so - it's a subfolder to a folder called TV which shows up.
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,355
Joined: Jul 2010
Reputation: 111
Location: USA
Post: #4
Are your mkv files also in their own subfolder under the TV folder?

Also, verify the permissions of the avi folder and also of the individual avi files to be sure they have at least read access across the board.
find quote
Ned Scott Offline
Team-XBMC Wiki Guy
Posts: 19,891
Joined: Jan 2011
Reputation: 247
Location: Arizona, USA
Post: #5
What protocol are you using to share the files? UPnP? SMB? NFS?

You can make easy links to the XBMC wiki using double brackets around common XBMC words: [[debug log]] = debug log, [[Video library]] = Video library, [[SMB]] = SMB , [[userdata]] = userdata, etc
find quote
slonn Offline
Junior Member
Posts: 5
Joined: Jul 2012
Reputation: 0
Post: #6
(2012-08-30 12:27)artrafael Wrote:  Are your mkv files also in their own subfolder under the TV folder?

Also, verify the permissions of the avi folder and also of the individual avi files to be sure they have at least read access across the board.

They have read permission.

The mkv files are also in their own subfolder in the TV folder. I purchased the series Rome on DVD and copied it via Handbrake. Season 1 was copied in avi format and season 2 in mkv format. Both seasons are in a sub folder in the TV folder, but only season 2 is visible. I can see both seasons in a regular file manager.


(2012-08-30 12:30)Ned Scott Wrote:  What protocol are you using to share the files? UPnP? SMB? NFS?

UPnP
(This post was last modified: 2012-08-30 14:17 by slonn.)
find quote
Ned Scott Offline
Team-XBMC Wiki Guy
Posts: 19,891
Joined: Jan 2011
Reputation: 247
Location: Arizona, USA
Post: #7
I'm guessing it's a UPnP issue. UPnP servers can be file type sensitive. See if you have the option to enable SMB (Windows Sharing) which should work on any XBMC installation.

You can make easy links to the XBMC wiki using double brackets around common XBMC words: [[debug log]] = debug log, [[Video library]] = Video library, [[SMB]] = SMB , [[userdata]] = userdata, etc
find quote
slonn Offline
Junior Member
Posts: 5
Joined: Jul 2012
Reputation: 0
Post: #8
Followed the instructions in this video and that fixed the issue.
find quote