Smb Windows 8

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
zirbio Offline
Junior Member
Posts: 16
Joined: Feb 2011
Reputation: 0
Post: #1
Hello,

I've some problems, I’ve upgraded to windows 8 but I’m dealing with some troubles with the smb in other to share the media. If I sing up with the offline user I'm able to share all the content, but I'd like to share the content with the online user, the windows live ID, because as you all know, this user has some advantages.

When I try to share the content with this online user, the XBMC tells me that I have to enter the user name and password, the thing is that when I enter the password the xbmc acts like is the wrong one, it just tell me again that I have to enter the password and username.

Any ideas?

Thank you very much.

P.S. I'm sorry if I haven't expressed myself properly, English is my second language.
find quote
stammie Offline
Senior Member
Posts: 152
Joined: Oct 2011
Reputation: 6
Post: #2
I don't know if this will help because I've turned off the online user,
my other (still Windows 7) pc wouldn't see the network shares from my Win 8 pc at all via XBMC after the upgrade, what I had to do was go to the shared folders manually through the network icon on the desktop, enter the password and check the remember box, XBMC then saw all the shares.

Sounds like you're having more luck with XBMC and Windows 8 than me, I can't even read any text in XBMC since upgrading Sad
find quote
jamiespeck Offline
Junior Member
Posts: 1
Joined: Oct 2012
Reputation: 0
Post: #3
I just upgrade as well to Windows 8 and thought this would be easier than what I had before but I guess I was wrong, I have Windows 8 and a Apple tv2 with Xbmc on it and it keeps asking me for user name and password but I don't have one. If anyone can point me in the right direction would be great. Thanks guys
find quote
smitopher Offline
Member
Posts: 94
Joined: Mar 2012
Reputation: 3
Post: #4
(2012-10-28 17:21)jamiespeck Wrote:  I just upgrade as well to Windows 8 and thought this would be easier than what I had before but I guess I was wrong, I have Windows 8 and a Apple tv2 with Xbmc on it and it keeps asking me for user name and password but I don't have one. If anyone can point me in the right direction would be great. Thanks guys
Your windows 8 has a user and password even if you do not enter it when you start it up. Check the control panel for user accounts.
find quote
stammie Offline
Senior Member
Posts: 152
Joined: Oct 2011
Reputation: 6
Post: #5
(2012-10-28 17:21)jamiespeck Wrote:  I just upgrade as well to Windows 8 and thought this would be easier than what I had before but I guess I was wrong, I have Windows 8 and a Apple tv2 with Xbmc on it and it keeps asking me for user name and password but I don't have one. If anyone can point me in the right direction would be great. Thanks guys

What exactly are you trying to do when you're asked for a user and pass?
I too have upgraded to Windows 8 this weekend, I expected some problems from the upgrade but nothing to the extent I've experienced,
if its something I've dealt within the past couple of days I'll be glad to pass on some knowledge
find quote
zirbio Offline
Junior Member
Posts: 16
Joined: Feb 2011
Reputation: 0
Post: #6
I have the same problem as jamiespeck, the ATV keeps asking me for the user name and password, Obviously, when I' logged in with the offline user I'm able to connect, but when I'm connect with the Microsoft online ID the ATV keeps asking me for the user name and password.
find quote
urbanhunter Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #7
I've had the same problem as well but I have solved it, at least for me anyway.Give the Administrator account a password then use that on the ATV. For those that don't know, there is an Administrator account that has higher privileges that is standard to windows and are greater than an administrator type account. It can be found in control panel, user accounts, manage another account. I haven't tried this with a live account but will test it when I get time.
find quote
HenryFord Offline
Posting Freak
Posts: 1,271
Joined: Jan 2010
Reputation: 19
Post: #8
(2012-10-28 17:58)smitopher Wrote:  Your windows 8 has a user and password even if you do not enter it when you start it up. Check the control panel for user accounts.
That's only half-right since you do not need to enter a password for an offline-user. So you can have a user without a password. This was a problem in Win7 as well:
If you choose to only share your files/folders via Username/Password (still don't really see the sense in this with media-files, just restrict the usage to Read-Only...), and you have a user without a password the whole sharing-thing wouldn't work. At all.

(2012-10-29 13:28)urbanhunter Wrote:  I've had the same problem as well but I have solved it, at least for me anyway.Give the Administrator account a password then use that on the ATV. For those that don't know, there is an Administrator account that has higher privileges that is standard to windows and are greater than an administrator type account. It can be found in control panel, user accounts, manage another account. I haven't tried this with a live account but will test it when I get time.
Having more privileges than an administrator is virtually impossible, there is no account with higher privileges than an "administrator type account". The single difference probably is that you are using the Live-Accounts whereas the Administrator-Account is an offline account.
The Administrator is disabled by default on Windows by the way. You have to enable it first, before you can do anything with it.

I'd recommend to simply deactivate the stupid password protection for shares. I mean... what protection do you get from it anyhow?
Here is a little how-to:
http://www.troublefixers.com/file-sharin...windows-8/


You still want to use the password-protection for other shares but not for media-files?
Then do the following:
Right Click the media-folder which should be shared and hit "Properties". In the new window click the tab "Sharing" and hit "Advanced Sharing", click the box "Share this folder", enter a name and click the Permission-Tab. Add the User "Everyone" to the permissions and save the settings.
You should then be able to connect to the share via "\\hostname\NameOfTheShare" without a password.

Need help? Check out my XBMC Frodo Guide. It contains full featured guides to Sickbeard and CouchPotato as well.

[Image: all-fanart.jpg]
(This post was last modified: 2012-10-29 15:54 by HenryFord.)
find quote
urbanhunter Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #9
(2012-10-29 15:20)HenryFord Wrote:  The Administrator is disabled by default on Windows by the way. You have to enable it first, before you can do anything with it.

I'd recommend to simply deactivate the stupid password protection for shares. I mean... what protection do you get from it anyhow?
Here is a little how-to:
http://www.troublefixers.com/file-sharin...windows-8/


You still want to use the password-protection for other shares but not for media-files?
Then do the following:
Right Click the media-folder which should be shared and hit "Properties". In the new window click the tab "Sharing" and hit "Advanced Sharing", click the box "Share this folder", enter a name and click the Permission-Tab. Add the User "Everyone" to the permissions and save the settings.
You should then be able to connect to the share via "\\hostname\NameOfTheShare" without a password.

I forgot you had to enable it but it was the only way for me to get shares to work if I wanted to have a user without a password. I have done all this and XBMC would always still ask for a username and password. Either the setting is not working properly on my install or something else is wrong with windows.
find quote
zirbio Offline
Junior Member
Posts: 16
Joined: Feb 2011
Reputation: 0
Post: #10
Ok, thank you very much, I've solved the problem.
I folowed the steps, and added the "everyone user" to the share folder. Now I'm able to connect the share media.
find quote
bruderbell Offline
Junior Member
Posts: 4
Joined: Dec 2013
Reputation: 0
Post: #11
(2012-10-30 10:44)zirbio Wrote:  Ok, thank you very much, I've solved the problem.
I folowed the steps, and added the "everyone user" to the share folder. Now I'm able to connect the share media.

After you add the everyone, what do you enter at the prompt in xbmc? I can't get this to work
find quote
Perfectdark Offline
Junior Member
Posts: 31
Joined: Apr 2013
Reputation: 0
Post: #12
(2013-12-12 08:14)bruderbell Wrote:  
(2012-10-30 10:44)zirbio Wrote:  Ok, thank you very much, I've solved the problem.
I folowed the steps, and added the "everyone user" to the share folder. Now I'm able to connect the share media.

After you add the everyone, what do you enter at the prompt in xbmc? I can't get this to work

Me too

I already have "everyone" added as a user and it doesn't work still. Only with the Linux xbmc on MyGica. When I flash back to android and run xbmc, it works fine
find quote
bruderbell Offline
Junior Member
Posts: 4
Joined: Dec 2013
Reputation: 0
Post: #13
I ended up getting my shares to work by editing the sources.xml file in xbmc directly. It seems to me that the browser in xbmc doesn't see my shares, but after manually adding them I have full access.
Cheers
(This post was last modified: 2014-01-23 02:06 by bruderbell.)
find quote
Perfectdark Offline
Junior Member
Posts: 31
Joined: Apr 2013
Reputation: 0
Post: #14
(2014-01-23 02:06)bruderbell Wrote:  I ended up getting my shares to work by editing the sources.xml file in xbmc directly. It seems to me that the browser in xbmc doesn't see my shares, but after manually adding them I have full access.
Cheers

is that something I can do with the mygica? if so how, I've never SSH'd into the box
find quote
edrikk Offline
Senior Member
Posts: 247
Joined: Jul 2011
Reputation: 5
Post: #15
(2014-01-23 02:06)bruderbell Wrote:  I ended up getting my shares to work by editing the sources.xml file in xbmc directly. It seems to me that the browser in xbmc doesn't see my shares, but after manually adding them I have full access.
Cheers

Yup... I had seen this and reported it a while back (when Win 8 first came out)... For whatever reason, XBMC doesn't see the SMB Shares, although they *are* there. If they are manually added to sources.xml, XBMC works as it should (still can't browse the share, but the share is "added")...
find quote
Post Reply