[Frodo] Apple Trailers does not work

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dbldown768 Offline
Fan
Posts: 349
Joined: Aug 2008
Reputation: 0
Post: #1
Apple Trailers are not working for me under frodo. Apple Trailers-lite appear to work, but I need the other for the Cinema Experience Script. Please see attached xbmc.log

http://pastebin.com/hQzgaahv

Specifically
Code:
19:38:58 T:2993855344    INFO: Loading skin file: DialogProgress.xml, load type: KEEP_IN_MEMORY
19:38:59 T:2993855344   ERROR: /usr/share/xbmc/addons/script.module.pysqlite/lib/pysqlite2/__init__.py:34: UserWarning: DeprecationWarning: the pysqlite2 module is deprecated; please change your script to use sqlite3.
                                              warnings.warn("DeprecationWarning: the pysqlite2 module is deprecated; please change your script to use sqlite3.")
19:38:59 T:2993855344   DEBUG: NEWADDON PythonCallbackHandler construction with PyThreadState 0xad3cb10
19:38:59 T:2993855344   ERROR: EXCEPTION: XML File for Window is missing
19:38:59 T:2993855344   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.RuntimeError'>
                                            Error Contents: XML File for Window is missing
                                            Traceback (most recent call last):
                                              File "/home/xbmc/.xbmc/addons/script.apple.movie.trailers/addon.py", line 54, in <module>
                                                import gui
                                              File "/home/xbmc/.xbmc/addons/script.apple.movie.trailers/resources/lib/gui.py", line 951, in <module>
                                                main()
                                              File "/home/xbmc/.xbmc/addons/script.apple.movie.trailers/resources/lib/gui.py", line 947, in main
                                                ui = GUI( "script-%s-main.xml" % ( __scriptname__.replace( " ", "_" ), ), os.getcwd(), "Default", "PAL16x9" )
                                            RuntimeError: XML File for Window is missing
                                            -->End of Python script error report<--
19:38:59 T:2993855344    INFO: Python script stopped
19:38:59 T:2993855344   DEBUG: Thread XBPyThread 2993855344 terminating

Motherboard P5N7A-VM, E8400 C2D 3.0 processor. NVIDIA 9300 graphics card. OpenELEC Stable - Generic x86_64 Version:3.2.4
(This post was last modified: 2013-01-29 04:58 by dbldown768.)
find quote
Howry Offline
Junior Member
Posts: 39
Joined: Jul 2009
Reputation: 0
Post: #2
Have you tried this version?

http://forum.xbmc.org/showthread.php?tid=119587

It works for me on Windows Frodo.
find quote
dbldown768 Offline
Fan
Posts: 349
Joined: Aug 2008
Reputation: 0
Post: #3
Is this supposed to replace 'apple trailers' in the addons repository? I believe I need that only because that is what cinema experience is looking for.

Motherboard P5N7A-VM, E8400 C2D 3.0 processor. NVIDIA 9300 graphics card. OpenELEC Stable - Generic x86_64 Version:3.2.4
find quote
dbldown768 Offline
Fan
Posts: 349
Joined: Aug 2008
Reputation: 0
Post: #4
Is there a specific thread dedicated to this plugin ? It looks like this should be a simple error to fix in that it is configuration or something. Any other help would be appreciated.

Motherboard P5N7A-VM, E8400 C2D 3.0 processor. NVIDIA 9300 graphics card. OpenELEC Stable - Generic x86_64 Version:3.2.4
find quote
dbldown768 Offline
Fan
Posts: 349
Joined: Aug 2008
Reputation: 0
Post: #5
Updated to official frodo version and still the same issue. Anyone have any help they suggest. I know I'm not the only user using this plugin.

Motherboard P5N7A-VM, E8400 C2D 3.0 processor. NVIDIA 9300 graphics card. OpenELEC Stable - Generic x86_64 Version:3.2.4
find quote
dbldown768 Offline
Fan
Posts: 349
Joined: Aug 2008
Reputation: 0
Post: #6
Ok, i think i solved my problem, but someone I would love to get an explanation. apparently the gui.py listed above was not finding the Apple Movie Trailers.xml. But what I didnt get is the file was in the path trying to be passed to the constructor. In any case inside the addons/script.apple.movie.trailers/resource/skin there was a Default folder that contains PAL16x9 and media. Inside the PAL16x9 was the correct xml, not sure why the script doesnt find this.

What i did was create a softlink from PAL16x9 to 720p
720p -> PAL16x9.

Code:
xbmc@xbmc-htpc:~/.xbmc/addons/script.apple.movie.trailers/resources/skins/Default$ ls -ltr
total 8
drwxr-xr-x 2 xbmc xbmc 4096 2013-02-04 19:46 PAL16x9
drwxr-xr-x 3 xbmc xbmc 4096 2013-02-04 19:47 media
lrwxrwxrwx 1 xbmc xbmc    7 2013-02-05 19:01 720p -> PAL16x9


this FINALLY allowed the script to start running. But i hope someone can explain to my why this was needed. Also, when it runs, i cannot say it looks pretty. the plugin doesnt even take up the entire screen.

I cant imaging that I was the only person with this issue. If there is a specific forum for this plugin please move this topic. I would like to make sure the devs of this plugin are informed.

Thanks.

Motherboard P5N7A-VM, E8400 C2D 3.0 processor. NVIDIA 9300 graphics card. OpenELEC Stable - Generic x86_64 Version:3.2.4
find quote
dbldown768 Offline
Fan
Posts: 349
Joined: Aug 2008
Reputation: 0
Post: #7
Over 200+ reads and no explanation?

Maybe this should be moved to the Linux forum or something.

Motherboard P5N7A-VM, E8400 C2D 3.0 processor. NVIDIA 9300 graphics card. OpenELEC Stable - Generic x86_64 Version:3.2.4
find quote
movietrailers Offline
Junior Member
Posts: 1
Joined: Dec 2013
Reputation: 0
Post: #8
But is here http://appletrailers.us/ is someomene same too movie trailers is here
find quote