[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within XBMC

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
munificent Offline
Junior Member
Posts: 15
Joined: Jul 2012
Reputation: 0
Post: #196
Yup, the rollback worked. Very nice. Sadly, Steam's streaming doesn't seem to work so well from Big Picture, but I'm glad I'm vaguely ready for it when it does.
find quote
teeedubb Offline
Donor
Posts: 2,035
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #197
New version in OP:
Quote:0.9.10
French translation thanks to Kre|S.
OSX checks for XBMC + Steam paths.
A advanced option to use a Batch file to launch scripts - uses a batch file as in previous version which should hopefully workaround the 'nothing happening' issue some people have been having. GUI settings for XBMC + Steam paths and whether to quit XBMC have no effect with this setting enabled, the options are configured via steam-launch.bat, located in userdata/addon_data/script.steam.launcher/scripts/ , with instructions located in file itself. steam-launch.bat is not deleted by the addon or updates and if it does not exist it will be copied to the userdata directory on first run with the option enabled, along with launchhidden-bat.vbs
Deleting scripts via addon settings now deletes scripts from other O/S's if they exist.

0.9.15
Addon now logs to xbmc.log.
A few fixes + changes.
Linux script uses a temp lockfile to prevent multiple instances of XBMC reopening.

@people having to use v0.5.2, can you try this version, if it doesnt work please post a debug log. If its still not working try to use the 'Batch file' option - more info above and on first page.

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
(This post was last modified: 2014-03-09 23:46 by teeedubb.)
find quote
wolfodeiwolfy Offline
Senior Member
Posts: 221
Joined: Mar 2011
Reputation: 3
Location: France
Post: #198
(2014-02-17 07:31)teeedubb Wrote:  
(2014-02-15 11:28)wolfodeiwolfy Wrote:  Hi, I've just updated from 0.5.2 to 0.9.8 and it doesn't work. Steam bpm doesn't launch (add-on settings are correct).

The only version that works is 0.5.2 so I reinstall it.
Do you get any errors in xbmc or autohotkey? Youre using windows right? Which exact version and edition, eg x64/x86, home premium/ultimate etc? Anything else that could affect the addon (as it uses external scripts)?Someone else reported the same problem but I'm unable to reproduce it on 2x win7 + 1x win8 x64 home premium installs. If I cant work out the problem is, when I have some time I'll look at adding a option to use a batch file as was the case in v0.5.2.

Hi, sorry I didn't play a game for a long time. I've just tried v0.9.15. It works perfectly.

I'm running windws 8.1 x64 home edition on i5 3570k with gtx 660, xbmc 12.2, artic skin

[Image: bannirew2w.jpg]
(This post was last modified: 2014-03-08 11:47 by wolfodeiwolfy.)
find quote
GCMX Offline
Junior Member
Posts: 9
Joined: Aug 2011
Reputation: 0
Post: #199
Hi teeedub,

I've set up xbmc and ubuntu minimal following this guide: http://forum.xbmc.org/showthread.php?tid=174854

I've installed openbox and wmctrl and made steam-launch.sh executable from within the addon-setings. I then followed your instructions here: http://forum.xbmc.org/showthread.php?tid...pid1584693

When I run the addon I get a "working" popup for a bit, then it disappears and nothing further happens. XBMC isn't even getting killed (the add-on setting says always kill XBMC).

I can start steam by ssh from within XBMC using:
Code:
DISPLAY=:0 steam -bigpicture

Although it gets stuck on selecting a network (I think this is simply because I haven't yet installed a network manager, wireless is working from the initial installation setup).

Has anything changed in the addon-on to make your suggested scripts not work?

The other possible cause of the issue is that I can't for the life of me work out how to start openbox. Because of that openbox has never run and I'm guessing there might be some initialisation that needs to take place before your scripts can work. I assume I have to kill XBMC and then start openbox but everything I've tried fails. Most guides are to start openbox at startup (which I don't really want, although will resort to if all else fails).

Any ideas?

Cheers
find quote
teeedubb Offline
Donor
Posts: 2,035
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #200
From a quick look at the minimal guide you need to omit one step, the /etc/xinit/xbmc.conf step, so disable the upstart script. I've updated my post you linked to with clearer instructions + wiki links. I think the script not working is from copy/pasting whole code blocks from that post, delete the user scripts via the addon settings and try with the updated instructions. If xbmc isnt killed with the new script please post a debug log.

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
find quote
rassilon Offline
Junior Member
Posts: 5
Joined: Jun 2010
Reputation: 0
Location: Portland, OR
Post: #201
(2014-03-12 07:07)teeedubb Wrote:  From a quick look at the minimal guide you need to omit one step, the /etc/xinit/xbmc.conf step, so disable the upstart script. I've updated my post you linked to with clearer instructions + wiki links. I think the script not working is from copy/pasting whole code blocks from that post, delete the user scripts via the addon settings and try with the updated instructions. If xbmc isnt killed with the new script please post a debug log.

I followed your setup there and changed some of the paths to match my system, but XBMC takes forever to startup and instead of a black background, its a black background with 13.10, then a couple of flickers and it opens XBMC. Steam launches fine when everything boots up. Sometimes when I reboot, it just hangs on the ubuntu 13.10 loading screen and never launches XBMC. Any advice?
find quote
teeedubb Offline
Donor
Posts: 2,035
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #202
Not sure why it would be taking long to boot, pressing escape will show you whats going on at boot time, you can also have a look in the log files in /var/log/

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
find quote
rassilon Offline
Junior Member
Posts: 5
Joined: Jun 2010
Reputation: 0
Location: Portland, OR
Post: #203
Weird. For some reason that bash_profile script is causing my system to not start X for around 3 minutes. I disabled it and had X start on boot and it works fine. I can't find anything in /var/log/boot.log or /var/log/Xorg.0.log that explains it. Also, the irxevent script isn't launching irxevent when XBMC is closed.
find quote
teeedubb Offline
Donor
Posts: 2,035
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #204
Youre not trying that method over xbmcbuntu/etc, how does X start if you remove .bash_profile? Unless your system disagrees with the command to launch X in the .bash_profile, I cant see why it would hang for minutes. Run the irexevent script, or individually, via ssh to see what going on/whether irxevent works.

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
find quote
rassilon Offline
Junior Member
Posts: 5
Joined: Jun 2010
Reputation: 0
Location: Portland, OR
Post: #205
It looks like I put the fstrim in my rc.local and that was causing the delay.. So when I removed that line its back toba few seconds, yay. When I run the irxevent script I get:
Code:
./.irxevent.sh: 6: ./.irxevent.sh: [[: not found
./.irxevent.sh: 14: ./.irxevent.sh: [[: not found
irxevent running, xbmc not running.

Edit: Fixed it, #!/bin/bash was missing at the top of the script
(This post was last modified: 2014-03-18 22:54 by rassilon.)
find quote
teeedubb Offline
Donor
Posts: 2,035
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #206
SteamOS + Ubuntu

Installing the packages from this PPA will give you a Steam Os session in Ubuntu, with the steam compositor, so you can log into it via lightdm, xinit etc or via the addon using my method here.. Note that running steam os has reset my steam install, games and all, on several occasions so do so at your own risk, although it is possible to run non steamos bpm with the valve compositor which has been trouble free and Ive found the steam compositor best for playing games. Only downside is that the "Retun to desktop" option does not work in this mode. If you want to use the steamos session, it is started via /usr/bin/steamos-session. If you want to run a steam bpm session copy the file /usr/bin/steamos-session elsewhere, as it will be overwritten with updates, and change the last line to something like the following:

Code:
steam -bigpicture #-tenfoot -steamos -enableremotecontrol

You can also add other programs to load suchs as unclutter or pulseaudio, a copy of mine as a example:

~/.scripts/steamos-session-xbmc
Code:
#!/bin/sh
export SDL_VIDEO_MINIMIZE_ON_FOCUS_LOSS=0

export HOMETEST_DESKTOP=1
export HOMETEST_USER=xbmc
export HOMETEST_DESKTOP_USER=xbmc
export HOMETEST_DESKTOP_SESSION=openbox

export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libmodeswitch_inhibitor.so #:/usr/lib/i386-linux-gnu/libmodeswitch_inhibitor.so

# Disable DPMS and screen blanking for now; it doesn't know about controller
# or Steam remote control events right now
xset -dpms
xset s off

steamcompmgr &
unclutter &
pulseaudio --start

loadargb_cursor /usr/share/icons/steam/arrow.png


steam -bigpicture -enableremotecontrol >> /tmp/steam.log

pulseaudio -k

ob-exit.sh

Also the steamos-xpad driver from that PPA is worth installing if you use a 360 controller, it stops the flashing ring of light.

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
(This post was last modified: 2014-03-19 08:58 by teeedubb.)
find quote
GCMX Offline
Junior Member
Posts: 9
Joined: Aug 2011
Reputation: 0
Post: #207
(2014-03-12 07:07)teeedubb Wrote:  From a quick look at the minimal guide you need to omit one step, the /etc/xinit/xbmc.conf step, so disable the upstart script. I've updated my post you linked to with clearer instructions + wiki links. I think the script not working is from copy/pasting whole code blocks from that post, delete the user scripts via the addon settings and try with the updated instructions. If xbmc isnt killed with the new script please post a debug log.

Thanks for all your effort teeedubb. I haven't had a chance to try this yet, but I'll report back when I do.
find quote
teeedubb Offline
Donor
Posts: 2,035
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #208
To people using my repo: Due to a change in the way that github handles links a manual update to v1.0.1 is required. This solves xbmc on linux crashing when checking for updates. Link in first post updated and it can also be downloaded from https://github.com/teeedubb/teeedubb-xbm....teeedubb/

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
(This post was last modified: 2014-03-21 23:59 by teeedubb.)
find quote
LSU Jonno Offline
Senior Member
Posts: 118
Joined: Dec 2012
Reputation: 0
Post: #209
teeedub,

Thanks for the great plugin!

I'm having some trouble getting it working. I'm a linux newb running XBMCbuntu.

I understand your first post about running Steam Launcher from an XBMC session. However, if I log into my desktop and launch XBMC from the desktop I can't get Steam Launcher to work.

I've installed wmctrl and
Quote: Linux only: Make steam-launch.sh executable on next run - This changes the executable bit on the file 'steam-launch.sh' which is necessary for this addon to run, Linux users need to do this on the first run and after deleting the profile://addon_data scripts. This setting defaults to off after being run once.

...but I keep getting an error that steam-launch.sh could not run.

I'm using XBMCbuntu 13:
http://forum.xbmc.org/showthread.php?tid=189553

Also, anyone know how to make XBMC autostart in XBMCbuntu from the desktop? I think I'd rather launch this way rather than through the XBMC session so that plugins like this one and Chrome launcher work without going through too much configuration.
find quote
teeedubb Offline
Donor
Posts: 2,035
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #210
Hmmmm... I haven't upgraded to xbmcbuntu 13 yet so I haven't tested it with 13. Can you please post a log file of the error occurring.

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
find quote
Post Reply