XBMC and RPi freezes when in idle with TV off

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dejc Offline
Junior Member
Posts: 12
Joined: Sep 2012
Reputation: 0
Exclamation  XBMC and RPi freezes when in idle with TV off
Post: #1
My RPi model B rev 2 with 512MB of RAM has OpenELEC 3.1.7 installed on 8GB Class 10 SanDisk memory card and connected to Samsung TV over HDMI. RPi power source is 5V 1A HTC charger.
It has some modest overclock (check config file at the bottom) which does not cause any troubles, even when watching full HD movie for more than two hours. Audio output is set to HDMI and TV is used to decode audio.

If I turn off TV or change TV source to any other source to display on TV and leave RPi turned on, XBMC and RPI will eventually freeze (in few hours).
In some cases when it is frozen I get error message from TV saying "there is no source" when I try to select HDMI source from RPi on TV. In other cases TV can connect to HDMI source from RPi and it shows picture from RPi on TV but XBMC and RPi are frozen - image is frozen. CEC remote control does not work, skin animation is frozen (I'm using nbox skin) and all lights on RPi are on (no flashing of network LED).

If I leave TV on with HDMI source selected to RPi it will never froze, even if it is on for days until TV is on and HDMI source is selected to RPi.

In all cases XBMC is left to display home screen or Movie/TV Shows library.

Any idea what might cause this odd issue? I did not have this issue until I updated openELEC from last stable build to 3.1.X (I think it was 3.1.2 but I'm not sure).
Any help or ideas are much appreciated.

Config file
Code:
arm_freq=900
core_freq=430
sdram_freq=430
force_turbo=1
gpu_mem=256
disable_overscan=1

config_hdmi_boost=4
hdmi_ignore_cec_init=1

decode_MPG2=0xd6ef99bf
decode_WVC1=0xc7f09fe3
(This post was last modified: 2013-09-05 09:57 by dejc.)
find quote
trogggy Offline
Senior Member
Posts: 169
Joined: Mar 2011
Reputation: 11
Location: Monthou sur Cher, France
Post: #2
Do you have this, or is it disabled (ie # in front)?
Quote:# Force HDMI even if unplugged or powered off
hdmi_force_hotplug=1
find quote
dejc Offline
Junior Member
Posts: 12
Joined: Sep 2012
Reputation: 0
Post: #3
No I do not have it. My config file is like is it shown in original post. I will add it to config file and check the result. I hope it will help.

Thanks Nerd
(This post was last modified: 2013-09-05 10:10 by dejc.)
find quote
popcornmix Offline
Team-Kodi Member
Posts: 2,967
Joined: Feb 2011
Reputation: 69
Post: #4
It might be CEC.

In system/settings/system/input devices/peripherals press enter. There's a whole load of options.
E.g.
"When TV is switched off : Suspend"
etc.
Play with those settings (it may be stutting down xbmc when TV is switched off)
find quote
dejc Offline
Junior Member
Posts: 12
Joined: Sep 2012
Reputation: 0
Post: #5
trogggy and popcornmix thanks both of you Big Grin It works!

I have added hdmi_force_hotplug=1 in config.txt file and changed CEC settings "When TV is switched off" to "Ignore".
find quote
dejc Offline
Junior Member
Posts: 12
Joined: Sep 2012
Reputation: 0
Post: #6
New OpenELEC (3.2.0) and same issue, again. I haven't changed anything, just updated to OpenELEC 3.2.0. Any new or more ideas?
find quote
dejc Offline
Junior Member
Posts: 12
Joined: Sep 2012
Reputation: 0
Post: #7
Watchdog was the cause of the RPi freezing. Apparently there is some issue with Watchdog and my Synology DS212j NAS from where RPi reads video content.
find quote
eros111 Offline
Junior Member
Posts: 15
Joined: Dec 2013
Reputation: 0
Post: #8
Hi

I have the same problem running openelec. I changed CEC settings "When TV is switched off" to "Ignore" and this is my config file

# Force HDMI even if unplugged or powered off
# hdmi_force_hotplug=1

Should I change anything there?

My rpi freezes all the time in idle, for no reason. I have tried several PSU so that is not the problem.
find quote
dejc Offline
Junior Member
Posts: 12
Joined: Sep 2012
Reputation: 0
Post: #9
If you have hashtag in front of hdmi_force_hotplug=1 in config file that this option is not applied in your case, because hastag is a line comment.

Have you checked if you have any scripts like I had watchdog to update library?
find quote
LilSnoop40 Offline
Junior Member
Posts: 14
Joined: Nov 2012
Reputation: 0
Post: #10
ok, I have this same issue. I am running Openelec 3.2.3, on 3 RPI boxes. 2 of the TV's don't' freeze on idle but one does. 1 TV Panasonic (running for 7 days straight), 1 TV Pioneer (running for 3 days straight, accidently rebooted) and the 3rd is a Samsung freezes about ever day while TV off and idle. they all have the same add-ons installed on them and same power supply's. as we as the same over clock settings:

arm_freq=900
core_freq=450 or 400
sdram_freq=450 or 400
over_voltage=0

I will try this when I get home:


"It might be CEC.

In system/settings/system/input devices/peripherals press enter. There's a whole load of options.
E.g.
"When TV is switched off : Suspend"
etc.
Play with those settings (it may be stutting down xbmc when TV is switched off) "

for this setting where at in the config.txt do I add it:

hdmi_force_hotplug=1

and do I just add with out the "#"

Thanks!
find quote
dandnsmith Offline
Senior Member
Posts: 247
Joined: May 2013
Reputation: 1
Location: Berks, UK
Post: #11
(2014-02-19 13:59)LilSnoop40 Wrote:  for this setting where at in the config.txt do I add it:

hdmi_force_hotplug=1

and do I just add with out the "#"

Definitely without the # (which might have the effect of commenting it out)

Derek
find quote
LilSnoop40 Offline
Junior Member
Posts: 14
Joined: Nov 2012
Reputation: 0
Post: #12
So when I look at this line in the config.txt below is the default setting:

################################################################################​
# various settings see also: http://elinux.org/RPi_config.txt
################################################################################​

# Force HDMI even if unplugged or powered off
# hdmi_force_hotplug=1


I should make it look like this:

################################################################################​
# various settings see also: http://elinux.org/RPi_config.txt
################################################################################​

# Force HDMI even if unplugged or powered off
hdmi_force_hotplug=1

Thanks!
find quote
rsperson Offline
Junior Member
Posts: 10
Joined: Nov 2013
Reputation: 0
Post: #13
Same issue here:

I am running Gotham with the OpenELEC distro

I already have:

"When TV is switched off : Ignore"

and in the config.txt I have

hdmi_force_hotplug=1

any other suggestions - Pi powers off about 6 seconds after HDMI display
It has one red light and I can no longer ssh into it
It will run for hours (haven't tested days) with the display turned on
find quote
popcornmix Offline
Team-Kodi Member
Posts: 2,967
Joined: Feb 2011
Reputation: 69
Post: #14
Can you also add:
hdmi_ignore_cec=1

to config.txt and reboot. This will stop cec working, but you can control with browser or smartphone app (actually, you may not even need to control it if problem is visible straight from boot when turning TV off).

Does issue still occur? If this fixes it then it is CEC causing power down. If not, then it's something else.
find quote
rsperson Offline
Junior Member
Posts: 10
Joined: Nov 2013
Reputation: 0
Post: #15
oops:

I already have:

hdmi_ignore_cec_init=1

is that the same as

hdmi_ignore_cec=1

I will add anyway, can't hurt
find quote
Post Reply