[BETA] XBMB3C - Media Browser AddOn for XBMC

  Thread Rating:
  • 5 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
crimsonfury Offline
Fan
Posts: 514
Joined: Mar 2012
Reputation: 1
Location: Arizona, U.S.
Post: #241
(2014-02-25 05:48)xnappo Wrote:  
(2014-02-25 05:29)crimsonfury Wrote:  Are you running the Gotham vs of Aeon Nox 4.1.9.4 ?

No - where is that? I only see 4.0.9 and 5.0 preview in the official repo.

xnappo

https://github.com/WarLion/skin.Aeon-Nox-4.1.9

http://forum.xbmc.org/showthread.php?tid=185290

[Image: all-thin-banner@2x.jpg]
find quote
xnappo Offline
Fan
Posts: 345
Joined: Oct 2008
Reputation: 10
Post: #242
Yeah, so those file are from 4.0.9 and are probably not compatible with that version.

xnappo
find quote
crimsonfury Offline
Fan
Posts: 514
Joined: Mar 2012
Reputation: 1
Location: Arizona, U.S.
Post: #243
I read that Aeon-Nox-Gotham works best with xbmc Gotham... They said it shows more artwork too... Can we get the skin files updated to work with it?

[Image: all-thin-banner@2x.jpg]
find quote
nabsboss Offline
Junior Member
Posts: 41
Joined: Sep 2012
Reputation: 1
Post: #244
OK thanks! I finaly found a workaround
find quote
xnappo Offline
Fan
Posts: 345
Joined: Oct 2008
Reputation: 10
Post: #245
(2014-02-25 16:59)crimsonfury Wrote:  I read that Aeon-Nox-Gotham works best with xbmc Gotham... They said it shows more artwork too... Can we get the skin files updated to work with it?

Well what we really want is for the skin devs to add support for our AddOn to their skin.

Us hacking at their skin is just going to continue to lead to problems as they make changes.

I'll make you a deal:

You post over on the Aeon Nox thread and ask nicely to add support for our AddOn - telling them all the great things MB3 can do. We will help them with any questions they have.

If you can do that, then I will do another hack with that version short-term.

xnappo
find quote
JDizzy Offline
Fan
Posts: 376
Joined: Apr 2009
Reputation: 1
Location: Californication
Post: #246
(2014-02-25 08:00)null_pointer Wrote:  I just check in a change that should fix your progress dialog error

Thanks! That now works.

I recently update my server to version 3.0.5168.16132. It now takes close to 40 seconds to load 1200 movies. With previous server release it was more like 20 seconds.
Ugh! -- I will post on the MB forums and see what is up with that. [EDIT]: I posted on MB and they said they believed it unusual for it to take that long to load.
I do have People, Overview, and Stream info turned off but what is the use of having a nice database when all the info is stripped off?
Also, when stopping a movie, it takes another 40 seconds to return to menu again (it re-parses everything again).
It seemed that previous version was faster... I will check it out. [EDIT] Loaded older XBMB3C version and now I suspect that the newest version of MB server (with more data) is slower loading content... don't really know.

Turns out I had Debugging and Profiling turned on from when I was troubleshooting
and it was REALLY slowing things down. Now, after turning debug off the movies load in about 8-10 seconds!
MY Bad.......



ASUS Republic of Gamers laptop i5 running Mediabrowser 3 or Plex Server - Zotac Zbox client running OpenELEC 4.0 w/XBMC Gotham with XBMB3C or PleXBMC Addon (depending on weather) - 12TB
(This post was last modified: 2014-02-28 23:16 by JDizzy.)
find quote
null_pointer Offline
Senior Member
Posts: 159
Joined: Oct 2011
Reputation: 5
Post: #247
When the progress dialog comes up what is taking the most time, Downloading, Parsing or adding the items?
find quote
xnappo Offline
Fan
Posts: 345
Joined: Oct 2008
Reputation: 10
Post: #248
(2014-02-24 23:04)Ballistic Wrote:  Looks good so far. Noticed a few bugs on the first tries but after trying it again a couple of times, i cannot seem to reproduce them.

Thanks for all the work. Here's your plugin in action on one of my systems;
https://www.youtube.com/watch?v=zMmw6OO1xYQ

I would like to see an MB3 log with debug turned on from this access that takes a long time.

null_pointer - I don't think we can tell if it is really downloading or waiting on the server?

I had a problem with very slow server crunching back when I was using FlexRaid pooling...

xnappo
find quote
null_pointer Offline
Senior Member
Posts: 159
Joined: Oct 2011
Reputation: 5
Post: #249
Quote:null_pointer - I don't think we can tell if it is really downloading or waiting on the server?
correct, from a client point of view it is just slow to download, but will at least know it is not the client. You would need to compare server logs for this.
find quote
Pete1989 Offline
Junior Member
Posts: 16
Joined: Mar 2013
Reputation: 0
Post: #250
Hi there,
I have MB3 set up to monitor a folder to which I download youtube vids too, create what meta it can (set to home video in MB3). In XBMC, it is displaying all the episodes by name.

Is it possible to edit the video node to display by date created?

Thanks.
find quote
xnappo Offline
Fan
Posts: 345
Joined: Oct 2008
Reputation: 10
Post: #251
(2014-02-26 01:27)Pete1989 Wrote:  Hi there,
I have MB3 set up to monitor a folder to which I download youtube vids too, create what meta it can (set to home video in MB3). In XBMC, it is displaying all the episodes by name.

Is it possible to edit the video node to display by date created?

Thanks.

I think if you change the sort order via the context menu, it should stay sticky.

xnappo
find quote
JDizzy Offline
Fan
Posts: 376
Joined: Apr 2009
Reputation: 1
Location: Californication
Post: #252
(2014-02-25 22:17)null_pointer Wrote:  When the progress dialog comes up what is taking the most time, Downloading, Parsing or adding the items?
OK,
After realizing I had Debug and Profiling toggled ON, I turned them off and now everything loads very quickly!
Thanks for all the help!

ASUS Republic of Gamers laptop i5 running Mediabrowser 3 or Plex Server - Zotac Zbox client running OpenELEC 4.0 w/XBMC Gotham with XBMB3C or PleXBMC Addon (depending on weather) - 12TB
(This post was last modified: 2014-02-28 23:18 by JDizzy.)
find quote
Pete1989 Offline
Junior Member
Posts: 16
Joined: Mar 2013
Reputation: 0
Post: #253
(2014-02-26 16:11)xnappo Wrote:  
(2014-02-26 01:27)Pete1989 Wrote:  Hi there,
I have MB3 set up to monitor a folder to which I download youtube vids too, create what meta it can (set to home video in MB3). In XBMC, it is displaying all the episodes by name.

Is it possible to edit the video node to display by date created?

Thanks.

I think if you change the sort order via the context menu, it should stay sticky.

xnappo

Ahhh, hadn't thought to look in context. It kinda works - if I select' date added' it will change the view to the kinda default folder view and sort them, it also isn't 'stickying' the changes.
find quote
null_pointer Offline
Senior Member
Posts: 159
Joined: Oct 2011
Reputation: 5
Post: #254
You can post logs to pastbin.

yes it sounds like something is not correct, do you have debug logging turned on in the addon? That can slow it down a lot.
also turn on profiling, load the movie view and then in the addon data dir you should see a profile txt file, post that to past bin so we can have a look at where all the time is being spent.
find quote
Ballistic Offline
Senior Member
Posts: 125
Joined: Nov 2009
Reputation: 2
Post: #255
(2014-02-25 00:17)null_pointer Wrote:  excellent thanks for the video, so do you think the progress dialog helps? it looks like a lot of your time is spend in downloading the json data when you view the movies for the first time, parsing and adding the items still take up some time but the initial data download looks like the main time hog.

I am forcing gzip compression on the HTTP request at the moment, perhaps on large requests on fat networks it might be quicker to not compress.

(2014-02-25 01:39)null_pointer Wrote:  Also one thing you can try is turn off Overview, People and Stream Info in the addon settings (XBMB3C->Settings->Media Data), this greatly reduces the amount of data that needs to be send/received/decoded. I would be interested if you could test this and see how much quicker the data load is.

To trigger a full reload of the movie data mark a movie as watched or unwatched, this should trigger a reload of the data when you next view the movie section.

My MB3 server is powered by Dual Quadcore Xeon's and don't see any CPU/Memory load on it when entering Movies on my XBMB3c client. Only a very short io peak of about 5MB/sec. The Server located on the internet with a 1Gbit pipe. It is 8 hops away.
Client is on a 100mbit fiber connection. Bandwidth should not be the issue.

Peoples info is turned off. Overview and Stream info is on. Turning this off does not seem to do anything to the performance. Maybe this is because it already has all the information cached for the currently added content. Perhaps it does improve loading times when it is turned off from the first time the content is loaded?

As far as processing speeds go; The system on in my video is a Intel i5 and takes several seconds. A different system of mine is a Dualcore Atom 2550 and takes about 10 seconds for 3000+ items there.

Here is an XBMC log, please let me know what other logs i can create for you and where i can find the logfiles.
http://pastebin.com/pQJ9zvVC
Note that this log was created when there was no new content for the client. So, no "Downloading" during the get. Only Parsing and Processing.


Edit:
Added new content to force a "Download JSON Data". Just read it's also possible when doing a watch/unwatched.
Again very little server load.
XBMC Log: http://pastebin.com/99NBZZ41
(This post was last modified: 2014-02-27 00:03 by Ballistic.)
find quote
Post Reply