Problem Live TV - Mediaportal Server 1.2.3 and RasPi

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
gurkenmann Offline
Junior Member
Posts: 3
Joined: Dec 2013
Reputation: 0
Post: #1
Hi guys,

maybe someone can help me, i have a Raspberry Pi Model B version and installed first Xbian and than Raspbmc.
Both with the same problem - i can not start Live TV without any problems. Sometimes it worked mostly not.

I can play already recorded movies without any problems but i can not start Live TV. Most of the time when i try to start Live TV, XBMC crash to the console or restarts.

I tried it with the TSReader (which i prefer) and also with the ffmpeg streaming method - both are not working.

Here are some logfiles:
Xbian directly after the crash.
http://pastebin.com/7NPXqFP8

Xbian dmesg before the crash:
http://pastebin.com/1iAPxnnW

and after the crash:
http://pastebin.com/YYvhQ8qm

Raspbmc:
http://pastebin.com/m7LFpzhN

In Raspbmc i tried Live TV directly after the installation with a SD channel and it worked. Than i switched to an HD channel and the system crashed. After the restart i tried again the SD channel and the system restarted again and i was not able to run Live TV anymore.

Another test was to add the timeshift folder from the server to the XBMC videofolder, i started manually timeshift on the server and opened the .ts timeshift file. XBMC was able to play the file without any problems.
(This post was last modified: 2013-12-25 14:02 by gurkenmann.)
find quote
margro Offline
Fan
Posts: 652
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #2
I can't help you with RPi related problems. I don't have one.
With respect to the crashes in "ffmpeg" mode: it is XBMC itself that is doing the RTSP stream playback, not the PVR addon, so the XBMC+ffmpeg library combination is causing troubles here.

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
gurkenmann Offline
Junior Member
Posts: 3
Joined: Dec 2013
Reputation: 0
Post: #3
thx for the answer, the strange thing is when i start timeshift manually on the server than i can open the timeshift file in the videofolder without any problems. But when i start the timeshift file with LiveTV in XBMC, RaspPi crash all the time.
find quote
margro Offline
Fan
Posts: 652
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #4
I will see if I can borrow my friends RPi in the coming month for a crash/debugging session...

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
gurkenmann Offline
Junior Member
Posts: 3
Joined: Dec 2013
Reputation: 0
Post: #5
already solved the problem - as you said it was not your Addon - updated everything - Firmware, Software etc. in the end it worked
find quote