Raspbmc: delay between songs, "working"

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
muckster Offline
Junior Member
Posts: 14
Joined: Jan 2014
Reputation: 0
Music  Raspbmc: delay between songs, "working"
Post: #1
When I play music on raspbmc, I get a longish delay (~10-15 seconds) until the screen updates. The music plays right away, but there's no fanart, no song and album info while the spinner indicates the system is "working". This shouldn't be a big deal, but it's exactly the moment when you look up to see what the new song is... so it gets you every time.

Does this have to do with downloading or loading the fanart? (I'm on the default Confluence skin). I don't really think that can be it though because this even happens if it's the same album, ie the fanart doesn't change at all.

Is there anything I can do to optimize speed? I run off an SD card, but all media and system data is on a USB hard drive.

Thanks!
find quote
deejayq Offline
Junior Member
Posts: 44
Joined: Dec 2013
Reputation: 0
Post: #2
try to put raspbmc alternative to openelec's /storage on a usb stick, maybe that will help
(This post was last modified: 2014-01-21 15:33 by deejayq.)
find quote
muckster Offline
Junior Member
Posts: 14
Joined: Jan 2014
Reputation: 0
Post: #3
Thanks. Do you have a link or quick advice how to do that? I'm looking in the wiki but coming up empty so far. How big/fast should the stick be?
find quote
muckster Offline
Junior Member
Posts: 14
Joined: Jan 2014
Reputation: 0
Post: #4
OK, it took me a while, but I tried both OpenElec and Raspbmc with the file system on a USB3 stick -- but I'm still getting that delay. Raspbmc seems a little faster overall, but the delay between songs is the same.

Any other ideas what I might try to get rid of it? Has anyone else encountered this?
find quote