Mac OS X - Audio sync off with refresh rate switching (nightly builds)

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ercaronte Offline
Junior Member
Posts: 5
Joined: May 2014
Reputation: 0
Post: #46
Hi juramusger,
thank you for the quick reply and nailed feedbacks. Your doubts were both correct.

>>> Are you sure that "sync playback to display" is necessary for it to happen? <<<
Confirmed: it is not necessary to set it for the issue to happen (and "Vertical blank sync" was enabled).

>>> Are you sure that you *really* tried with software decoding? <<<
Confirmed again: I could enable SW decoding only by disabling "use vda decoder". SW decoding was confirmed by the codec info overlay (and by the CPU usage :-).

It sounds that the developer team already has most of the information, but just in case I posted a debug log here.

Thank you again!
find quote
lord-j Offline
Junior Member
Posts: 1
Joined: May 2014
Reputation: 0
Post: #47
Ma petite pierre à l'édifice...

My setup : hackintosh, HD4000, M-Audio Transit, 10.9.2

I get a more or less 100ms delay between sound and image in these conditions : 24p, DTS, plasma sync to 24p, VDA.
→ It happens straight from the beginning, no need for fforward or freward
→ When i switch to sw decode, it doesn't change anything

I get a correct sync in any of these 2 cases :
1. when the movie is running, unselecting-reselecting passthrough
2. Setting the option : delay for switching display to 0.5s

Point 2. is what i do to get things working.
I reckon the shift between audio au video happens when switching display to 24p, where the audio might not wait for the video...
(This post was last modified: 2014-05-12 10:29 by lord-j.)
find quote
juramusger Offline
Member
Posts: 59
Joined: Mar 2014
Reputation: 1
Post: #48
(2014-05-12 10:28)lord-j Wrote:  Ma petite pierre à l'édifice...

My setup : hackintosh, HD4000, M-Audio Transit, 10.9.2

I get a more or less 100ms delay between sound and image in these conditions : 24p, DTS, plasma sync to 24p, VDA.
→ It happens straight from the beginning, no need for fforward or freward
→ When i switch to sw decode, it doesn't change anything

I get a correct sync in any of these 2 cases :
1. when the movie is running, unselecting-reselecting passthrough
2. Setting the option : delay for switching display to 0.5s

Point 2. is what i do to get things working.
I reckon the shift between audio au video happens when switching display to 24p, where the audio might not wait for the video...

I'm pretty sure that is a separate issue. As far as I know there is an uber-long thread about this in the general or Linux section of this board. I remedy this by introducing a delay via advancedsettings.xml . OpenElec has it by default if I remember correctly.
find quote
ercaronte Offline
Junior Member
Posts: 5
Joined: May 2014
Reputation: 0
Post: #49
Following up my previous post, I guess everybody is happy with switching to SW decoding.
Unfortunately I have a macmini 2010 and the ffmpeg soft decoding goes to more than 100% in some movies and the results are bad artifacts on the screen.

If I want to keep the hardware I guess either I go back at 12.3, or I need to wait for a fix, or make it. On the latter alternative, is anybody working on this issue?
(This post was last modified: 2014-05-15 02:21 by ercaronte.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,850
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #50
You all could try to disable passthrough and use 5.1 (or whatever speaker setup you have) instead - with this test build - where i finally fixed the wrong channel mapping in multichannel pcm mode.

http://mirrors.xbmc.org/test-builds/osx/...x86_64.dmg

Passthrough is not recommended anyway and once multi channel pcm is confirme fixed - its the better solution to have proper a/v sync. (i know that this is not an option for optical links but only for hdmi or usb devices with multichannel pcm support.)

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
(This post was last modified: 2014-05-15 11:00 by Memphiz.)
find quote
japardo Offline
Junior Member
Posts: 2
Joined: May 2014
Reputation: 0
Post: #51
On a mac mini with snow leopard, xbmc13.1 beta fixes the audio lag issue with vda decoder activated. Wink
find quote
ercaronte Offline
Junior Member
Posts: 5
Joined: May 2014
Reputation: 0
Post: #52
(2014-05-15 10:59)Memphiz Wrote:  You all could try to disable passthrough and use 5.1 ...

In my setup (macmini and Maverick 10.9.2) I am not using audio passthrough, but I tried the build in any case.
The lag issue is still present with vda decoder activated.
find quote
mou Offline
Junior Member
Posts: 29
Joined: Jan 2005
Reputation: 1
Post: #53
Try setting "Render method: Software".
This solved my framedropping after skipping/pause.

Btw "Allow hardware acceleration (VDADecoder): Enabled" is okay.
find quote
mou Offline
Junior Member
Posts: 29
Joined: Jan 2005
Reputation: 1
Post: #54
(2014-05-19 23:51)mou Wrote:  Try setting "Render method: Software".
This solved my framedropping after skipping/pause.

Btw "Allow hardware acceleration (VDADecoder): Enabled" is okay.

Maybee not the perfect solution... It seems to crash quite alot with software decoder
find quote
ercaronte Offline
Junior Member
Posts: 5
Joined: May 2014
Reputation: 0
Post: #55
(2014-05-19 23:51)mou Wrote:  Try setting "Render method: Software".
This solved my framedropping after skipping/pause.

I tried that, and it fixes the sync issue after skipping/pause. Unfortunately however, I have a macmini 2010 and the ffmpeg soft decoding goes to more than 100% in all BD movies. The results are bad artifacts on the screen, so bad that you can not watch such movies. On the other hand, CPU stays at 40% with VDAdecoder.
find quote
juramusger Offline
Member
Posts: 59
Joined: Mar 2014
Reputation: 1
Post: #56
(2014-05-16 11:17)japardo Wrote:  On a mac mini with snow leopard, xbmc13.1 beta fixes the audio lag issue with vda decoder activated. Wink

I confirm this finding also for 13.1 beta2. and Mountain Lion. On my MBP running 10.8.5 the 13.1. betas fix the issue. After unpausing the video needs just a moment catching up but then sync is restored. I can see about 20-40 dropped frames each time I do this in the codec info overlay.

Strangely enough it is not fixed on my MBA running Mavericks. So now it is a OS-specific issue after all. Before the same problem would affect both 10.8. and 10.9.
I hope this helps the investigation. Instruct me to do further testing if needed!

(2014-05-20 01:18)ercaronte Wrote:  
(2014-05-19 23:51)mou Wrote:  Try setting "Render method: Software".
This solved my framedropping after skipping/pause.

I tried that, and it fixes the sync issue after skipping/pause. Unfortunately however, I have a macmini 2010 and the ffmpeg soft decoding goes to more than 100% in all BD movies. The results are bad artifacts on the screen, so bad that you can not watch such movies. On the other hand, CPU stays at 40% with VDAdecoder.

Also for me hardware decoding would be much better. CPU usage only reaches about 60% on my machines but that's enough to make the fans spin up considerably.

(Just selecting Software without deactivating VDA beforehand still does nothing for me though. Should I open a separate thread about that? It's not for the 13.1 beta thread as it isn't a regression.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,850
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #57
Software rendering and vda is not compatible. When vda is enabled its always vda rendering.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
juramusger Offline
Member
Posts: 59
Joined: Mar 2014
Reputation: 1
Post: #58
(2014-05-20 13:04)Memphiz Wrote:  Software rendering and vda is not compatible. When vda is enabled its always vda rendering.

Makes sense and is what I'm seeing. The way the settings are implemented is just not very intuitive for people not too familiar with the technical background. When you select "software" as decoding method the toggle for VDA gets greyed out and seems to be disabled. But it's not.
See the posts by ercaronte to witness how it even makes troubleshooting more complicated. It was only because I had already found out before that I could ask him to verify the results that might otherwise have been taken at face value.

Also - and thereby I find the way back to the thread topic - it makes testing new versions for the lipsync issue just slightly inconvenient. What should be one setting is two.
(This post was last modified: 2014-05-20 13:28 by juramusger.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,850
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #59
Thats a bug in the new settings system ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
juramusger Offline
Member
Posts: 59
Joined: Mar 2014
Reputation: 1
Post: #60
(2014-05-20 17:27)Memphiz Wrote:  Thats a bug in the new settings system ...

That's what I thought and why I asked whether to open a separate thread as my reporting in the (old) Gotham beta thread was not taken up.
But now I take your post as saying that it is a known bug.
find quote