Movies beginning with "The"

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
kye Offline
Junior Member
Posts: 36
Joined: Apr 2006
Reputation: 0
Post: #1
I've used many past T3CH builds of XBMC. I loaded up the most recent 2008-09-01 build and it works great for the most part. I do notice now that all my movies that start with "The" such as "The Queen" are now listed down in the T section when sorted alphabetically. Past version of T3CH's build didn't do this and I would like to be able to change it back to what I'm used to. I looked through the settings but didn't see an option to ignore "The" while sorting.

Is there any way to fix this? I also noticed that it still ignores "The" while in Library Mode.

Thanks in advance.
find quote
ShortySco Offline
Fan
Posts: 329
Joined: Apr 2007
Reputation: 0
Post: #2
I think the option you are looking for is Appearence/View options/Ignore Tokens when sorting.

I think you can add extra tokens too, with the advanced settings.xml (ie. for "A nightmare on Elm St", for example)

Shorty
find quote
kye Offline
Junior Member
Posts: 36
Joined: Apr 2006
Reputation: 0
Post: #3
Thanks for the helpful reply. I added the advancedsettings.xml file and am still having trouble. This is the body of advancedsettings.xml.

Code:
<advancedsettings>

  <sorttokens>
     <token>the</token>
     <token>The</token>
  </sorttokens>

</advancedsettings>


With that file and no matter if I turn the "Ignore tokens when sorting" option on or off it doesn't seem to make a difference.
find quote
ShortySco Offline
Fan
Posts: 329
Joined: Apr 2007
Reputation: 0
Post: #4
hmmm... i'm not sure... sorry.

With the option enabled "The" is filtered without the advanced settings, it's for adding others (Dunno if any others are by default or not)

All i can really add, is that this works for me in library mode, but not files (I assume this is meant to be?)

Shorty
find quote
kye Offline
Junior Member
Posts: 36
Joined: Apr 2006
Reputation: 0
Post: #5
Yes this is exactly the same for me. Work in Library mode but not in Files View. This is a fairly recent change though and I hold out hope there is a way to get the old sort order back.
find quote
spiff Offline
Retired Developer
Posts: 12,386
Joined: Nov 2003
Post: #6
not in file view, its a file view. a view of your files
find quote
kye Offline
Junior Member
Posts: 36
Joined: Apr 2006
Reputation: 0
Post: #7
Sorry I know I'm not the best at explaining this. What I mean is while in the video section of XBMC listing my video while not in library mode.
find quote
Bloksel Offline
Junior Member
Posts: 39
Joined: Feb 2008
Reputation: 0
Location: The Netherlands
Post: #8
Same problem here. In some skins it did'nt work, but now even when I use "Project Mayhem III" it will not work anymore. I tried every setting and different skins.
The "Ignore The" seems to do nothing.
Standard, I use the "Basic-Vision" skin.
find quote
sho Offline
Team-XBMC Member
Posts: 4,128
Joined: May 2004
Reputation: 3
Post: #9
kye Wrote:What I mean is while in the video section of XBMC listing my video while not in library mode.
Not in Library Mode = File View.
See Spiff's answer.

mgboom, same goes for you then.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Bloksel Offline
Junior Member
Posts: 39
Joined: Feb 2008
Reputation: 0
Location: The Netherlands
Post: #10
Sho, I know what you mean. But in previous versions it worked, so why was it removed? Some people don't want to use the library mode. I personally hate it, because its very slow if you have a lot of files.
find quote
sho Offline
Team-XBMC Member
Posts: 4,128
Joined: May 2004
Reputation: 3
Post: #11
Presumably because a decision was made to have the files view a... uhm... files view.
That is not my experience, what do you call "a lot of files"?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Bloksel Offline
Junior Member
Posts: 39
Joined: Feb 2008
Reputation: 0
Location: The Netherlands
Post: #12
Around 2000 that actually exist.
Another annoyance; To clean to library, I have to rebuild it every somewhat months, because I sometimes replace files (Cleaning the database through the settings/movie dialog doesn't work that well).

MyVideos34.db = 12Mb. So it's presumably time to rebuild it again.

But I would simply prefer to use the File View, I don't need all the overload in library mode.
find quote
Pr.Sinister Offline
Fan
Posts: 680
Joined: Sep 2007
Reputation: 15
Location: Montreal, Canada
Post: #13
I too was disappointed to find that the recent builds couldn't ignore "The" in
file mode.

Library is all fine and dandy for people who don't suffer from OCD or are extremely
anal like myself.

I like my Library to be perfect so my "Downloads" folder isn't part of it. I do not
have time to cleanup my Downloads folder to move contents to their proper
place as soon as they are downloaded. I do it once a week or even once a month. So i use file mode to watch yesterday's episode of "The Cleaner" or
"The Shield". The 1st one used to be under the C's and the second under the S's.

I do not want to have to scan a filename that is not in it's proper place and that
is not named the way i like it. I personally cannot stand to have files in
my extensive library that are named

"The.Shield.S07E01.REPACK.DSR.XviD-0TV.[VTV].avi"

I rename those when i have time and they are then moved to the proper
drive :

The Shield-(7x01)-Coefficient of Drag.avi

What's annoying is that before library mode, i used to name my movie folders
in this way :

Bourne Ultimatum, The (2007)

But the IMDB scraper wouldn't always find movies named this way. Then i
found the wonderful option of ignoring "The" so i renamed all my folders to
the proper way. Now, it is gone from filemode.

I am trying to find a way to use Library mode all the time but it isn't easy
to do because i download a lot of stuff every day and simply cannot spend
all my free time preparing files to be imported into the library. I already am
way behind in importing my current 7 TB of Movies and TV Shows but when
i figure out the best way, i will let all the other OCD sufferers know Smile

P.S. This is by no means a rant/flame. Just explaining one of the many reasons
why many people are not in Library mode 24/7.

-Pr.

------------------------------------------
[4 XBMC Clients + 3 Norco RPC-4224 Media Servers w/74 TB HDD Space]
If my post helped, thank me by adding to my reputation! :)
find quote
Hippo Online
Junior Member
Posts: 49
Joined: Feb 2008
Reputation: 0
Post: #14
I noticed on build 15201 that my movies (which are in a multipath by the way) were not being sorted correctly. Rather, all the "The .." movies were clumped together despite my having "Ignore tokens when sorting" switched on. I turned that setting off, no change. Back on, no change.

So, I rebuilt to 15551, just to be sure. The problem is still there.

I had an old build 14430 lying around. That one does NOT have the problem.

Did this just get forgotten? Am I the only one? I'll post a log file if anyone wants, but this doesn't seem to be that kind of problem...

Thanks,
-Dan
find quote
spiff Offline
Retired Developer
Posts: 12,386
Joined: Nov 2003
Post: #15
it now only applies to library view
find quote
Post Reply