[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs

  Thread Rating:
  • 17 Votes - 4.82 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
M3m3nt0 Offline
Junior Member
Posts: 4
Joined: May 2013
Reputation: 0
Post: #4336
(2014-09-17 11:18)M3m3nt0 Wrote:  Hi guys!

I'm unable to properly import a standalone game (SuperTuxKart) under (Ed)Ubuntu 14.04.

How could I create a shortcut to launch it under RCB?

I've tried use the .desktop file but it fails... Sad

You will probably need to make a script to launch the game, and use the script as the ROM and bash as the emulator.
[/quote]

Could you please help me doing it?

I've made this script (is it correct?):
Code:
#!/bin/bash

/usr/games/supertuxkart --no-console

Then I've added the ROM collection selecting "Linux" and "*.sh" as file mask;
"Emulator Cmd" : /bin/bash
"Emulator params" : sh "%ROM%".sh

It does not work... Sad

if i directly input /usr/games/supertuxkart in "Emulator Cmd" and --no-console in "Emulator params", it starts correctly...
find quote
teeedubb Offline
Donor
Posts: 2,594
Joined: Mar 2010
Reputation: 62
Location: Down Under
Post: #4337
As the emu param use just "%ROM%" , everything else looks right.

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
(This post was last modified: 2014-09-17 23:55 by teeedubb.)
find quote
ricardo85x Offline
Junior Member
Posts: 3
Joined: Sep 2014
Reputation: 0
Post: #4338
Hi

Are there any limit on the number of roms we can have per system?

I have 8668 mame' roms, but it just list 4039
(This post was last modified: 2014-09-19 14:42 by ricardo85x.)
find quote
malte Offline
Skilled Python Coder
Posts: 1,349
Joined: Jan 2010
Reputation: 28
Location: Germany
Post: #4339
Found some time again to answer the latest requests.

Tomkun Wrote:Sorry to keep bothering you, but I am getting this error when trying to scrape with a new scraper I have created. I don't know if it's an error on my part, or possibly a bug?
Ok, I was able to get it working with this parser:
Code:
<parserConfig>
    <GameGrammar type="multiline">            
       <SkippableContent>$info=</SkippableContent>
       <crc restOfLine="true"></crc>
       <SkippableContent>$bio</SkippableContent>
       <Description skipTo="LineStart- SERIES -LineEnd"></Description>
    </GameGrammar>
</parserConfig>
Still had some issues with it as it keeps the "," at the end of the title. I had no more time to look into this atm. If you don't get it, please come back and I will see if I find some more time later on.

diedel Wrote:I'm trying to import game data from my MSX game collection and I've noticed that the mobygames scraper doesn't import any image. By analyzing the resources\scraper\04.09 - mobygames - screenshotlink.xml file, the log file and the mobygames webpage, I've discovered that the problem is because the token <div class="thumbnailContainer"> has been replaced by <div class="mobythumbnail">. Thus I've changed it in the 04.09 - mobygames - screenshotlink.xml file and it seems it works now.
By the way, when importing screenshots from mobygames (or any other site), is it possible to select the desired screenshot to import to the database? In mobygames the first screenshot is almost always the title screenshot and that is the less interesting
Thanks a lot for the fix. I will check it and include in the next release.

Chadthomson19 Wrote:Hi I'm having a problem with rcb when it comes to opening a emulator and launching a rom. The emulator opens up outside of xbmc and into a window and not full screen. The option "use emulator in solo mode" doesn't seem to do anything either. Any help would be appreciated. Thanks.
What emulator are you trying to launch and what arguments do you use? Usually you have to tell the emulator to launch in fullscreen. You will find some hints here: http://www.gwenael.org/xbmc/index.php?title=Main_Page


lrrosa Wrote:I'm having a problem with RCB handling of .7z files that I haven't seen anyone mention here.
I use version 2.0.17 with Openelec 4.0.7 x64 generic.

Of course all the lzma libs are there.
Is this some problem with the version of Python used in Openelec 4.0.7?
You will need to get the latest libs that are working with your python version (2.6 or 2.7). Unfortunately there are only some prebuilt packages available for windows: https://pypi.python.org/pypi/pylzma. On Linux you have to grab the source code and compile it yourself. My linux system is not up and running so I can't do this myself atm.


arucard Wrote:I created a patch to fix Issue 147

This should allow you to use a directory as emulator parameter, which basically allows you to use Higan as emulator.

You first need to configure RCB to use the game's folder name for scraping in order for it to be scraped correctly. But this patch then allows you to use the game's folder name as emulator parameter, which is what Higan requires (the imported game's folder, to be exact).

I was hoping this could get included in the next release of RCB.
Thanks for the fix. I will check it and include it in the next release.


Darkitz Wrote:Hey there,

Uhm yea its thinking that my xbmc is older than it is...
Code:
NOTICE: RCB_INFO: XBMC version: Assuming we are on Eden
ERROR: EXCEPTION: Unimplemented method: executehttpapi::executehttpapi(...)
im on gotham

iirc executehttpapi(...) is gone since frodo

does anybody have a solution?
It should say: "on Eden or above". RCB is trying to use executehttpapi and when it fails it uses the correct code for frodo or gotham. So, this isn't your issue. I guess you have issues with getting back to fullscreen after returning to XBMC? This could happen when your screensaver kicked in while you were playing. But I am just guessing as you did not tell me what issue you haveSmile


bbennett22 Wrote:I'm not sure if I did this correctly, but here is my log file: http://xbmclogs.com/show.php?id=284861

When I start rom collection browser, I selected SNES and several options that I have on my firetv came up (Retroarch and Snes9xex) I select the snes9xex (non retro-arch version) and then choose the path to my roms on my external hard drive. I setup the fan art and wait as it loads up my collection. It goes through each game I have (even downloads the artwork into the proper folders). However, every time its finished it comes up empty. my roms are stored on my hard drive as .smc and I type in *.smc when asked to do so. I have no clue what I'm doing wrong, but if anyone could help me out I would really, really appreciate it!
It looks like your log file does not belong to the behaviour you described. In your log it just says: "RCB_ERROR: Configuration error. config.xml does not contain any RomCollections". In this case it will never start any scraping. I guess that you did upload a log of another session.


prometheusbob Wrote:The problem I am having is that I can not figure out a configuration that will work, when trying to launch game for the Neo Geo. The Neo Geo roms are in .zip format. I tried a neoragex set but soon found that I could not frontend it with RCB or any frontend (emulators fault). So I switched to a winkawaks set.

I tried many methods to get them to launch with RCB. I tried putting the zipped roms directly in the winkawaks game folder and setting the winkawaks rom directory to there location. I tried all methods with "do not unzip" option clicked and not clicked. I've used "popen" and "stand alone" with my other set up combinations. I've even tried "%romname% instead of %rom%....

I have tried to search the internet for a fix but have ended up having to ask here. Any link or general advise for setting up a neo geo collection for RCB would be great and highly appreciated.
I never tried to set it up myself. But here is a link how to setup winkawaks with Advanced Launcher. Most of it should be valid with RCB too: http://www.gwenael.org/xbmc/index.php?ti...ks#Windows


Zacharybinx34 Wrote:Not sure what the deal is, after setting up all my rom paths I hit import and it immediately goes to a screen with a controller in the upper right. no scraping progress bar or anything.

ideas?

LOG:
http://xbmclogs.com/show.php?id=288774
You need to use correct file masks to find any games. E.g. "*.gb" instead of ".gb".


Hyperglide Wrote:Hi everyone! I'm having an issue with RCB when I go to import Playstation games I find that all the ISO's that have .sub extension in the ROM folder always re-import when I import new games, even though they already have nfo's and have been scraped numerous times. I tried adding a *.sub to the ROM File Mask, Saved Config and it doesn't seem to fix the problem. Can anyone tell me what's causing this? It's really annoying that, whenever I go to import a new game, it constantly scrapes games I've already got data for.
You have to deactivate Rescrape already imported games in Addon Settings. This should solve the issue.


ibleedspeed Wrote:Maybe it,s just me but after using this program today for the first time it seems horribly buggy and completely counter intuitive...I thought it was going to be amazing but it seems it will take a whole lot of time and research to even get it to be semi fun...I finally managed to get my nes roms scraped in and they work.... it did download the art but the problem I have is that the 3 viewtypes that come with rcb are bland and lifeless.... to top that off I have some random texts in the middle of the screen on every viewtype that do not belong there.....genre, year, and some others just floating in the middle of the screen for unknown reasons...perhaps this is not compatible with gotham idk but what I do know is this will not work for me...

I read in the faq about how the aeon skins are compatible but have no clue how to get them to work with rcb...I might keep after rcb and see if I can get it to look like others have done that I saw on youtube but I am so frustrated with this app for now I need to put it to rest for a few days...it has potential but seems the devs dont much care about fluidity or intuitive easy to use interface for rcb...back to advanced launcher for now...
As Tomkun already said, most of these issues occur because your main skin does not support RCB. That is the downside of implementing RCB as a script and not as a plugin. On the other hand there are some features that could not have been implemented in a plugin.

But I will see if the 720p/1080p orientation is causing some of these issues as this could be something that I might be able to fix on my own.


axlt2002 Wrote:Hi malte,

So I have played a little bit with export and import of nfo files. What I have noticed seems to be quite strange: when I change the description of the game quite drastically (i.e. completely from english to italian), the edited nfo file is not imported back into the RCB (using the LOCAL NFO scraper); when I edit it partially (i.e. change just few words in the description), it is imported back correctly and the changes are in fact displayed on the screen.

Does the LOCAL NFO parser (or something else) make some check on the nfo file dimension when importing it back?

Please let me know...I'm quite confused!
No, it does not. This can happen when the description contains some characters that RCB cannot handle properly (encoding issues). In this case it will just crash while exporting the nfo and does not write the complete file. This issue is already on my list (for some time as you already have discovered).


marcel19 Wrote:hi guys,

the last 5 days, i keep fighting with the same problem: NO SOUND.

i have tried everything.

i'm using the following setup:

Operating system: Openelec 4.0.7
Rom Collection Browser: 2.0.17
Retroarch addon: 4.1.0

when i start a game is going wel. until the point it should play the sound.
the game runs perfectly but without sound.
Sorry, can't be of help here. There are some interesting threads in the linux section of this forum. Maybe you will find some answers over there.


ricardo85x Wrote:Hi

I can't find the option to add Final Burn Alpha(FBA) games.

I am using the the android and the Mac OS build.

thanks
Yes, thats right. The last time I checked for it the online sites that I use to scrape did not list FBA as separate system. So I did not add it in RCB. I could do so but there will be no online scraping for these games.


M3m3nt0 Wrote:Hi guys!

I'm unable to properly import a standalone game (SuperTuxKart) under (Ed)Ubuntu 14.04.

How could I create a shortcut to launch it under RCB?

I've tried use the .desktop file but it fails...
You could create shell scripts (similar to batch files on windows) that launch your games. In RCB you have to reference these shell scripts (usually .sh). A simple example of such a script could look like this (not tested):
Code:
#!/bin/sh
/path/to/my/game
Save this file as "SuperTuxKart.sh" and make sure that this file is executable (of course insert the correct path to your gameWink). In RCB point to the folder with this script and use "*.sh" as file mask. This way you can place other .sh-files for other games in the same folder.


ricardo85x Wrote:Hi

Are there any limit on the number of roms we can have per system?

I have 8668 mame' roms, but it just list 4039
No. I guess there have been issues with scraping and/or importing the other games. Can you try to reimport some of these games and post a link to your log file?
find quote
trnzaddict Offline
Junior Member
Posts: 8
Joined: Mar 2014
Reputation: 0
Post: #4340
Malte, what is up with the text format the .nfo files use? I ask because I'm filling in a bunch of missing info using Wordpad that none of the scrapers are able to find on alot of games I have, and for instance I'll copy paste a description from wikipedia for a game, then when I try to save it in Wordpad it complains that the text format has changed. If I save it anyway, RCB won't show the new info in the description pane after reimporting.

Also, is there a text editor you can suggest that makes filling in the missing info alot easier? Like when an nfo file does not find anything it leaves open plot tags, genre tags, etc. like <plot />It's a pain to manually have to type correct tags like <plot></plot> as well.

Like I would like to just copy paste the info into the tag and then save it and it automatically closes the tags correctly.
find quote
FailBoatSailsOn Offline
Junior Member
Posts: 10
Joined: Sep 2014
Reputation: 0
Post: #4341
My library magically disappeared, which I'm sure isn't normal.

After receiving undesireable results with the online scrapers (missing artwork along with wrong and / or inaccurate descriptions), I decided to use a vanilla offline scraper (using the example file and parser supplied in the FAQs but with my own games of course).

Everything loaded and displayed just fine but in later sessions, they all vanished. I tried rescraping, it acknowledges that it found the games but they don't display. I tried using the Delete Games & Settings option followed by importing everything again - still no joy. Finally, I deleted the games and settings, then took it even further by uninstalling and reinstalling RCB followed by importing everything.... nothing.

Something glitched... hard. I'm all out of ideas, and the log files don't seem to hint at anything obvious either other than these possible highlights.

02:52:16 T:1692636120 DEBUG: Activating window ID: 10000
02:52:16 T:1692636120 DEBUG: ------ Window Deinit (/storage/sdcard0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/script.games.rom.collection.browser/resources/skins/Default/720p/script-Rom_Collection_Browser-main.xml) ------
02:52:16 T:1692636120 DEBUG: ------ Window Init (Home.xml) ------
02:52:16 T:1692636120 DEBUG: Window Home.xml was already loaded
02:52:16 T:1692636120 DEBUG: Alloc resources: 10.57m
02:52:16 T:1834732064 INFO: CPythonInvoker(10, /storage/sdcard0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/script.games.rom.collection.browser/default.py): script successfully run
02:52:16 T:1824493384 DEBUG: POParser: loaded 40 strings from file /storage/sdcard0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/weather.wunderground/resources/language/English/strings.po
02:52:16 T:1834732064 WARNING: CPythonInvoker(10, /storage/sdcard0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/script.games.rom.collection.browser/default.py): the python script "/storage/sdcard0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/script.games.rom.collection.browser/default.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon4xbmc8PlayListE
02:52:16 T:1834732064 INFO: Python script stopped
02:52:16 T:1834732064 DEBUG: Thread LanguageInvoker 1834732064 terminating

02:54:57 T:1692636120 ERROR: Control 52 in window 13000 has been asked to focus, but it can't

02:55:00 T:1833495120 ERROR: EXCEPTION: 'platforms' is an invalid Id
02:55:05 T:1692636120 DEBUG: ------ Window Init (/storage/sdcard0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/script.games.rom.collection.browser/resources/skins/Default/720p/script-RCB-editscraper.xml) ------
02:55:05 T:1692636120 INFO: Loading skin file: /storage/sdcard0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/script.games.rom.collection.browser/resources/skins/Default/720p/script-RCB-editscraper.xml, load type: LOAD_ON_GUI_INIT
02:55:05 T:1692636120 DEBUG: LocalizeStrings: no strings.po file exist at /storage/sdcard0/Android/data/org.xbmc.xbmc/files/.xbmc/addons/script.games.rom.collection.browser/resources/language/English, fallback to strings.xml
02:55:05 T:1692636120 DEBUG: Previous line repeats 26 times.

02:55:34 T:1692636120 ERROR: Control 50 in window 13000 has been asked to focus, but it can't

I'd hate to have to reinstall and reconfig ALL of XBMC just to get it working properly again (especially if the end result is still fail).

Platform information that may be of use:

RCB Version: 2.0.17
XBMC Version: 13.2 Gotham (ARM)
Sideloaded official apk on my OUYA (Makes for a good XBMC box)
Android Version: 4.1.2
Kernel Version: 3.1.10-g780994a

Other Useful infomation:

I noticed the glitch occured when going through the sample library (populated with only 2 games to ensure the parser and multi-game description files were in working order) and somehow while navigating, the selection went off-screen (which can be reproduced in even the PC version, although not the glitch itself) and being the natural bug tester that I am, decided to "click" on it and see what happens (expecting a crash or error), instead, everything vanished on the next session with no way to restore it - even after redoing everything from scratch.

http://xbmclogs.com/show.php?id=298572
(This post was last modified: Yesterday 18:13 by FailBoatSailsOn.)
find quote
ricardo85x Offline
Junior Member
Posts: 3
Joined: Sep 2014
Reputation: 0
Post: #4342
Hello there,

I did update the file MAME.txt to use info from mame 0.154
I did upload the file here:

https://drive.google.com/folderview?id=0...sp=sharing

it is for the offline game description on mame
find quote
Post Reply