[Linux] .mkv playback problems ACER R3160 Revo

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Matija Offline
Junior Member
Posts: 12
Joined: Jan 2009
Reputation: 0
Post: #1
Hey guys, here is a description of my problem, but first the info you need. Smile Take care, I'm quite new at linux so it's possible I did some mistakes.

# Computer: Acer Aspire R3160 Revo / 2 GB Ram / Intel Ion / connected to Philips LCD 5603D via HDMI cable

# Linux Distribution and Version - Ubuntu 9.10 desktop for 64 (Ubuntu 9.10, 2.6.31-20-generic x86_64)

# Architecture x86_64

# Install Method - Manual following guidelines on forum

# SVN Revision - couldn't find under confluence skin, if you can help me where to find it - I'll post it here

# Detailed Instructions to Reproduce the Problem:

- The first problem I encountered was huge frame loss and slow . mkv reproduction, both 720p/1080p, both over ethernet connection and wireless. This was fixed by finding a similar problem on forums and using the solution here http://forum.xbmc.org/showthread.php?p=473089 (apt-get install libvdpau1)

- the second problem I can't solve is that in the lower part of the screen, lets say the lower 1/5 (or 1/4) there is video jutter, screen tearing. I found a a solution here so I just did add-apt-repository ppa:team-xbmc-svn - update and install.
- Even though I got those new options, there is still a problem with jutter, screen tearing in the lower part. It looks like some frames there overlap for a second.

- I did try to edit my xorg.conf like noted here but that boots my ubuntu in low GFX mode.

# FULL Debug Log - debugg was enabled under Confluence skin - Sytem - Debugging - Enable Debug Logging - here is the copy paste of log http://pastebin.com/RPAKCMXv

If I can add anything else, let me know. Hope it helps!
(This post was last modified: 2010-03-19 01:02 by Matija.)
find quote
cbrunhaver Offline
Member
Posts: 81
Joined: Sep 2009
Reputation: 0
Post: #2
Sounds like you have done your homework but here are a couple of suggestions.

1. Don't run the 64 bit version of karmic, run the 32 bit. You done need to be able to address 4+ GB of ram in your ion box and the 64 bit version seems to be more bug prone.

2. Don't give us on working on your xorg.conf. The tearing is most likely due to compositing and so just try disabling compositing and leave the other stuff along for now.
find quote
Matija Offline
Junior Member
Posts: 12
Joined: Jan 2009
Reputation: 0
Post: #3
cbrunhaver Wrote:2. Don't give us on working on your xorg.conf. The tearing is most likely due to compositing and so just try disabling compositing and leave the other stuff along for now.

Would adding

Quote:Section "Extensions"
Option "Composite" "Disable"
EndSection

to it help?
find quote
cbrunhaver Offline
Member
Posts: 81
Joined: Sep 2009
Reputation: 0
Post: #4
oops. I meant don't give up, no don't give "us".

In any case, yes, you want to disable compositing by adding that to your xorg.conf.
find quote
Matija Offline
Junior Member
Posts: 12
Joined: Jan 2009
Reputation: 0
Post: #5
cbrunhaver Wrote:oops. I meant don't give up, no don't give "us".

In any case, yes, you want to disable compositing by adding that to your xorg.conf.

I've tried adding those few lines, however, that puts my Ubuntu into low gfx mode. Any ideas?

I'll try toying with it a bit, I think it could be a problem between display sync and xbmc, not sure.
find quote
d3fiant Offline
Junior Member
Posts: 35
Joined: Dec 2004
Reputation: 0
Post: #6
I have the r3610 with 2GB. I run x86 ubuntu karmic and an xbmc svn dated march 1st. I am running the 190.53 nvidia drivers and have the following xorg.conf. This works fine with some settings within XBMC which I will post in a bit. I do get a few seconds of green pixelation at the start of playing an mkv file but after that its fine, be it 720p or 1080p

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Tue Dec  8 21:04:28 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
    gamma 1.2 1.2 1.2
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option  "NoLogo"              "true"
    Option  "DynamicTwinView"     "false"
    Option  "NoFlip"               "true"
    Option  "FlatPanelProperties" "Scaling = Native"
    Option  "ModeValidation"      "NoVesaModes, NoXServerModes"
    Option  "ModeDebug"           "true"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Modes "1920x1080_60_0" "1920x1080_24_0"
    EndSubSection
EndSection

Section "Extensions"
        Option  "Composite"           "false"
EndSection

Acer Revo 3610 : 2GB RAM : 320GB HDD : Ubuntu 10.4.1 : XBMC dharma final : Sony Bavia 40" over HDMI
(This post was last modified: 2010-03-19 11:44 by d3fiant.)
find quote
SpaceMonkey Offline
Posting Freak
Posts: 1,162
Joined: Aug 2008
Reputation: 24
Location: Finland
Post: #7
try using this as a somewhat sane default

Code:
Section "Device"
        Identifier "nvidia"
        Driver  "nvidia"
        Option  "NoLogo"              "true"
        Option  "DynamicTwinView"     "false"
        Option  "NoFlip"              "false"
        Option  "FlatPanelProperties" "Scaling = Native"
EndSection

Section "Screen"
        Identifier      "screen"
        Device          "nvidia"
EndSection

Section "Extensions"
        Option  "Composite"           "disable"
EndSection

though, on my asrock ion i have to set noflip to true, otherwise i get tearing. also make sure opengl sync is turned on in nvidia settings.
find quote
Matija Offline
Junior Member
Posts: 12
Joined: Jan 2009
Reputation: 0
Post: #8
d3fiant Wrote:I have the r3610 with 2GB. I run x86 ubuntu karmic and an xbmc svn dated march 1st. I am running the 190.53 nvidia drivers and have the following xorg.conf. This works fine with some settings within XBMC which I will post in a bit. I do get a few seconds of green pixelation at the start of playing an mkv file but after that its fine, be it 720p or 1080p


Gonna give it a go since with this jutter, it's unplayable.
find quote