Linux - HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!

  Thread Rating:
  • 16 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
robo989 Online
Senior Member
Posts: 276
Joined: Apr 2010
Reputation: 6
Post: #976
Hi there, just seen 11.0-pvr build84 has been released yesterday for ubuntu, does that have the new audioengine in it?

Cheers Smile
(This post was last modified: 2012-06-12 10:06 by robo989.)
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,224
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #977
no, and I probably won't include it until it's stable and in frodo final

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
robo989 Online
Senior Member
Posts: 276
Joined: Apr 2010
Reputation: 6
Post: #978
Thanks for the confirmation Smile Much appreciated for the comment and of course all the work.
find quote
kosobrin Offline
Junior Member
Posts: 1
Joined: Jun 2012
Reputation: 0
Post: #979
Hello, I have problem with time schedule recording, I get an error: "ERROR: PVRClient - AddTimer - addon 'HTS Tvheadend:127.0.0.1:9982' returned an error: server error"
I have xbmc-prv eden from pulse eight and HTS Tvheadend 2.12

Can I somehow fix the error?
find quote
Begall Offline
Senior Member
Posts: 172
Joined: Dec 2011
Reputation: 6
Post: #980
Updated to the latest TVHeadend pulse eight build this morning via apt-get and there seems to be a serious problem. Seemed to be functional to begin with and I was able to log in to the web interface, but that stopped and I now get 'Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data' when attempting to access it. Additionally, I am unable to stream anything.

However, the service can be seen to be running in top (without any unusual CPU utilization) and when I restarted the service it runs the XMLTV grabber as per normal, but it does not solve the above issues.

Any ideas?
find quote
Pyromaniac Offline
Donor
Posts: 157
Joined: Mar 2012
Reputation: 1
Location: Germany
Post: #981
(2012-06-09 17:42)pszab Wrote:  Hi.
Which mpeg4 dvb-c tuners are recommened under linux for proper working?
I would prefer usb stick types.
Thanks

I've tested TechnoTrend CT-3600 (http://www.amazon.de/Technotrend-TT-conn...B0016LHOPG) it will work out of the box (on Ubuntu 12.04) but I have artifacts in the picture every 2-3 minutes.
Actually I am using the Terratec Cinergy HTC USB Stick (http://www.amazon.de/TerraTec-Cinergy-HT...961&sr=1-7), which won't run OOTB on Ubuntu 12.04, but following these instructions:
http://git.linuxtv.org/media_build.git
will do it for you.
On both I've tested only DVB-C, no analog or something else. Both can handle HD, it's just a matter if your CPU or GPU can handle HD.
find quote
Benoe Offline
Junior Member
Posts: 20
Joined: Oct 2011
Reputation: 0
Post: #982
Hi!

When I want to upgrade to the latest version, apt says, that I need to remove xbmc-live package.
Is it safe to do that?

I used the old xbmcbuntu method to install this htpc, it is based on 11.10.
find quote
basco Offline
Senior Member
Posts: 230
Joined: Jun 2010
Reputation: 1
Post: #983
the webinterface from the latest opdenkamp tvheadend does not work.
does anyone else have this?
(This post was last modified: 2012-06-27 20:57 by basco.)
find quote
Gnaddel Offline
Junior Member
Posts: 11
Joined: Oct 2010
Reputation: 0
Post: #984
Hi there,

I've run into some trouble following the guide on the current xbmcbuntu release.
Here is where I'm stuck:
Code:
gnaddel@gnaddel-htpc:~$ sudo apt-get -y install xbmc-live
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xbmc-live : Depends: xbmc (= 2:11.0-pvr+p8~git20120515.310d665-0ubuntu1~stable76~oneiric) but 2:11.0-pvr+pulse8~git20120627.d7c419c-0ubuntu1~build91~oneiric is to be installed
E: Unable to correct problems, you have held broken packages.

Seems to be a pretty straightforward problem with the repository, however I'm at a loss on how to fix it Wink
find quote
davy39 Offline
Junior Member
Posts: 38
Joined: Nov 2011
Reputation: 0
Post: #985
sudo apt-get -y install xbmc-standalone

?
find quote
Gnaddel Offline
Junior Member
Posts: 11
Joined: Oct 2010
Reputation: 0
Post: #986
Thank you davy, that did the trick. Everything is up an running now Smile
find quote
mr_blond18 Offline
Junior Member
Posts: 19
Joined: May 2009
Reputation: 0
Post: #987
(2012-06-27 10:43)Benoe Wrote:  Hi!

When I want to upgrade to the latest version, apt says, that I need to remove xbmc-live package.
Is it safe to do that?

I used the old xbmcbuntu method to install this htpc, it is based on 11.10.

I have the same problem... I am reluctant to remove xbmc-live, because I fear loosing autostart (and restart in case of crash) of XBMC. Anybody tackled thisConfused


-----UPDATE------
Nevermind. Took the bold move and updated anyway. Everything is working as desired. Turns out xbmc-live is not used for autostart. The graphical interface (lightdm) is autostarted at boot. In the graphical interface, XBMC is started during startup.
(This post was last modified: 2012-07-16 18:53 by mr_blond18.)
find quote
Begall Offline
Senior Member
Posts: 172
Joined: Dec 2011
Reputation: 6
Post: #988
I'm curious, how come the ability to use a TS stream over HTTP was removed? It seemed to be working well, much better than MKV streaming which is seriously glitchy in comparison.
find quote
kobid84 Offline
Junior Member
Posts: 6
Joined: Jul 2012
Reputation: 0
Post: #989
(2012-06-30 15:33)Gnaddel Wrote:  Thank you davy, that did the trick. Everything is up an running now Smile

hey
how did you solve it ? i can't start xbmc-live after the upgrade...
find quote
Balthazar Offline
Member
Posts: 97
Joined: Oct 2010
Reputation: 0
Location: Salina, KS
Post: #990
Having some trouble setting this up with my hdhomerun. Here is what I have so far (Ubuntu 12.04)

I have all of the software installed ( hdhomerun-config hdhomerun-config-gui dvbhdhomerun-dkms dvbhdhomerun-utils)
Script installed to start dvbhdhomerun-utils and tvheadend from this thread.
I can access the web interface at http://localhost:9981/extjs.html.
Output of hdhomerun_config discover returns "hdhomerun device 101899F3 found at 192.168.2.5"
/etc/hdhomerun config file is setup like this:

[101899F3-0]
tuner_type=ATSC

[101899F3-1]
tuner_type=ATSC

I think everything is correct, but when I go to the web interface to select my tuner the drop down menu is blank. Am I missing something?
find quote
Post Reply