VDR VNSI Deinterlacing

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Larry_Lobster Offline
Member
Posts: 96
Joined: Oct 2010
Reputation: 0
Post: #1
Hi everyone,

I use the xbmb pvr build of Lars op den Kamp: https://launchpad.net/~lars-opdenkamp/+archive/xbmc-pvr

I have a TechnoTrend CT-3650CT to watch dvb-c using VDR and VNSI Server. But I have a problem with deinterlacing. On fast camera moves I see some vertical stripes. How can I configure the deinterlacer. I just didn't find a xbmc option... or do I have to configure it in vdr?

Thanks for your help.

Kind regards
Larry_Lobster
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,209
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #2
if you have a card that supports vdpau: choose "(vdpau) temporal".

guess the best setting is "temporal" without vdpau if you don't have it, but haven't tested that.

edit:
set this by pressing "M" while playing a stream and go to video options. choose "set to default for all channels" before closing the dialog.

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
Larry_Lobster Offline
Member
Posts: 96
Joined: Oct 2010
Reputation: 0
Post: #3
Thanks for the 'm' hint. I found the menu...

I use vdpau, but i don't have a "(vdpau) temporal" option... there is only "temoral". Any ideas why?
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,209
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #4
see if system->settings->video has vdpau enabled (and perhaps disable vaapi)

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
Larry_Lobster Offline
Member
Posts: 96
Joined: Oct 2010
Reputation: 0
Post: #5
dushmaniac Wrote:see if system->settings->video has vdpau enabled (and perhaps disable vaapi)

This are my srttings and the info while watching tv. Disabling vaapi doesn't add an "(vdpau) te,poral" option, too.

[Image: video-preferences.png]
[Image: tv-info.png]
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,209
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #6
guess your video card doesn't support it

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
Larry_Lobster Offline
Member
Posts: 96
Joined: Oct 2010
Reputation: 0
Post: #7
dushmaniac Wrote:guess your video card doesn't support it

Hmm, it's a NVIDA ION II GT218 chipset... nothing special I think...
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,209
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #8
someone wrote a deinterlacer option for ION chipsets, but I'm not sure it's in the Dharma builds. do you see something like "ion optimised" in there?

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
Larry_Lobster Offline
Member
Posts: 96
Joined: Oct 2010
Reputation: 0
Post: #9
dushmaniac Wrote:someone wrote a deinterlacer option for ION chipsets, but I'm not sure it's in the Dharma builds. do you see something like "ion optimised" in there?

Yes, there is an "ion optimized" option. I'm going to try this one, thanks!
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,676
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #10
your screen shot shows that you have not synced playback to display. this enables smooth video and you get much better results. make sure you have enabled sync to vblank in nvidia settings.
you get the best deinterlacing quality when you leave the setting to 'auto'. this enables temporal/spatial + inverse telecine. the ION auto option just sets this back to temporal for HD content.
BTW: only the auto options honor progressive content and turn off deinterlacing.
(This post was last modified: 2011-02-04 14:42 by FernetMenta.)
find quote
steffen_b Offline
Member
Posts: 52
Joined: Dec 2009
Reputation: 0
Post: #11
auto (ion optimized) should be perfect for G210/ION2/ION.
find quote