Stutter / Frame skip ION330 / Dharma

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
TFHfony Offline
Member
Posts: 72
Joined: Mar 2009
Reputation: 1
Post: #1
I have installed the Dharma Live CD on my ION330 system, and most of it seems to be running quite fine, but I still have a files (mostly 1080p files) that keep stuttering. And the weird thing is... Sometimes they run files, but most of time well, the framerate jumps around from 10 - 50 fps...

Here is a pastebin of my log:

http://pastebin.com/6CqWavGY

The first 2 times, I ran a file from BBC Earth, which jumps around from 10 - 25 fps, looking like s**t... CPU usage is quite low, all cores show somewhere between 0 - 10%, so.. it's not a CPU issue.
The 3rd file I ran is a ZZ Top concert. Also 1080p, but that one runs perfectly. It seems to happen mostly with 24fps files.
I have tried all A/V sync methodes, including not syncing at all, but the problem remains.
Camelot didn't give me this problem, what ever framerate: it was rock-steady. But Dharma is keeping me puzzeled. I would consider going back to Camelot, if it weren't for the Win7 Live/SMB problems...

If anyone wants more information, please let me know what you need.
find quote
Smagyarown Offline
Junior Member
Posts: 38
Joined: Jul 2010
Reputation: 0
Post: #2
I don't know if this helps, but I kind of had the same issue when I upgraded. It turns out that the mp4 files I had that worked just fine in Camelot, were stuttery in Dharma. I just used Handbrake to convert them to m4v files (compatible for my Ipod) and they work just fine now.

It could be just a file format issue.
find quote
TFHfony Offline
Member
Posts: 72
Joined: Mar 2009
Reputation: 1
Post: #3
Smagyarown Wrote:I don't know if this helps, but I kind of had the same issue when I upgraded. It turns out that the mp4 files I had that worked just fine in Camelot, were stuttery in Dharma. I just used Handbrake to convert them to m4v files (compatible for my Ipod) and they work just fine now.

It could be just a file format issue.

Well, I have quite some files on my server. Converting all of them (which will also cause a loss in quality) would take a whole lot of time.
I'd rather prefer to have these files working as they should.
BTW, it's not a file-type issue. I have this issue with m2ts, but also MKV....

Thanks anyway for trying to help! Smile
find quote
TFHfony Offline
Member
Posts: 72
Joined: Mar 2009
Reputation: 1
Post: #4
Stuff gets weirder.. it seems that when I resume the file, the file will (sometimes?) play fine. Here is a log:

http://pastebin.com/q37mYh8S

The first time, I resumed the file: and it runs fine.
The 2nd time, I restarted the file at the beginning, and the framerate goes crazy...
The 3rd time, I resume again, and... guess what.. I runs fine.

And this error in the log, seems to be the a reference to the issue:

Quote:22:40:59 T:2861886320 M:3151970304 ERROR: Decode - avcodec_decode_video returned failure
22:44:53 T:3077490560 M:3036479488 ERROR: Previous line repeats 1089 times.
I see that one all the time in the parts of the log where the playback goed wrong...

Anyone any idea?
(This post was last modified: 2011-02-21 00:02 by TFHfony.)
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #5
Turn on debug logging and post another log please.
find quote
h.udo Offline
Fan
Posts: 574
Joined: Feb 2009
Reputation: 8
Post: #6
I have an Asrock 330 with Dharma installed and it can play BBC Earth perfectly. What nvidia drivers are you using?

**EDIT**
I took a look on your log. You are not using the latest Nvidia drivers. Check my signature.
(This post was last modified: 2011-02-21 01:37 by h.udo.)
find quote
TFHfony Offline
Member
Posts: 72
Joined: Mar 2009
Reputation: 1
Post: #7
hudo Wrote:I have an Asrock 330 with Dharma installed and it can play BBC Earth perfectly. What nvidia drivers are you using?

**EDIT**
I took a look on your log. You are not using the latest Nvidia drivers. Check my signature.

Well, I just updated the driver, but it didn't help at all. I more or less expected that aldready because:

* The files play fine on resume (as mentioned above)
* I'd expect the files on the live CD to work. Most people using the live CD wouldn't know how to upgrade these files

But, it was worth the try. Thanks for trying to help!

bobo1on1 Wrote:Turn on debug logging and post another log please.

Of course, no problem:

http://pastebin.com/cbdwwCU2

I did everything in as little steps as possible, to keep the log within a decent size. During the first run: The frame rate goes all over the place, the resume gave me a perfect framerate.

If you need me testing anything else, please don't hesitate to ask!
(This post was last modified: 2011-02-21 21:21 by TFHfony.)
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #8
Can you turn off adjust refreshrate to match video, see if that fixes anything.
What I'm seeing is the a/v sync code going crazy, is audio playback influenced in any way? Like dropouts etc.
find quote
X3lectric Offline
Closed Account
Posts: 1,756
Joined: Feb 2006
Location: in a Dropbox
Post: #9
https://launchpad.net/~team-iquik/+archive/nvidia-vpau

your welcome

Also would go GIT but would backup your hdd before just in case you rather go back. See my sig for the Linux compile needs.
find quote
TFHfony Offline
Member
Posts: 72
Joined: Mar 2009
Reputation: 1
Post: #10
bobo1on1 Wrote:Can you turn off adjust refreshrate to match video, see if that fixes anything.
What I'm seeing is the a/v sync code going crazy, is audio playback influenced in any way? Like dropouts etc.

Most of the time, the audio stays running as it should, but there are some dropouts once in a while.
I will turn off the "adjust refreshrate to match video" and post you a log of that. But if I recall correctly, it didn't solve the issue, but did make my videofiles judder a lot more, but I am not 100% sure.
I'll give it a go this evening and let you know the results.

X3lectric Wrote:https://launchpad.net/~team-iquik/+archive/nvidia-vpau

your welcome

Also would go GIT but would backup your hdd before just in case you rather go back. See my sig for the Linux compile needs.
Hmmm, nice.. There is a reason I installed the Live-CD -> I am not a Linux wizard. I was already quite happy I was able to update the nvidia drives and to check if there was an updated xbmc stable release available Smile
find quote
TFHfony Offline
Member
Posts: 72
Joined: Mar 2009
Reputation: 1
Post: #11
bobo1on1 Wrote:Can you turn off adjust refreshrate to match video, see if that fixes anything.
What I'm seeing is the a/v sync code going crazy, is audio playback influenced in any way? Like dropouts etc.

Well, I have done what you asked, but it didn't help I am afraid.

http://pastebin.com/mKbjSk4G

Again: The first run, it goes crazy. Just stopping the playback by hitting the stop button, re-select the file and resume: Presto: it runs perfectly.

The fact it runs smooth after resuming the file, would give me a few ideas:

1. It's not a driver issue: After resuming, all works fine.
2. There seems to be a difference on how starting a file is handled, compared to resuming a file.

As a complete programming noob, I'd say: change the code to insead of "starting at 00:00:00", to "resume at 00:00:00". But then again: I guess I'm probably saying something quite rediculous...

Anyway: If you need me to try something else or to install something to do some testing: please do not hesitate to ask!
(This post was last modified: 2011-02-23 23:03 by TFHfony.)
find quote
deppan Offline
Member
Posts: 59
Joined: Jan 2011
Reputation: 0
Post: #12
I have a similar issue (maybe the same) and noted that when a playback starts stuttering, it will keep doing so until ff'ed/stop-resumed. Try to provocate a frame skip when the playback is fine by loading the box with something else, and see if it starts stuttering again. Would be interesting to know Smile
find quote
TFHfony Offline
Member
Posts: 72
Joined: Mar 2009
Reputation: 1
Post: #13
deppan Wrote:I have a similar issue (maybe the same) and noted that when a playback starts stuttering, it will keep doing so until ff'ed/stop-resumed. Try to provocate a frame skip when the playback is fine by loading the box with something else, and see if it starts stuttering again. Would be interesting to know Smile

The box has the live-CD installed... So I have no clue on how to accomplish that in an easy way...
find quote
deppan Offline
Member
Posts: 59
Joined: Jan 2011
Reputation: 0
Post: #14
TFHfony Wrote:The box has the live-CD installed... So I have no clue on how to accomplish that in an easy way...
bringing up the osd should suffice i think
find quote
TFHfony Offline
Member
Posts: 72
Joined: Mar 2009
Reputation: 1
Post: #15
deppan Wrote:bringing up the osd should suffice i think

Well, that won't help I guess: I bring up the codec info every time which is indeed good for giving a small hickup on HD material. It doesn't give any difference in both situations: If the FPS is going crazy, it will continue doing so. If the FPS is OK, it will stable, except for a small moment when the OSD comes up.
find quote
Post Reply