AppleTV 2 (black) - iOS 5.1 & XBMC

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
misa Offline
Senior Member
Posts: 103
Joined: Mar 2012
Reputation: 2
Post: #106
(2012-04-02 13:30)shamsudin Wrote:  does xbmc work atv2 5.0 jailbroken, if it does, can anyone help with a link or instruction please, i would really appreciate

It's working great when you follow:

http://forum.xbmc.org/showthread.php?tid=127369

and take a look at:

http://www.youtube.com/watch?feature=pla...U-vr3amAo4


When you follow these steps.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,827
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #107
Guys are my instructions wrong or what? I don't get your errors. The first instruction "apt-get update" and the third instruction "apt-get install org.xbmc.xbmc-atv2" should take care off all that dependency problems you post here.

Did you do these? Did they work without error? Or are you just skipping my instructions and go straight forward to the "dpkg -i" part (that would indeed give these errors you post).

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
PanMan79 Offline
Member
Posts: 60
Joined: Jun 2011
Reputation: 0
Location: Gothenburg
Post: #108
(2012-04-02 13:40)Memphiz Wrote:  Guys are my instructions wrong or what? I don't get your errors. The first instruction "apt-get update" and the third instruction "apt-get install org.xbmc.xbmc-atv2" should take care off all that dependency problems you post here.

Did you do these? Did they work without error? Or are you just skipping my instructions and go straight forward to the "dpkg -i" part (that would indeed give these errors you post).

I will try it out tonight (live in sweden) and i will feedback to you.
You are awesome.
LOVE XBMC
find quote
misa Offline
Senior Member
Posts: 103
Joined: Mar 2012
Reputation: 2
Post: #109
(2012-04-02 13:40)Memphiz Wrote:  Guys are my instructions wrong or what? I don't get your errors. The first instruction "apt-get update" and the third instruction "apt-get install org.xbmc.xbmc-atv2" should take care off all that dependency problems you post here.

Did you do these? Did they work without error? Or are you just skipping my instructions and go straight forward to the "dpkg -i" part (that would indeed give these errors you post).


Instructions are good. I didn't had any problems.
find quote
NewFolk Offline
Junior Member
Posts: 32
Joined: Jan 2011
Reputation: 0
Post: #110
1)I restored aTV
2)JB
3) install aTV Flash
3) XBMC successfully installed
find quote
4akss Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #111
(2012-04-02 13:40)Memphiz Wrote:  Guys are my instructions wrong or what? I don't get your errors. The first instruction "apt-get update" and the third instruction "apt-get install org.xbmc.xbmc-atv2" should take care off all that dependency problems you post here.

Did you do these? Did they work without error? Or are you just skipping my instructions and go straight forward to the "dpkg -i" part (that would indeed give these errors you post).
on this step ---dpkg -i org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb---- terminal stucks on the line ----Unpacking replacement org.xbmc.xbmc-atv2----- then it writes down

dpkg: dependency problems prevent configuration of org.xbmc.xbmc-atv2:
org.xbmc.xbmc-atv2 depends on org.xbmc.xbmc-seatbeltunlock; however:
Package org.xbmc.xbmc-seatbeltunlock is not installed.
dpkg: error processing org.xbmc.xbmc-atv2 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
org.xbmc.xbmc-atv2

I have tried to copy paste the whole code also I tried to paste each line in terminal in order to identify where the problem is. Have never installed xbmc before.
find quote
XBMCOWNER Offline
Junior Member
Posts: 20
Joined: Mar 2012
Reputation: 0
Post: #112
(2012-04-02 14:16)4akss Wrote:  
(2012-04-02 13:40)Memphiz Wrote:  Guys are my instructions wrong or what? I don't get your errors. The first instruction "apt-get update" and the third instruction "apt-get install org.xbmc.xbmc-atv2" should take care off all that dependency problems you post here.

Did you do these? Did they work without error? Or are you just skipping my instructions and go straight forward to the "dpkg -i" part (that would indeed give these errors you post).
on this step ---dpkg -i org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb---- terminal stucks on the line ----Unpacking replacement org.xbmc.xbmc-atv2----- then it writes down

dpkg: dependency problems prevent configuration of org.xbmc.xbmc-atv2:
org.xbmc.xbmc-atv2 depends on org.xbmc.xbmc-seatbeltunlock; however:
Package org.xbmc.xbmc-seatbeltunlock is not installed.
dpkg: error processing org.xbmc.xbmc-atv2 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
org.xbmc.xbmc-atv2

I have tried to copy paste the whole code also I tried to paste each line in terminal in order to identify where the problem is. Have never installed xbmc before.

Hi what terminal program are you using, use PUTTY works first time

http://www.speak2siri.com/

Google API server for £1 thats for use for as long as you want it 99% uptime only down for updates all cash goes to upkeep of the server ie pc on 24/7 an to pay the server bil
find quote
waspish Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #113
I've done it now cheers everyone
find quote
happyendin21 Offline
Junior Member
Posts: 16
Joined: Jun 2010
Reputation: 0
Post: #114
Quote:I think its unrelated to this ios5.1 thing i fixed here (ios5.1 compatibility is more about how XBMC appears on the screen - 90degree rotated or not Big Grin).

Feel free to open a new thread with all needed info (xbmc.log, syslog, crashreporter log and mediainfo - first link in my signature will tell you how to get those).

I guess you started with XBMC on iOS5.1 directly did you? So its not that you've tested these movies with older iOS versions and only the iOS5.1 version crashes right?

Beside that - did you undo these changes to the guisettings.xml you did? Thats important i think to be sure that take3 fixed it and not your changes to the guisettings.xml Wink

Thanks again for your replies. I should have clarified that I have just recently purchased my atv2 and this is my first time running xbmc from it. on ios 5.1. I have run xbmc on several other devices and never had any problems like this. Thie screen is positioned perfectly though, and I thank you kindly for the work you did to port this to ios 5.1 so quickly. I will open up a new thread with my log files and see what happens.

As far as the directions I had no problems at all using PuTTy. (well done)

As far as the guisettings.xml I was never one to try altering these settings. so no worries there. Again I can't tell you how thankful I am for the work you all have done to make this work. I will be sending some dollars your way.
(This post was last modified: 2012-04-02 16:43 by Memphiz.)
find quote
deanmv Offline
Posting Freak
Posts: 877
Joined: Jun 2011
Reputation: 10
Location: UK
Post: #115
(2012-04-02 14:16)4akss Wrote:  
(2012-04-02 13:40)Memphiz Wrote:  Guys are my instructions wrong or what? I don't get your errors. The first instruction "apt-get update" and the third instruction "apt-get install org.xbmc.xbmc-atv2" should take care off all that dependency problems you post here.

Did you do these? Did they work without error? Or are you just skipping my instructions and go straight forward to the "dpkg -i" part (that would indeed give these errors you post).
on this step ---dpkg -i org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb---- terminal stucks on the line ----Unpacking replacement org.xbmc.xbmc-atv2----- then it writes down

dpkg: dependency problems prevent configuration of org.xbmc.xbmc-atv2:
org.xbmc.xbmc-atv2 depends on org.xbmc.xbmc-seatbeltunlock; however:
Package org.xbmc.xbmc-seatbeltunlock is not installed.
dpkg: error processing org.xbmc.xbmc-atv2 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
org.xbmc.xbmc-atv2

I have tried to copy paste the whole code also I tried to paste each line in terminal in order to identify where the problem is. Have never installed xbmc before.

You didn't answer and of the questions there. You need to each line one at time in order and if ANY line fails then it will have a knock on effect for the rest of them. Most of the time if you read the output it makes sense as to what has gone wrong. Just make sure you do it in order and one line at a time making sure eatch line before hand has completed successfully.

Set Up
Raspberry Pi running Raspbmc - XBMC 12.2
40" Samsung ES6800 LED Smart 3D 1080P TV
Onkyo HTS3405 5.1 DD True HD and DTS-HD Surround Sound
ReadyNAS Duo with 4TB (2 x 2TB X-RAID) Western Digital Caviar Green using NFS
find quote
realjobe Offline
Posting Freak
Posts: 1,022
Joined: Sep 2004
Reputation: 0
Post: #116
Hi there.
Eden works quite good on ATV2 5.0 (4099) teathered jailbreak with Seas0npass.
"ATV2-Eden-iOS5.1 compatible take3" worked great. Menu browsing twitches a bit but it does matter.
SMB shares (sources.xml) needed to be edit on PC and then fileZilla'd to correct place.

Pictures thumbnails were created quick and browsing was fast.
DVD .iso movies had no problem to play, navigation with the ATV Remote was bit confusing..
Blueray .iso movies (pure) also played astonising good, despite small buffering issues and slite performace issues..

EXCELENT WORK!
.)
find quote
Cactus Jack Offline
Junior Member
Posts: 6
Joined: Mar 2012
Reputation: 0
Post: #117
Everything installed smooth, I am wondering if users are missing steps?

It's easy to do when you are copying and pasting
find quote
bbdor Offline
Junior Member
Posts: 11
Joined: Feb 2011
Reputation: 0
Post: #118
Installed and running!!
find quote
Falo Offline
Junior Member
Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #119
Installed and running perfectly!

For everyone who needs an step by step tutorial, use the link below.

http://www.appletvhacks.net/2012/04/02/x...-tutorial/

ThanX for all the hard work Blush

Falo
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 10,827
Joined: Feb 2011
Reputation: 113
Location: germany
Post: #120
(2012-04-03 10:21)Falo Wrote:  Installed and running perfectly!

For everyone who needs an step by step tutorial, use the link below.

http://www.appletvhacks.net/2012/04/02/x...-tutorial/

ThanX for all the hard work Blush

Falo

Since take3 there are no "non-working" reports anymore (and there shouldn't be any). So you can scratch that from your tutorial...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Post Reply