Windows - [SOLVED] DXVA 2 and flashing video

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Vimes Offline
Member
Posts: 78
Joined: Feb 2009
Reputation: 2
Post: #1
Hello

I am using the final build of Eden on Windows 7x64 SP1. My other hardware is as follows...

E8400
4GB of DDR2
Gigabyte P35c DS3R
on board Realtek 889 sound. Drivers R 2.68
Asus GT 430 1GB GPU

Latest WHQL drivers applied version 296.10

If I run with using DXVA and do not use the DXVA2 option then all is well when I play my x264 content.
However if I then use Auto for the renderer and tick the DXVA2 box then I get a video which flashes continually brighter every second or so. The flashing isn't over the entire video. For example watching a Victorian film encoded in x264 there are candles in a darkened room and where the candles emit light the light from them is flashing brighter and dimmer. Any "highlighted" aspect of the film will flash.

when I run the DXVA checker I find...

[Image: 1333373279.png]

...so all should be well there.

It seems very difficult to capture this as a screenshot but here is the info displayed when I select that option...

[Image: 1333344264.png]


So if I use DXVA all is well but using DXVA2 and I get "high tones" of the depicted scene flashing brighter on and off.

Any ideas please, apart from just use DXVA...?

The strange thing is if I enable debugging then it does not do it and the video is perfect. I turn off debugging and it remains perfect until XBMC is closed down and restarted again.
(This post was last modified: 2012-04-02 15:54 by DDDamian.)
find quote
bluray Offline
Posting Freak
Posts: 8,315
Joined: May 2011
Reputation: 145
Post: #2
Try the settings as shown in my screen shots below-

[Image: zwkhlt.jpg]
[Image: 33pc6lw.jpg]

I saw the video flashes in one of my HTPC, but with the settings above it stop flashing....

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
Vimes Offline
Member
Posts: 78
Joined: Feb 2009
Reputation: 2
Post: #3
Thanks for putting the effort in what you have done, it is most appreciated Smile

I applied those settings but alas I will still get the flashing on what I will call the high tones of a video.

Using the Debeg mode and it stops and using DXVA and not DXVA2 and it stops.

Strange but maybe I will have to live with what it is rather than resolve it.

Thanks very much again Smile
find quote
vicmanpergar Offline
Fan
Posts: 418
Joined: Aug 2011
Reputation: 3
Post: #4
Something similar happened to me in the past, and finally i could solve it without deactivating the DXVA2. Could be the same, so u should give it a try and check this in the Nvidia control panel.
Check that u don't have the video set to the Nvidia configuration, but to the player configuration. I was ages trying to solve this issue till i finally changed all these sets to Player Configuration and the strange colors and flicks went away. May be it could work for u as well.
find quote
Vimes Offline
Member
Posts: 78
Joined: Feb 2009
Reputation: 2
Post: #5
Thanks for that. I will have a look there and check it out. I will post my findings back Smile

That resolved the issue....

[Image: 1333454036.png]


you can see that I needed to change my settings to what I have noted above. Prior to that it was set using the NVidia ones and hence the flashing.

Now it does not flash at all.

Thanks for your help Smile
(This post was last modified: 2012-04-02 13:40 by Vimes.)
find quote
HenryFord Offline
Posting Freak
Posts: 1,271
Joined: Jan 2010
Reputation: 19
Post: #6
Dude... thanks. So much thanks.
I always though that it was an issue with my TV (the flashing that is), never ever thought that it would be a problem with my video-card being misconfigured Big Grin
I have to say - I never investigated this very much, just lived with it up until now - saw your post and I did the most obvious thing:
I just turned on my monitor while playing back video - and well... the flickering was also occuring on my monitor which ruled out my TV as the source of the flickering (although I could have been a little bit smarter in finding this out earlier: My Games never had those issues...).
Thanks to your investigation, I can now watch without any flickering whatsoever. Thank you SO MUCH.
+rep for you!

Need help? Check out my XBMC Frodo Guide. It contains full featured guides to Sickbeard and CouchPotato as well.

[Image: all-fanart.jpg]
(This post was last modified: 2012-04-02 14:19 by HenryFord.)
find quote
Vimes Offline
Member
Posts: 78
Joined: Feb 2009
Reputation: 2
Post: #7
You are most welcome.

I popped back to change it to "solved" but that had already been applied.

Hopefully this information might help others with the same problem.
find quote
vicmanpergar Offline
Fan
Posts: 418
Joined: Aug 2011
Reputation: 3
Post: #8
Yeah i thought the same i typed it in some forums back some months ago, cos it was really hard for me to find the solution. I am glad it solved 100% for both of u.

P.s. : Games are not affected cos this settings are only applied to Videos.
(This post was last modified: 2012-04-02 19:36 by vicmanpergar.)
find quote
HenryFord Offline
Posting Freak
Posts: 1,271
Joined: Jan 2010
Reputation: 19
Post: #9
Yes - hence my comment "My Games never had those issues" Wink

For anyone experiencing similiar issues on ATI cards by the way:
Disable the menu-item "Dynamic Contrast" in the Video-Configuration of the CCC - that solved it on my other box as well.

Need help? Check out my XBMC Frodo Guide. It contains full featured guides to Sickbeard and CouchPotato as well.

[Image: all-fanart.jpg]
find quote
Recharge Offline
Junior Member
Posts: 2
Joined: Apr 2012
Reputation: 0
Post: #10
Hi.

Sorry to reopen an solved thred but i have the same problem. Im on a Zotac AD04 with 6320 radeon and with updated grafik drivers. I have turned everything off in vision engine including dynamic contrast but the problem still exists.

The thing is that the video playes fine in vlc. So what am i doing wrong??


Log:

19:47:22 T:1756 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
19:47:22 T:1400 NOTICE: Creating InputStream
19:47:22 T:1400 NOTICE: Creating Demuxer
19:47:23 T:1400 NOTICE: Opening video stream: 0 source: 256
19:47:23 T:1400 NOTICE: Creating video codec with codec id: 28
19:47:23 T:1400 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
19:47:23 T:1400 NOTICE: Creating video thread
19:47:23 T:1400 NOTICE: Opening audio stream: 1 source: 256
19:47:23 T:1400 NOTICE: Finding audio codec for: 86019/-99
19:47:23 T:1400 NOTICE: Creating audio thread
19:47:23 T:1292 NOTICE: running thread: CDVDPlayerAudio::Process()
19:47:23 T:1292 NOTICE: Creating audio device with codec id: 86019, channels: 6, sample rate: 48000, pass-through
19:47:23 T:1908 NOTICE: running thread: video_thread
19:47:23 T:1908 NOTICE: fps: 25.000000, pwidth: 1280, pheight: 544, dwidth: 1280, dheight: 544
19:47:23 T:1908 NOTICE: Display resolution ADJUST : 1920x1080 @ 50.00 - Full Screen (159) (weight: 0.000)
19:47:23 T:1908 NOTICE: D3D: rendering method forced to DXVA2 processor
19:48:26 T:1756 NOTICE: CDVDPlayer::CloseFile()
19:48:26 T:1756 NOTICE: DVDPlayer: waiting for threads to exit
19:48:26 T:1400 NOTICE: CDVDPlayer::OnExit()
19:48:26 T:1400 NOTICE: DVDPlayer: closing audio stream
19:48:26 T:1400 NOTICE: Closing audio stream
19:48:26 T:1400 NOTICE: Waiting for audio thread to exit
19:48:26 T:1292 NOTICE: thread end: CDVDPlayerAudio::OnExit()
19:48:26 T:1400 NOTICE: Closing audio device
19:48:26 T:1400 NOTICE: Deleting audio codec
19:48:26 T:1400 NOTICE: DVDPlayer: closing video stream
19:48:26 T:1400 NOTICE: Closing video stream
19:48:26 T:1400 NOTICE: waiting for video thread to exit
19:48:26 T:1908 NOTICE: thread end: video_thread
19:48:26 T:1400 NOTICE: deleting video codec
19:48:26 T:1400 NOTICE: CDVDPlayer::OnExit() deleting demuxer
19:48:26 T:1400 NOTICE: CDVDPlayer::OnExit() deleting input stream
19:48:26 T:1756 NOTICE: DVDPlayer: finished waiting
19:48:28 T:1756 NOTICE: CDVDPlayer::CloseFile()
19:48:28 T:1756 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
19:48:28 T:1756 NOTICE: DVDPlayer: waiting for threads to exit
19:48:28 T:1756 NOTICE: DVDPlayer: finished waiting


"Edit"

Fixed it! I had disabled CCC in the background cuse it minimized xbmc but when i leave it running the flicker is gone.
(This post was last modified: 2012-04-28 07:56 by Recharge.)
find quote
adskee Offline
Junior Member
Posts: 24
Joined: Mar 2011
Reputation: 0
Post: #11
Can anyone assist with this issue? I am having the same problem as detailed in this thread. I am running Eden on Windows 7 on an Acer Asipre Revo 3700 with NVIDIA graphics.

The flickering has been driving me crazy. I have checked my NVIDIA settings and both options are set to us the player configuration. When I try using DXVA without DXVA2 as described in the first post, I still get flickering. No combination of settings seem to work.

The only thing that solves the problem is enabling debugging, but then I have the text at the top of the screen. Is anyone else having this issue or does anyone know of any other settings I could try?
find quote
adskee Offline
Junior Member
Posts: 24
Joined: Mar 2011
Reputation: 0
Post: #12
I've done some more research and tried every combination. The brightness is still changing as if Dynamic Contrast is enable in NVIDIA, but whether I enable, disable, use the video player or the NVIDIA card, the flickering is still there.

Does anyone know why enabling debugging would be the only way to fix this issue and is there any way to enable debugging and get rid of the text on the screen? At least this would be a workaround.
find quote