VNSI versions and compatibility

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
FernetMenta Offline
Team-XBMC Developer
Posts: 2,689
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #1
Gotham versions:
XBMC: 13.0
PVR API to XBMC: 1.9.0
VNSI Addon: 1.9.8
VNSI protocol between addon and vdr-plugin: 5
vnsi vdr-plugin: 1.0.0 (https://github.com/FernetMenta/vdr-plugin-vnsiserver)

________________________________________________________________________________​_____

XBMC 12.0 (Frodo) was just released. It is the first version of XBMC which has official support for PVR. The PVR client addons, the part which loads into XBMC are not part of XBMC and may be distributed as separate packages.
The vnsi plugin for VDR is distributed separately as well. The sources frozen with Fordo can be found here:
https://github.com/opdenkamp/xbmc-pvr-addons/tree/frodo

Frodo versions:
XBMC: 12.0
PVR API to XBMC: 1.6.0 (see: http://forum.xbmc.org/showthread.php?tid=97764)
VNSI Addon: 1.6.3
VNSI protocol between addon and vdr-plugin: 3
vnsi vdr-plugin: 0.9.0

XBMC: 12.1
PVR API to XBMC: 1.6.0
VNSI Addon: 1.6.4
VNSI protocol between addon and vdr-plugin: 3
vnsi vdr-plugin: 0.9.1
This version is in opdenkamp repo, branch frodo. To be loaded by vdr with vnsiserver3.

Development continues. Regarding VNSI there are a lot of features like timeshift and OSD in the pipeline which require API/protocol changes. I will announce changes in this thread.

From a compatibility perspective the APIs and communications protocols are most important. XBMC's plugin concept will take care for compatibility of the PVR client addons. Those are meant to be distributed via repositories which can be accessed directly by XBMC. Online updates will work this way. This is not in place yet.
Be careful:
This mechanism does not prevent from loading too new addons into XBMC. Do not use upcoming development versions of the PVR addons with XBMC 12.0.

The vdr plugin:
For more transparency future versions of the plugin will be suffixed by the protocol version, i.e. vnsiserver3. I have already completely re-written the plugin but due to this big change this version is not in the frozen Frodo branch. It will be available in opdenkamp master branch soon. I will announce the Git SHA you can use to check out this version (git checkout <sha>). This will be the last version of the plugin using protocol 3 and consequently named vnsiserver3. It's the last compatible with Frodo.
(This post was last modified: 2014-03-19 21:45 by FernetMenta.)
find quote
asshep Offline
Member
Posts: 65
Joined: Mar 2009
Reputation: 0
Post: #2
I would like to use your Repository ( is more up-to-date ?)
In the Past I do

# git clone https://github.com/FernetMenta/xbmc.git git-$date_ext
# cd git-$date_ext
# git clone https://github.com/FernetMenta/xbmc-pvr-addons.git pvr-addons

This is still OK after Frodo Release ?

Server OpenSuSE 12.1 - vdr-2.0.1 - 2xSatelco EasyWatch-C - streamdev-server git-31.03.2013 - vnsi4-01.05.2013
Client OpenSuSE 12.1 - vdr-2.0.1 - SoftHDDevice git-01.05.2013 - XBMC + vnsi4 git-01.05.2013 - Nvidea GT 610 / 313.30
Client Zbox ID84 OpenSuse 12.2 - vdr-2.0.1 - SoftHDDevice git-01.05.2013 - XBMC + vnsi4 git-01.05.2013 - Nvidea 313.30
find quote
charlie0440 Offline
Fan
Posts: 385
Joined: Dec 2011
Reputation: 5
Post: #3
@asshep, I believe FernetMenta is testing the different features in different branches eg OSD (for the VDR OSD), timeshiffting for timeshiffing etc etc

You will need to clone the specify branch you want to test ie

git clone --branch osd https://github.com/FernetMenta/xbmc.git
git clone --branch osd https://github.com/FernetMenta/xbmc-pvr-addons.git

Someone correct me if I am wrong

Guide to building an all in one Ubuntu Server - TV(vdr),File,Music,Web

Server Fractal Designs Define XL, Asus P5QL/EPU, Dual Core E5200, 4gb, L4M-Twin S2 v6.2, Supermicro AOC-USAS-L8I, 1*SSD & 13*HDD drives (24TB total) - Ubuntu Server
XBMC 1 ASRock Z77E-ITX, G850, 8GB RAM, SSD, BD - Ubuntu / OpenElec frodo
XBMC 2 Revo 3700 - OpenElec frodo
XBMC 3 Raspb Pi
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,689
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #4
Be careful, my master branch of my pvr-addons repo is not maintained. I have various staging branches for submitting changes to opdenkamp. As charlie0440 noted correctly bleeding edge is my osd branches but all 3 components are needed from those branches. Once the changes to XBMC's gui api have been merged into mainline, those branches will be removed.
find quote
asshep Offline
Member
Posts: 65
Joined: Mar 2009
Reputation: 0
Post: #5
OK, so what Repository should I use to stay close to development ? (as I did in the past )

# git clone git://github.com/xbmc/xbmc.git "git-"$date_ext
# cd "git-"$date_ext
# git clone git://github.com/opdenkamp/xbmc-pvr-addons.git pvr-addons

Server OpenSuSE 12.1 - vdr-2.0.1 - 2xSatelco EasyWatch-C - streamdev-server git-31.03.2013 - vnsi4-01.05.2013
Client OpenSuSE 12.1 - vdr-2.0.1 - SoftHDDevice git-01.05.2013 - XBMC + vnsi4 git-01.05.2013 - Nvidea GT 610 / 313.30
Client Zbox ID84 OpenSuse 12.2 - vdr-2.0.1 - SoftHDDevice git-01.05.2013 - XBMC + vnsi4 git-01.05.2013 - Nvidea 313.30
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,689
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #6
with this change: https://github.com/opdenkamp/xbmc-pvr-addons/pull/151
vnsiserver was renamed to vnsiserver3

Consider this for loading the plugin.
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,689
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #7
PVR API change!

Don't use opdenkamp master with XBMC 12.
find quote
foxy82 Offline
Junior Member
Posts: 18
Joined: Nov 2012
Reputation: 0
Post: #8
Hi,

If I'm using XBMC 12.2 and vnsiserver4 version 0.9.2 what version of the XBMC plugin do I need?
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,689
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #9
There's no official support for vnsi4 and Frodo (12.2). vnsi4 + vnsiserver4 are in opdenkamp master which is Gotham version.
You have to compile the vnsi addon from this branch: https://github.com/FernetMenta/xbmc-pvr-...tree/frodo
find quote
martin.haager Offline
Junior Member
Posts: 20
Joined: Jan 2013
Reputation: 0
Location: Vienna
Post: #10
hello

I also use XBMC 12.2 stable and vnsiserver4 version 0.9.2 / yavdr-testing..
and try to compile pvr-vnsi-plugin v4 for atv2, osx maveriks, and linux 12.04
have my issues compiling . but before i dig deeper. i just want to make sure if the git in the last post is still the right one.. kind of got mixed up with all the different versions and branches... short note would be perfect... or ist there a place where i can download the v4 plugin corresponding to the above os's and xbmc 12.2

thanks in advance for every information provided

martin

yavdr 2.0.4 testing / TBS 6991 dvbs-2 - Twin Tuner plus CI / vdr-plugin-vnsiserver 1.0 - FernetMenta / Ubuntu 12.04 LTS
RasPi / openelec 3.95.6 XBMC 13.0-Beta4 19.04.2014 with shipped vdr addon 1.9.6, Skin Amber 1.6.0
MacBook Pro OSX 10.9 / XBMC 13.0-Beta4 18.04.2014 with shipped vdr addon 1.9.7, Skin Amber 1.6.0
MySQL MediaDB
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,689
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #11
vnsi4 is not really supported with 12.2. I have not looked at this branch for quite a while. You should consider moving to XBMC 13, 12.2 has never been a good release, in particular for PVR.
find quote
martin.haager Offline
Junior Member
Posts: 20
Joined: Jan 2013
Reputation: 0
Location: Vienna
Post: #12
yep !!

this was the basic intention.... upgrading to gotham.
especially for the timeshift feature, and the ability to set buffering for media on local shares (afp shares in my case)

already installed the november monthly on my macbook pro, which seams to be working ok at a first glance
therefore upgraded my vdr-vnsiserver to version4 (0.9.2)

Next I decided upgrading my ATV2 (TV living room client ---- reeeeaaaaly important :-) but ran into pretty big performance issues
100 % CPU on almost all SD LiveTV Channels
Was around 80% to 90% using Frodo, (excapt ORF1 / ORF2 (SD) --> around 98% to 100% CPU)

we're talking about playing vdr .ts files (live tv, and recorded) -- mp4 works ok

So I blamed the monthly Gotham, went back to 12.2 and thought of compiling vnsi-plugin v4 for the ATV2 and give this setting a test

Hmmmmm.....

Kind of stuck now ...
Guess Im going back to vnsi3 / xbmc 12.2 for all my Clients, till Gotham Stable comes out, an give it another try..


or do you think the performance issue is general related to Gotham
will this be better in the stable version, or is simply to early to fiddle around with the alphas

I mean, if Gotham / vnsi consumes more CPU in general than I have to think about new hardware anyways
RasPi or whatever..

We'll see,

Any thoughts appreciated

Regards
Martin

(2013-12-07 14:10)FernetMenta Wrote:  vnsi4 is not really supported with 12.2. I have not looked at this branch for quite a while. You should consider moving to XBMC 13, 12.2 has never been a good release, in particular for PVR.

What you mean with never been a good release, and what alternative would you suggest, if Gotham is still to early to switch to ....
Realy want to stick to vdr-server / xbmc-client.. just works perfect,

But probably there other Ideas around.

BTW....
thanks for all the great work, you guys doing

Cheerio
M

yavdr 2.0.4 testing / TBS 6991 dvbs-2 - Twin Tuner plus CI / vdr-plugin-vnsiserver 1.0 - FernetMenta / Ubuntu 12.04 LTS
RasPi / openelec 3.95.6 XBMC 13.0-Beta4 19.04.2014 with shipped vdr addon 1.9.6, Skin Amber 1.6.0
MacBook Pro OSX 10.9 / XBMC 13.0-Beta4 18.04.2014 with shipped vdr addon 1.9.7, Skin Amber 1.6.0
MySQL MediaDB
(This post was last modified: 2013-12-07 21:28 by martin.haager.)
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 2,689
Joined: Jul 2010
Reputation: 55
Location: Munich
Post: #13
hmm, not sure if this will improve for atv2. It does not support mpeg2 hw decoding and is not really an attractive platform for users and devs. If you compare it to Raspberry Pi you don't see many pros on ATV side.
find quote
martin.haager Offline
Junior Member
Posts: 20
Joined: Jan 2013
Reputation: 0
Location: Vienna
Post: #14
OK....
So much for that !!!!!

Changed Hardware to Raspberry PI !!
Running XBMC Gotham Nightly 09122013 on USB Stick.

LiveTV via VDR VNSI Protocol 4, works perfect,
CPU arround 40%
Channelswitchtimes OK

No luck with Timeshift and EPG sofar, but guess I will find out what's wrong.

Thanks for your support

Martin

yavdr 2.0.4 testing / TBS 6991 dvbs-2 - Twin Tuner plus CI / vdr-plugin-vnsiserver 1.0 - FernetMenta / Ubuntu 12.04 LTS
RasPi / openelec 3.95.6 XBMC 13.0-Beta4 19.04.2014 with shipped vdr addon 1.9.6, Skin Amber 1.6.0
MacBook Pro OSX 10.9 / XBMC 13.0-Beta4 18.04.2014 with shipped vdr addon 1.9.7, Skin Amber 1.6.0
MySQL MediaDB
find quote
uuzi Offline
Junior Member
Posts: 23
Joined: Dec 2010
Reputation: 0
Location: Germany
Post: #15
Hello there,

for the life of me i can't get vnsi output to xbmc to work. my system runs exactly like described in fritsch's superb Radeon OSS tutorial.

i've tried several combinations of precompiled packages of vdr-plugin-vnsiserver and xbmc-pvr-vnsi and also tried self compiling from several forks (for example your fernetmenta vnsi5 tree etc), but still no luck.

HD channels work flawlessly but SD channels crash xbmc. Via Live webgui and streamdevserver every channel works. but not with vnsi.


here are my xbmc crashlogs up until the crash:
http://pastebin.com/VbZfi72M

dmesg output:
http://pastebin.com/WLD7thDe

Xorg.0.log:
http://pastebin.com/eNjRFpZa

xbmc debug log from the point of starting a SD channel:
http://pastebin.com/62QuHxrP


can any0ne tell me which versions of vdr-plugin-vnsiserver and xbmc-pvr-vnsi are recommended?

thx in advance
(This post was last modified: 2014-02-06 19:41 by uuzi.)
find quote
Post Reply